Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Internet Musik-Streaming-Server - nicht oversized - aber wie?

Frage Internet Server

Mitglied: peterha

peterha (Level 1) - Jetzt verbinden

13.12.2008, aktualisiert 16.12.2008, 6625 Aufrufe, 13 Kommentare

Mahlzeit!


Ausgangssituation

Habe gerade zu Hause einen Server gebastelt. Nichts kompliziertes XP Pro 32 bit auf mittelmäßiger Hardware mit einer Uptime von 24/7. Macht bei mir Fileserver, Backupserver, Mediastreaming-Server, Webserver, Printserver etc....

Plan

Jetzt würde ich gern noch das meine Musik von außen erreichbar ist und ich sie von zu Hause streamen kann. Also ein Webradio nur für mich. (Bitte schlagt mir jetzt mich vor einen MP3-Player zu kaufen Da ich damit keine anderen Hörer erreichen will muss ich wohl auch keine Gema zahlen.

Was könnte man da machen? Kennt jemand ein Tool mit dem das geht? Ich habe natürlich schon gegooglet aber nicht wirklich etwas gefunden was so toll ist.

Was meint ihr was da gut geeignet wäre?? Wichtig natürlich, dass die Musik nicht zugänglich ist da ich legal bleiben will.

Gruß
Christoph
Mitglied: Devian
13.12.2008 um 20:23 Uhr
klick

sockso ist nett und einfach
Bitte warten ..
Mitglied: peterha
13.12.2008 um 21:55 Uhr
habe das eben installiert und nach außen gemappt. sieht sehr gut aus!

Ich habe aber noch ein problem: wenn ich von einem rechner auf dem internet mich anmelde komme ich immer wieder zu der anmelde seite zurück und werde auf gefordert die daten einzugeben. woran mag das liegen? kann es sein dass das wegen der dyndns adresse so ist? ich habe eine domain auf meine dyndns adresse mit port verlinkt. also domain verlinkt auf http://ftpuser.mine.nu:4444

oder woran?? haste ne idee? auf jedem fall schon mal vielen dank! hammer tool!



Gruß
Christoph
Bitte warten ..
Mitglied: peterha
13.12.2008 um 22:30 Uhr
das mit dem kennwort hat sich gegeben... reboot tut gut.... ABER jetzt hab ich noch das prob dass player fenster aufgeht aber nicht musik spielt!! Wie kann das kommen? format WMA.

Jemand ne idee?

VG
Christoph
Bitte warten ..
Mitglied: Devian
14.12.2008 um 00:45 Uhr
Schau mal in die "encoding" optionen und versuch den recode mit dem integrierten "lame" mit angepasster Rate (128 oder 160, je nach upstream). hab ich auch so gemacht...

btw: 1.1.3 ist nicht die beste version. die 1.1.1 ist mir persönlich sympathischer ;)

Achja: lame muss separat installiert werden (am besten im path)
Bitte warten ..
Mitglied: peterha
14.12.2008 um 21:00 Uhr
mahlzeit!

1.
also ich habe gestern noch rumgespielt. hatte ja keinen ton. dann auf "none" mal gestellt. dann kam ton. ich habe testweise wma to mp3 auf 160 kbps konvertiert. the big aber: der ton stockt leider. ich habe 16 mbit aDSL. das sind real 2 mb download und ca. 130 kb upload. 160 kbit macht doch 20 KByte.

==) Folglich müsste mein Bandbreite doch vollkommen ausreichen!? Es könnten sogar 5-6 Leute gleichzeitig hören.

Wo ist jetzt das Problem??? Wo kann man da noch drehen? Hab mom keine Idee.

2. Lame

Im path? Was meinste damit?? Ich hab gestern gegooglet nach Lame und Download. Hab die Lame dll gezogen und mich dann aber gefragt, wie ich das ihm bei Costum beibringen soll!??!

So schreiben wie in ner batch???

Naja und dann musste ich ins Bett ;)

Viele Dank für die Antworten!!!


Gruß
Christoph
Bitte warten ..
Mitglied: peterha
14.12.2008 um 22:08 Uhr
Zum Beitrag davor: habe es wegen dem Stocken mal runterkonvertiert auf 32 kbps . Und TrOtZdEm tritt das Problem mit dem Streaming auf. Der Ton bleibt für 3 oder auch mal 10 Sekunden mal weg... das ist schade.

was geht da?

vg
christoph
Bitte warten ..
Mitglied: Devian
14.12.2008 um 23:49 Uhr
also scheinbar hast du das mit "lame" hinbekommen. (allerdings ist lame eine exe und keine dll ;) )...

Das Problem mit den Aussetzern hab ich nicht (160er Rate bei dsl6000).. Allerdings ist lame und sockso recht cpu-lastig. hast du mal beim hören einen blick auf die CPU-last geworfen? (insbesondere die "javaw.exe" und "lame.exe")
Bitte warten ..
Mitglied: peterha
14.12.2008 um 23:59 Uhr
hi divian,


die cpu last pendelt zwischen 0 und 18 %. dabei 1-2% auf javaw.exe bei 22 mb ram in nutzung. die maschine ist ne single core 3 GHz 1 GB Ram. Verbrauchen tut se gerade mal die Hälfte an RAM. Wenn die Mugge stoppt ist die Auslastung auf 0 %. Ich werde Sockso mal auf ne andere Maschine bringen und gucken wie die sich verhält.... wenn das Problem weiter besteht können wir ja die Rechner ausschließen als Fehlerquelle.

Richtig? ;)

VG
Christoph
Bitte warten ..
Mitglied: Devian
15.12.2008 um 10:52 Uhr
Richtig. Ist zumindest ein Versuch..

Sag mal Bescheid ob es Erfolg brachte..
Bitte warten ..
Mitglied: peterha
15.12.2008 um 20:28 Uhr
Hi Devian,

habe es nun auf einen anderen Rechner gebracht. Und dort auf eine virtuelle Maschine.

Ich habe eine gute und eine schlechte nachricht... die gute: es geht es ohne das es stockt auch der player wird sofort geladen. die schlechte: es läuft nicht auf meinem eigentlichen server... mist. naja ich werd nen anderen rechner dafür bereit machen. scheiß de*l hardware ;)


--// Ich möchte an dieser Stelle allen Interessenten das Programm Sockso empfehlen \\-- sehr gut!!!

VIelen Dank an Devian für diesem Tipp!

Gruß
Christoph

PS: devian weißt du warum im pop up player immer die alben gezeigt werden die man gar nicht hat??? links das bild mein ich. *grübel*
Bitte warten ..
Mitglied: Devian
15.12.2008 um 21:56 Uhr
Nope, kann ich dir nicht sagen. Ich hab die Album-Anzeige bei mir abgeschaltet (find ich irgendwie unsinnig).. aber guck doch malim (englischen) Forum von Sockso. Der Support dort ist ziemlich gut und recht fix.

Viel Spass mit dem Teil
Bitte warten ..
Mitglied: peterha
15.12.2008 um 23:57 Uhr
hi noch mal...

mhm wo kann man denn die cover disablen???

wo hast du das lame besorgt? (ich habe das gezogen: http://www.chip.de/downloads/LAME_13003295.html)

was soll ich da denn eintragen bei command?? ich müsste sonst alle meine WMA zu MP3 konvertieren...

gruß
Christoph
Bitte warten ..
Mitglied: Devian
16.12.2008 um 00:12 Uhr
Cover disable:
In der GUI auf die KOmmandoebene und dort

propset www.covers.disable yes

eingeben.

Ich glaublame habich damals auch von chip gezogen.. (Läuft einfach, ich weiss nicht einmal weilche Version ich nutze..)

Zum "recoden" einfach in den Encoder-Options "lame" angeben und "160" eintragen. Mehr nicht. Nur die gewünschte Bitrate.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Entwicklung
gelöst Opening port 5080 1935 for Red5 Streaming Server (5)

Frage von MiguelMesa zum Thema Entwicklung ...

Netzwerkgrundlagen
gelöst Heimnetzwerk über Server im Internet und OpenVPN erreichbar machen (16)

Frage von byt0xm zum Thema Netzwerkgrundlagen ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (9)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...