Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Internetseite bei 1und1 nur erreichbar wenn man index.php ergänzt

Frage Internet Hosting & Housing

Mitglied: Bange123

Bange123 (Level 1) - Jetzt verbinden

12.03.2013 um 15:43 Uhr, 3091 Aufrufe, 5 Kommentare

Hallo zusammen,

wir haben unseren Shop online gestellt und nun zeigt sich ein für mich komisches Bild. Wenn ich die Domain www.bla.de aufrufe sehe ich nur die Baustellenseite von 1und1... Wenn ich aber www.bla.de/index oder www.bla.de/index.php eingebe, dann komme ich auf die korrekte Seite.

Ich möchte natürlich schon auf der Seite landen wenn ich nur www.bla.de eingebe. Woran kann das liegen?

1und1 ist der Hoster und die das "Heimatverzeichnis" ist auf den Ordner mit der index.php eingerichtet.

Weil ich bei meinen Recherchen gelesen habe, dass die htcaccess wichtig sein soll hier der Inhalt der selbigen:

  1. RewriteEngine on
  2. RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php

DirectoryIndex index.php

RewriteEngine on
RewriteBase /stallshop/

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/extAdmin/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule .* index.php
Mitglied: langerwo
12.03.2013 um 15:55 Uhr
Hallo,

bitte mal im IE oder im Firefox den Cach leeren und dann nochmals versuchen

Gruß

Wolfgang
Bitte warten ..
Mitglied: Arano
12.03.2013 um 18:16 Uhr
Hallo Bange,

steht das da nicht auch so !?
DirectoryIndex index.php
http://httpd.apache.org/docs/2.2/mod/mod_dir.html


~Arano
Bitte warten ..
Mitglied: Bange123
13.03.2013 um 10:38 Uhr
Zitat von Arano:
Hallo Bange,

steht das da nicht auch so !?
> DirectoryIndex index.php
http://httpd.apache.org/docs/2.2/mod/mod_dir.html


~Arano

Ja steht drin, du siehst ja die htaccess...

Offensichtlich lag das gestern an 1und1 dass noch nicht umgeschaltet war. Heute gibt es viel lustigere Probleme:
Im IE ist die Seite nicht erreichbar, im Firefox und vom Handy aus schon - auch nach dem Leeren des Caches, etc.

Okay und jetzt gerade habe ich den Fehler gefunden: In der htaccess muss es so stehen:

RewriteBase /

und schon ist alles gut, trotzdem danke an alle
Bitte warten ..
Mitglied: 106543
13.03.2013 um 10:41 Uhr
Hi,

bitte noch:
http://www.administrator.de/faq/32

Grüße
Exzellius
Bitte warten ..
Mitglied: Dschinni
26.03.2013 um 16:20 Uhr
Befindet sich vielleicht noch eine index.html im root?

Gruß
Dschinni
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Problem Auslesen einer Internetseite mit Powershell (11)

Frage von c20082005 zum Thema Batch & Shell ...

Exchange Server
gelöst Fehler 208 bei 1und1 (8)

Frage von HeinrichM zum Thema Exchange Server ...

Multimedia
EBook Reader für Internetseiten (3)

Frage von cgicloud zum Thema Multimedia ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 im Unternehmen? (26)

Frage von zorlayan zum Thema Windows 10 ...

LAN, WAN, Wireless
Ping u. DNS geht am Rechner nicht mehr (19)

Frage von Kuemmel zum Thema LAN, WAN, Wireless ...

Festplatten, SSD, Raid
Raid 1 2 SSD mit Windows Server 2016 (17)

Frage von jaywee zum Thema Festplatten, SSD, Raid ...