Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Internetverbindung der Clients über Server herstellen

Frage Microsoft Windows Server

Mitglied: 17735

17735 (Level 2)

21.08.2006, aktualisiert 08.05.2007, 5476 Aufrufe, 16 Kommentare

Hallo,

folgende Situation: Es gibt einen Windows Server 2003 mit zwei Netzwerkkarten. Die Netzwerkkarte A ist mit einem Router verbunden, von dem sie auch per DHCP die IP-Adresse bezieht. Über den Router besteht auch eine Internetverbindung, so dass der Server also über Netzwerkkarte A ins Internet gehen kann.

Die zweite Netzwerkkarte, Netzwerkkarte B ist mit den Clients im Netzwerk verbunden.

Folgendes Problem soll gelöst werden: Die Clients, die über Netzwerkkarte B mit dem Server vernetzt sind, sollen auch über Netzwerkkarte A des Servers ins Internet gehen können.

Dabei sind die Netzwerkkarten auf dem Server wie folgt konfiguriert (symbolisch):

Netzwerkkarte A
IP per DHCP
Standard-DNS-Server: 192.168.2.1 (Router)

Netzwerkkarte B
IP: 186.2.19.1
Sub: 255.255.0.0
Gateway: -
Standard-DNS-Server: 186.2.19.1

Clients
IP: 186.2.19.25 (z. B.)
Sub: 255.255.0.0
Gateway: 186.2.19.1
Standard-DNS-Server: 186.2.19.1

Die physikalische Verbindung besteht also, DNS wird auch richtig aufgelöst, die Clients finden den Server, und können sich auch auf der vorhanden Windows-Domäne anmelden - die DNS-Auflösung klappt bis zum Server also problemlos.

Allerdings können die Clients nicht ins Internet, eine Verbindung der Clients über den Server zum Router ist nicht verfügbar (PING von den Clients an Router schlägt fehl).

Wie kann ich es hinbekommen, dass die Clients also über den Server und die beiden Netzwerkkarten ins Internet kommen können? Hilft da möglicherweise die Netzwerkbrücke von Windows? Wenn ja, wie soll sie konfiguriert werden?

Gruß,
Ahnenforscher
Mitglied: adks
21.08.2006 um 22:36 Uhr
Geht aber auch mit der guten alten Internetverbindungsfreigabe!!!

(Die z.B. auch in Routing und RAS integriert ist)
Bitte warten ..
Mitglied: nacosis
22.08.2006 um 12:47 Uhr
Hallo,

dein Win2003 Server muss als router zwischen den beiden Netzwerkkarten konfiguriert werden.

grüße nacosis
Bitte warten ..
Mitglied: 17735
25.08.2006 um 16:59 Uhr
hallo,

das problem wurde mit hilfe von Routing und RAS gelöst!

Gruß,
Ahnenforscher
Bitte warten ..
Mitglied: yves1979
05.05.2007 um 14:11 Uhr
Hallo,
ich habe ein ähnliches Problem. Der Windows 2003 Server ist mit 2 Netzwerkkarten ausgestattet. Karte A verbindet den Server mit einem Router, der mit dem Internet verbunden ist.

Router-IP: 192.168.0.2,

Servers-IP: 192.168.0.1
Standartgateway: 192.168.0.2
bevorzugter DNS-Server: 192.168.0.2

Karte B stellt die Verbindung zu PC's via eines Switch's her und via eines WLan-Routers zu Laptops.

Server-IP: 192.168.2.1
Standartgateway: 192.168.0.1
bevorzugter DNS-Server: 192.168.0.1

WLan-Router-IP: 192.168.2.2
Standartgateway: 192.168.2.1
bevorzugter DNS-Server: 192.168.2.1

Allen Geräten, inklusive den Clients, wurde eine statische IP-Adresse zugewiesen und befinden sich im selben Subnetz (255.255.255.0). Allerdings erfolgt die Anmledung am Server nicht über eine Domänenstruktur, sondern lediglich über eine Arbeitsgruppe, da auf den Laptops XP-Home installiert wurde.

Nun ist es so, dass alle Geräte sich über Karte B anpingen können und auch im Netzwerk zu sehen sind. Allerdings können die Clients nicht auf das Internet zugreifen. Routing/RAS wurde bereits eingerichtet, mit den Optionen, dass Karte A die Verbindung zum Internet herstellt und Karte B die Verbindung in interne LAN.

Woran kann das liegen?? - Danke!!
Bitte warten ..
Mitglied: IceBeer
05.05.2007 um 14:21 Uhr
Hallo,

generell hast du die obigen Möglichkeiten:
- RRAS
- ICS

Aber, bitte passe deinen IP-Bänder an.
Die 186.x.x.x ist KEINE private Adresse --> sie wird im Internet geroutet --> du kannst Probleme bekommen wenn du eine "Internetadresse" ansprechen willst die in deinem LAN existiert.
http://de.wikipedia.org/wiki/Private_IP-Adresse

MfG IceBeer
Bitte warten ..
Mitglied: yves1979
06.05.2007 um 14:14 Uhr
Hallo,

generell hast du die obigen
Möglichkeiten:
- RRAS
- ICS

Aber, bitte passe deinen IP-Bänder an.
Die 186.x.x.x ist KEINE private Adresse
--> sie wird im Internet geroutet -->
du kannst Probleme bekommen wenn du eine
"Internetadresse" ansprechen willst
die in deinem LAN existiert.
http://de.wikipedia.org/wiki/Private_IP-Adresse

MfG IceBeer


Hallo und Danke soweit für die Antwort.
Mit RRAS habe ich das ganze schon versucht, allerdings hat es den Anschein, dass die Internetverbindung nicht weitergeleitet wird. Vom Server aus kann ich auf das Internet zugreifen, heißt also, dass Karte A die Verbindung zum Internet herstellen kann.
In der Netzwerkumgebung sehe ich auch alle anderen Clients, somit funktioniert die Verbindung von Karte B ins Netzwerk auch.

Trotz der Einrichtung von RRAS, kann ich aber nicht von einem Client auf das Internet zugreifen.

Liegt es vielleicht an den o.g. Konfigurationen??

So langsam bin ich wirklich mit meinem Latein am Ende.
Bitte warten ..
Mitglied: IceBeer
06.05.2007 um 14:41 Uhr
Hallo,

versuch es mal nicht direkt mit dem Internet.
Wie sieht es denn mit dem Ping auf den Router aus???
Fehlt dir eventuell eine Route ins interne LAN, a la:
route add 186.2.0.0 Mask 255.255.0.0 186.2.19.1

Halte es allerdings für möglich das der RRAS Server die nicht private Adresse im internen LAN nicht mag.
Ich würde das evt. mal auf ein "richtiges" LAN Band nachziehen, wenn es ein Klasse B sein muss z.B. 172.16.19.x 255.255.0.0
Die Route müsstest dann natürlich anpassen.

MfG IceBeer
Bitte warten ..
Mitglied: yves1979
07.05.2007 um 14:20 Uhr
Funktioniert so auch nicht, leider. Kann es sein, dass ich einen garvierenden Denkfehler habe?? Ich werde beim Einrichten des RRAS gefragt, welche Karte die Schnittstelle zum öffentlichen Internet herstellen soll. Bisher habe ich dort die Karte angegeben, die mit dem Internet, also mit dem Router verbunden ist. Liegt da vielleicht der Fehler??

Danke nochmals!!
Bitte warten ..
Mitglied: IceBeer
07.05.2007 um 15:26 Uhr
Hallo,

so nu aber. War etwas verwirrt, weil Thema in Thema.
Was funktioniert "so" auch nicht???
Der Server kommt denke ich ins Internet???

MfG IceBeer
Bitte warten ..
Mitglied: yves1979
07.05.2007 um 22:16 Uhr
Hallo,

also ins Internet kommt der server. Ich kann den server vom Router aus anpingen und umgekehrt auch.

Vom Server aus kann ich auch die Clients im LAN anpingen, was auch umgekehrt möglich ist.

Nur stellt der Server eben nicht die Internetverbindung den Clients zur Verfügung, warum auch immer.

Ich werde morgen mal den Server neu aufspielen und dann noch mal alles neu machen, vielleicht hat sich irgendwo was "festgefahren".
Bitte warten ..
Mitglied: IceBeer
08.05.2007 um 07:29 Uhr
Hallo,

was hast du denn sonst noch konfiguriert???
- Öffentliche Schnittstelle
- Private Schnittstelle
- Routen

MfG IceBeer
Bitte warten ..
Mitglied: yves1979
08.05.2007 um 10:44 Uhr
Hallo,

also die öffentliche und die private Schnittstelle hatte ich konfiguriert, das wurde auch vom System so beibehalten.

Ich denke ich habe den Fehler gefunden. Die Einträge bei den statischen Routen werden nicht gespeichert.

Wie muss so eine Route aussehen, nicht dass es daran liegt?

Danke!!
Bitte warten ..
Mitglied: IceBeer
08.05.2007 um 13:21 Uhr
Hi,

also wenn ich nicht ganz daneben liege müsste deine Konfig aussehen wie folgt:
Öffentliche Schnittstelle:
IP: 192.168.0.1
Subnet: 255.255.255.0
GW: 192.168.0.2 (Router)
DNS: 192.168.0.2 (Router)

Private Schnittstelle:
IP: 192.168.2.1
Subnet: 255.255.255.0
GW: ---
DNS: 192.168.0.2 (Router)*

WLAN Router:
IP: 192.168.2.2
Subnet: 255.255.255.0
GW: 192.168.2.1 (private Schnittstelle)
DNS: 192.168.0.2 (Router)*

Client Schnittstelle:
IP: 192.168.2.x
Subnet: 255.255.255.0
GW: 192.168.2.1 (private Schnittstelle)
DNS: 192.168.0.2 (Router)*

*Sollte dein Server auch als DNS Server konfiguriert sein, solltest du hier die private IP des Servers eintragen. Am Server muss dann eine Weiterleitung auf den Router konfiguriert sein.

Am Router brauchst du dann noch eine statische Route damit er weiß, dass alles was ans 192.168.2.x'er Netz soll über an die 192.168.0.1 schickt.
Der Server sollte dann wissen was er damit zu tun hat.
Die Clients haben auch eine 192.168.2.x Adresse nehm ich an oder routet der WLAN Router ein weiteres Netz (z.B. 192.168.3.x)?

MfG IceBeer
Bitte warten ..
Mitglied: yves1979
08.05.2007 um 20:42 Uhr
Halle IceBeer,

1000 Dank, es lag dann wohl an den Routen. Ich habe es jetzt nach Deiner Anleitung konfiguriert und siehe da, die Maschine macht auf einmal was sie soll.

Nun ja, es stimmt also doch...Computer sind nur so intelligent, wie derjenige, der sie bedient... :o(

MfG
Yves1979
Bitte warten ..
Mitglied: IceBeer
08.05.2007 um 21:53 Uhr
Hi,

freut mich dass es geholfen hat....
Dann ist alles klar....

Schönen Abend noch

MfG IceBeer
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Backup
Clients als Server missbrauchen? (21)

Frage von 1410640014 zum Thema Backup ...

DSL, VDSL
OpenWRT VDSL VOIP Internetverbindung herstellen (3)

Frage von danielr1996 zum Thema DSL, VDSL ...

Windows 10
Windows 10 Clients laden Updates nicht von WSUS Server (7)

Frage von Alternativende zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...