Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Intranet-Website wird Internet-Zone zugeordnet - Authentifizierungsfehler HTTP 400

Frage Microsoft Windows Server

Mitglied: michaelolb8004

michaelolb8004 (Level 1) - Jetzt verbinden

19.06.2009, aktualisiert 14:38 Uhr, 13201 Aufrufe, 4 Kommentare

Eine Intranet-Website wird vom Internet Explorer (7 und 8 getestet) nur bei bestimmten Usern der Internet-Zone zugeordnet. Daraufhin wird NTLM statt Kerberos als Authentifizierung benutzt und die Website gibt den Fehlercode "HTTP 400 Ungültige Anforderung" zurück

Hallo zusammen!

Ich muss ein bisschen ausholen.

Wir verwenden einen Internet-Proxyserver (ISA) und eine Proxy.pac zur Konfiguration des Webbrowsers. Es ist der Internet Explorer 7 und 8 im Einsatz. In der Proxy.pac wird festgelegt, dass alle Intranet-Websites den Proxy-Server umgehend. Das funktioniert auch, die internen Websites gehen nicht über den Proxy. Als Zoneneinstellung für das "Lokale Intranet" ist festgelegt "Intranetnetzwerk automatisch ermitteln". Auch das funktioniert prinzipiell gut. Ich habe ein Problem mit einer bestimmten Website im Intranet. Sie lautet beispielsweise "http://meinserver/meinverzeichnis".

Diese Website wird im Internet-Explorer der Zone "Internet" zugeordnet. Dadurch wird nicht die Kerberos-Authentifizierung verwendet, sondern NTLM. Das unterstützt die Website wohl nicht und gibt den HTTP 400-Fehler zurück. Und jetzt wird es ganz skuril: Das Phänomen tritt nur bei einigen wenigen Usern auf - mir sind zwei User bekannt. Wenn diese User allerdings statt des Hostnamens die IP-Adresse des Server eingeben, also beispielsweise http://192.168.100.101/meinverzeichnis - dann geht es! Und dennoch: Es ist kein DNS-Problem. Die Namensauflösung funktioniert tadellos. Die Anfrage kommt ja auch beim Webserver und und läuft auf den HTTP 400-Fehler.

Und es geht noch ein bisschen seltsamer: Egal, was ich versuche und die Site-Einstellung im Internet Explorer manuell mache, d. h. http://meinserver/meinverzeichnis als Site der lokalen Intranetzone hinzufüge, die Site ist und bleibt in der Zone "Internet". Mit dem Firefox lässt sich die Site übrigens ohne Probleme aufrufen.

Ein Problem mit der Website selbst kann es nicht sein. 1000 andere User können die Site aufrufen. Es muss irgendetwas im User-Objekt im AD hängen, dass den Internet Explorer manipuliert. Das Erneuern des lokalen Benutzerprofils hat auch keine Besserung gebracht. Ich bin mit meinem Latein wirklich am Ende.

Vielen Dank im Voraus für die Unterstützung!
Michael
Mitglied: Destry
19.06.2009 um 15:10 Uhr
Hallo Michael,

möglichlicherweise ist eine Group-Policy dafür verantwortlich.
Darüber kann man die Zonenzugehörigkeit steuern. Die Policy würde manuelle Änderungen immer wieder überschreiben.

Gruss,
Destry
Bitte warten ..
Mitglied: clubmaster23
19.06.2009 um 16:33 Uhr
"Wenn diese User allerdings statt des Hostnamens die IP-Adresse des Server eingeben, also beispielsweise http://192.168.100.101/meinverzeichnis - dann geht es! Und dennoch: Es ist kein DNS-Problem."

Anwort selber geliefert: Muss es wohl dann sein. Auch die Antwort, mit Firefox geht es ist einleuchtend.

1. Host.conf vergleichen
2. Firewall-Rules
3. Proxy-Conf
4. Active Directory Conf. --> Rules

Firefox nutzt generell nicht die Einstellungen der Windows-Api (wie einige andere (selbstgebastelter) Browser auch!).

Kann dir leider kein konkreten Rat geben, da ich schliesslich nicht selber vor der Kiste hocke und einfach deine Begebenheiten/Netzwerk nicht wirklich kenne.

Greetz
Bitte warten ..
Mitglied: wbaeck
22.06.2009 um 10:48 Uhr
Hi

Hatte das gleiche Problem und ist nun gelöst. Problem war, dass der Benutzer in zu vielen AD-Gruppen Mitglied war und dieser im http-header field nicht mehr Platz hatten. Hab den IIS auf NTLM-only umgeschalten und dann hat es geklappt.

Lösungsbeschreibung hab ich hier gefunden: http://www.marc-antho-etc.net/blog/post/HTTP11-400-Bad-Request-(Header- ...

Mit dem Befehl: cscript adsutil.vbs set w3svc/1/root/NTAuthenticationProviders "NTLM" konnte ich das Problem lösen.

Gruss,
Wolfgang
Bitte warten ..
Mitglied: michaelolb8004
22.06.2009 um 13:10 Uhr
Danke!

Genau das hat auch hier geholfen! Endlich!
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Webbrowser
gelöst Firefox 50 downloads stocken ohne Internet Verbindung (2)

Frage von LordXearo zum Thema Webbrowser ...

Erkennung und -Abwehr
Port 7547 SOAP Remote Code Execution Attack Against DSL Modems Internet Storm Center (5)

Link von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...