Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Entwicklung PHP

Intranetserver schlechte Performance trotz geringer Zugriffszahl

Mitglied: Dirmhirn

Dirmhirn (Level 2) - Jetzt verbinden

17.12.2013, aktualisiert 18.12.2013, 2033 Aufrufe, 6 Kommentare

HI!

Haben einen kleinen virtuellen Intranet Server laufen - Ubuntu mit LAMP.
Der fadisiert sich eigentlich die meiste Zeit - bzw. eigentlich immer.

das Problem ist aber, dass manche Bilder manchmal extrem langsam (10 Sekunden bei 3 Bildern mit 300x400 px ^^) oder gar nicht geladen werden. Am gleichen Client IE & FF parallel, kann es passieren dass die Bilder in einem Browser in ein paar ms da sind und im anderen ewig hängen.

Apache, Mysql, PHP Logs sind leer. Top gibt auch keinen Prozess aus der hängt oder so. Die Gbit Leitung können die paar Bilder ja auch nicht auslasten.

Die Website, ist recht einfaches "selbst gebasteltes" PHP.

wo könnte ich hier noch ansetzen?

sg Dirm
Mitglied: certifiedit.net
17.12.2013 um 17:16 Uhr
Wie viel Power hat der Server denn?
Bitte warten ..
Mitglied: Dirmhirn
17.12.2013 um 17:22 Uhr
1 GB RAM und 1 CPU auf einem Xeon Quadcore 2,66Ghz
hmm jetzt wo ich das schreibe - könnte vll eine 2. CPU helfen.
da der Server eigentlich wirklich nur paar Bilder ausgibt max 3 User zu gleich, hab ich das nie so beachtet.
Bitte warten ..
Mitglied: TheAndy
17.12.2013 um 19:18 Uhr
Ich denke die CPU sollte eigentlich ausreichen. Ich kenne mehr als genug Leute die das nicht mal an ihrem Desktop haben. Je nachdem welche Festplatte du verwendest kann auch das deinen Server ausbremsen. Eventuell mal mehr RAM, aber ich bin mir nicht sicher ob dir das hilft.

Andy
Bitte warten ..
Mitglied: Alchimedes
17.12.2013, aktualisiert um 20:31 Uhr
Hallo Dirmhirn ,

auch wenn lampp selbst nicht viel Ressourcen braucht , würde ich dem Server mal wenigstens 2 GB RAM gönnen.
Du kannst ja mal auf dem UBUNTU Server via Top/htop die Auslastung anschauen und via iftop die Netzauslastung , während Bilder heruntergeladen werden.

Gruss
Bitte warten ..
Mitglied: szifer
17.12.2013 um 21:03 Uhr
Hi,

hast Du X, Gnome, KDE am laufen? Was sagt top denn zur CPU/Speicher Auslastung? Hast Du mal die tatsächliche Dateigröße der Bilder geprüft? Hab schon "Webdesigner" gesehen, die 300dpi Druckdaten einfach im Dreamweaver oder was auch immer klein ziehen

LG
Bitte warten ..
Mitglied: Dirmhirn
18.12.2013 um 11:21 Uhr
HI!

das is ein "leeres" Ubuntu 10.04.4 LTS. SSH, FTP, LAMP
die Bilder haben 200KB max und es sind max 10 Stück auf einer Seite. Und werden mit einem "normalen" <img...> angezeigt.

Die Bilder sind auch nicht beschädigt - gibt eine PDF-Ausgabe und die funktioniert immer. Es sind auch nicht immer die gleichen Bilder die langsam laden.

wird einmal die Ressourcen verdoppeln. Mehr Power!!

sg Dirm
Bitte warten ..
Ähnliche Inhalte
Benchmarks
Sehr schlechte SSD Performance
gelöst Frage von HenereBenchmarks9 Kommentare

Hallo zusammen, Hardware: ASUS Z10PE 16-WS Xeon 2620 v3 64 GB Reg ECC Ram Samsung 950pro SSD NVMe Im ...

RedHat, CentOS, Fedora
Schlechte RAID Performance
gelöst Frage von plex88RedHat, CentOS, Fedora9 Kommentare

Hallo Zusammen, ich habe für die Arbeit einen kleinen Backupserver gebastelt dieser besteht aus: Intel Core Quad Q8200 2GB ...

Datenbanken
MySQL Abfrage schlechte Performance
Frage von TorstenEDatenbanken7 Kommentare

Ich mache folgende Abfrage Suche alle Artikel in welchem der "Suchbegriff" im Name des Artikels vorkommt oder in 2 ...

Netzwerkmanagement
Schlechte Performance im Heimnetz - Optimierungsmöglichkeiten
Frage von Matthias182Netzwerkmanagement39 Kommentare

Hallo zusammen, ich suche aktuell mal wieder nach etwas Unterstützung, um mein Heimnetz zu optimieren. Der Grund ist, dass ...

Neue Wissensbeiträge
Router & Routing

PfSense als Addon auf QNAP

Information von magicteddy vor 31 MinutenRouter & Routing

Moin, für Spielereien eine ganz nette Idee aber ich fürchte das soetwas auch als echte Firewall genutzt wird: In ...

Datenschutz

Teamviewer kommt für IoT-Geräte wie den Raspberry Pi

Information von magicteddy vor 7 StundenDatenschutz

Moin, jetzt werden IoT Geräte endgültig zur Wanze? Anscheinend kann man auf einem Dashboard seine Geräte visualisieren Ich stelle ...

Microsoft

Letzte Updates für Win10 und Server2016 müssen bei Bedarf über den Update catalogue in den WSUS importiert werden!

Tipp von DerWoWusste vor 12 StundenMicrosoft1 Kommentar

automatisch kommt da nichts an im WSUS und auch nicht im SCCM. Siehe Hinweise zum Bezug der jeweils neuesten ...

Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 3 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Preis für Wartungsvertrag ok?
gelöst Frage von a-za-zNetzwerkmanagement22 Kommentare

Hallo! Mal ne Frage, weil ich mich mit dem akzeptablen Preis für einen Reaktionszeitvertrag nicht auskenne. Meine Firma hat ...

Windows Netzwerk
Ist ein Portforwarding auf einen PC ohne lauschendes Programm ein (großes) Sicherheitsproblem?
Frage von PluwimWindows Netzwerk13 Kommentare

Hallo zusammen, zur Fernwartung eines Rechners an einem anderen Ort nutze ich VNC. Da dieser Rechner einfach nur eine ...

Windows Server
Terminal Server 2016 erkennt Berechtigungen nicht
gelöst Frage von Thomas2Windows Server10 Kommentare

Hallo Administratoren, folgendes Problem stellt sich dar: Es gibt zwei Windows Server 2016, die als Terminal Server fungieren. Jetzt ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS10 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...