Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

IOS am Exchange, Verbindung mit dem Server fehlgeschlagen

Frage Microsoft Exchange Server

Mitglied: Eisern

Eisern (Level 1) - Jetzt verbinden

22.03.2012, aktualisiert 23:45 Uhr, 19080 Aufrufe, 5 Kommentare

Hallo,

ich komme irgendwie nicht mehr weiter. Wir hatten vor einigen Tage einen Komplettausfall unseres Exchange 2010 Servers. Dieser wurde nun neu aufgesetzt und alle bisher angeschlossene iOS Geräte funktionieren auch bestens.

Nun wollte ich neue iOS Geräte (ipad3) an den Exchange anbinden und komme hierbei nicht weiter. Wenn ich das Postfach im ipad einrichte und alle Angaben wie Mailadresse, Server, Benutzer...eingebe, erfolgt auch die Verifizierung und Bestätigung per Haken. Wenn ich nun aber Mail öffne, erhalte ich die Fehlermeldung "E-Mails können nicht empfangen werden Die Verbindung mit dem Server ist fehlgeschlagen"

Nun hatte ich nur selbstsignierte Zertifikate mit lokalen DNS Namen (4Server) welcher so logischerweise aus der Ferne nicht auflösbar wären, also habe ich mich nach folgender Anleitung beigemacht unseren dyndns Eintrag in ein Zertifikat einzuarbeiten.
http://stephan-mey.de/?p=534

Ich habe auch die Bindung an https (IP nicht zugeordnet) mit dem dyndns Zertifikat versehen. Alles leider ohne erfolg.

Was mache ich falsch oder vergesse ich mal wieder vor lauter Bäumen?

Vielen Dank!!!

Gruß, Tom

Edit: Wenn ich mich per OWA über Safari anmelde, klappt alles. Beim Einrichten erhielt ich auch den Hinweis zu dem dyndns Zertifikat was ich akzeptierte.

Edit2: Struktur: W2k8 R2 als AD + W2k8 R2 inkl. HyperV, dort dann Exchange 2010

PS: an einem anderen Exchange funktioniert alles bestens, also Eingaben OK und dann auch Mailempfang
Mitglied: filippg
23.03.2012 um 00:51 Uhr
Hallo,

vielleicht bringt dir ExRCA (https://www.testexchangeconnectivity.com/ ) weitere Erkenntnisse.
Daneben ist mir unklar, was du mit "Dieser wurde nun neu aufgesetzt" meinst. Bzw: wenn er wirklich neu aufgesetzt wurde, wären aus Server-Sicht alle iOS Geräte "neu". Daneben wäre natürlich die obligatorische Frage nach Eventlogs und IIS/HTTP-Logs vom Exchange und ggf. auch Logs auf einem vorgeschalteten TMG/sonstigen Reverse-Proxy noch offen.

Gruß

Filipp
Bitte warten ..
Mitglied: Eisern
23.03.2012 um 07:01 Uhr
Hallo,

Die Konnektivität teste ich gleich wenn drin bin.

Neu aufgesetzt ist in meinem Fall Neuinst W2k8, Exchange und dann die DB wieder eingehängt, ich denke deshalb sind die Geräte noch drin.

Danke, Tom
Bitte warten ..
Mitglied: Antos
23.03.2012 um 08:32 Uhr
Hi,

vielleicht ist es hilfreich mal die Logs des iPads mit zu verfolgen.
Das geht am besten mit dem Tool iPhone Konfigurationstool . Device anstöpseln, und unter "Dein iPad" gibt es ein Tab Konsole.
Ich schätze mal schwer das es ein Problem mit dem Zertifikat ist. Viel Toleranz gibt es beim iOS in der Hinsicht nicht.

mfg
Antos
Bitte warten ..
Mitglied: Eisern
23.03.2012 um 09:51 Uhr
Hallo,

vielen Dank für die Unterstützung.

Ich habe nun mal das ipad Protokoll erstellt. Ich denke ja auch dass das Zertifikat das Problem ist. Im Protokoll steht auch folgendes:

Mar 23 09:35:06 iPad3-TR Preferences[113] <Notice>: 262ac0|EAS|Error|connection died with error Error Domain=NSURLErrorDomain Code=-1003 "Es wurde kein Server mit dem angegebenen Hostnamen gefunden." UserInfo=0xfcb7d20 {NSErrorFailingURLStringKey=https:/unseredomain.de/Autodiscover/Autodiscover.xml, NSErrorFailingURLKey=https://unseredomain.de/Autodiscover/Autodiscover.xml, NSLocalizedDescription=Es wurde kein Server mit dem angegebenen Hostnamen gefunden., NSUnderlyingError=0xfca6930 "Es wurde kein Server mit dem angegebenen Hostnamen gefunden."} 0xe6bfcf0

Klar das er unseredomain.de nicht findet, ich kann kein CNAME Eintrag bei unserem Provider eintragen. Deshalb geht ja auch alles über die dyndns Nummer.

Wenn ich mich über Safari mittels OWA einwähle, wird ja auch das Zertifikat mit der dyndns als nicht vertrauenswürdig angezeigt.

Ich habe nun auch mal das Zertifikat mir auf das ipad gesendet und installiert. Dort steht auch unter alternative Namen alle Adressen drin (also unseredomain.de, dyndns...)

MfG, Tom
Bitte warten ..
Mitglied: filippg
23.03.2012 um 20:07 Uhr
Hallo,

wenn ich das richtig in Erinnerung habe ist iOS bei Zertifikaten sehr großzügig und akzeptiert auch selbst-signierte (deren Root es nicht kennt). Ob der Name auch ignoriert wird weiß ich nicht.
Aber etwas anderes: Die Fehlermeldung die du gefunden hast stammt ja offensichtlich von Autodiscover. Man kann den Servernamen aber auch manuell angeben, dann kann er auch auf eine andere Domain als die SMTP-Domain lauten.

Gruß

Filipp
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Windows Tools

Zeit für Energiesparmodus, Bildschirmabschaltung etc. schnell anpassen

Anleitung von hannsgmaulwurf zum Thema Windows Tools ...

Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(4)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Heiß diskutierte Inhalte
Firewall
Richtige Grundeinstellungen der Pfsense für mein Netzwerk (14)

Frage von Spitzbube zum Thema Firewall ...

Switche und Hubs
gelöst Cisco 2960x Stacking über mehrere Etagen (12)

Frage von b3scher zum Thema Switche und Hubs ...