Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

IP-Datagramme werden verworfen

Frage Microsoft Windows Netzwerk

Mitglied: MichaZ

MichaZ (Level 1) - Jetzt verbinden

29.08.2011, aktualisiert 18.10.2012, 2636 Aufrufe, 8 Kommentare

- 1x Server 2008 als DC
- 1x Server 2008 als FS
- beide als VM auf ESX 4.0
- VM Host angebunden über link aggregation (3x GB LAN)
- andere VMs auf diesen Host laufen ohne Probleme
- PCs Windows XP SP3

Hallo Leute,

ich habe folgendes Problem. In einer größeren Umgebung habe ich einige VMs für verschiedene Dienste laufen. In einem Bereich besteht seit längeren ein große Performance Problem. Das tritt auf, wenn sich ein Anwender am Client anmeldet und sein Profil vom Server geladen wird. Um so mehr User das gleichzeitig tun, um so langsamer wird es und führt bis zum Stillstand. Meldet sich ein Dämonenuser ohne Server Profil an geht es recht schnell. Die Profile sind von der Größer her eher sehr klein. Nach einigen suchen und Testen ( trennen der Dienste auf einen zusätzlichen Server) habe ich folgendes gefunden. Mit der Leistungsdiagnose auf dem Server, konnte man sehen das der Wert " Datagramme verworfen" auf bis zu 100% geht.

Nun die Frage? Wodurch kann das kommen? Schmeißt er die ganzen Pakete einfach weg? Solange bis ein PC mal Glück hat und eins durch kommt?


Danke und Gruß
achiM
Mitglied: aqui
29.08.2011, aktualisiert 18.10.2012
Nur mal so dumm nachgefragt: Die Link Aggregation ist auch auf dem LAN Switch entsprechend konfiguriert ?? 802.3ad mit LACP ?
Ein "show link aggregation" oder "show lacp" zeigt auch wirklich einen aktiven 3er Trunk mit LACP vom Switch zum Server an ??

Oft ist es so das Leute "meinen" sie machen Link Aggregation, tun es dann aber de facto nicht weil Switch (oder NICs) falsch konfiguriert sind mit genau dem Fehlerprofil was du derzeit siehst...?!
http://www.administrator.de/forum/motherboard-mit-2-onboard-lan-anschl% ...
http://www.administrator.de/forum/traffic-am-server-auf-2-nics-verteile ...
http://www.administrator.de/forum/kann-man-einen-server-zur-performaces ...
http://www.administrator.de/forum/bonding-mit-broadcom-slb-117829.html
Bitte warten ..
Mitglied: MichaZ
30.08.2011 um 20:35 Uhr
Hallo "aqui",

das weiß ich so genau nicht! Habe die Konfig für den Netz-Part nicht gemacht.
Aber ich kann da auf jeden Fall noch mal nachsehen. Da Stellt sich aber die
Frage, warum das bei anderen VMs super klappt!?!? Auf dem DC läuft noch
ein Radius-Server. Kann der solche Effekte verursachen? Denke da an
Authentifizierung im Netzwerk. Als ich den Dienst beendet hatte, brachte das
aber auch nix. Laufen tut er für die Anmeldung am WLAN-Netzwerk.

Dank für die Link's!

achiM
Bitte warten ..
Mitglied: aqui
31.08.2011 um 10:31 Uhr
.. ."das weiß ich so genau nicht! " In der IT Welt ist das eine tolle Aussage ! Respekt ! Was erwartest du denn wie man dir zielführend helfen kann und das Problem lösen kann.
Die Konfig des Switches ist bei Teaming oder Link Aggregation mit Servern zwingend wichtig und es ist essentiell sich dort genauestens mit dem Netzwerk Admin abzustimmen. Eben genau aus diesem Grunde eine saubere Link Aggregation zum laufen zu bekommen.
Das es mit den anderen VMs "super klappt" kannst du dann doch gar nicht beurteilen, da du keinerlei Ahnung hast ob der Trunk tatsächlich aktiv ist wenn du die Switch Seite gar nicht kennst !! Du beurteilst das vermutlich nur nach simpler Funktion und ob der Server erreichbar ist, was natürlich völlig unzureichend ist !
Der Radius hat natürlich keinerlei Einfluss, das ist bararer Unsinn, denn die Server Ports werden ja logischerweise so oder so immer aus der Port Authentifizierung ausgenommen.
Das wäre so als würde man vermuten das es Sonntag ist weil es gerade regnet...vergiss das also !
Besorg dir lieber vom Netz Admin einen show Output vom Status des Trunks auf diesem Switch mit "show link aggregation" oder "show lacp" das ist viel sinnvoller und zielführender zum Lösen des Problems !! Das sollte der Netz Admin in 3 Minuten hinbekommen ?!
Bitte warten ..
Mitglied: MichaZ
31.08.2011 um 13:15 Uhr
Hi "aqui",

auch wenn du Recht hast, Ruhe bewahren ! Der Rest der
Umgebung läuft sonst ohne solche Effekte und das seit
einiger Zeit. Ich bin aber auch der Meinung, dass ein Problem
mit dem Teaming auch die anderen VMs betreffen sollte.
In den einzelnen VMs ist diesbezüglich nix eingerichtet.
Diese haben alle nur einen virtuellen 1GB NIC an dem
virtuellen Switch des Hostes verbunden. Die Aggregation
besteht lediglich zwischen virtuellen und physischen Switch.

Werde den NetzMenschen mal darauf hin ansprechen.
Fragen kostet ja nix!

achiM
Bitte warten ..
Mitglied: aqui
31.08.2011 um 16:22 Uhr
...und ist auch der bessere Weg
Lass dir die 802.3ad und LACP Switch Outputs aber zeigen oder als Ausdruck. Weisst ja..."Vertrauen ist gut...Kontrolle ist besser " !
Bitte warten ..
Mitglied: MichaZ
31.08.2011 um 22:27 Uhr
Ja das wohl war ! Habe mich bisher da eher raus gehalten.
Man kann irgendwann nicht mehr auf jeder Hochzeit gleich gut
mit tanzen.
Bitte warten ..
Mitglied: aqui
06.09.2011 um 10:28 Uhr
Wenns das nun war bitte dann auch
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Mitglied: MichaZ
07.09.2011 um 21:11 Uhr
Ja mache ich wenn ich die Lösung habe.
Noch besteht das Problem. Haben jetzt
noch einen Testaufbau gemacht.

VM --> separater NIC (VMHost) --> einfacher Switch --> Kabinett PC

Verspreche mir da zwar nicht viel davon, da
auf dem Stack keine Fehler sind. Aber vor
Ort will man das sehen ohne die Netztechnik.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Erkennung und -Abwehr
Backdoor in IP-Kameras von Sony (3)

Link von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Netzwerke
LAN und WLAN je mit gleicher IP (13)

Frage von dauatitsbest zum Thema Netzwerke ...

E-Mail
gelöst Mail Spam fremde IP (10)

Frage von BerndP zum Thema E-Mail ...

DNS
gelöst Sophos UTM9 - FTP nur über IP erreichbar (4)

Frage von PronMaster zum Thema DNS ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (22)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...