Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

IPhone und Fritzbox 7170 WLan Problem

Frage Netzwerke

Mitglied: Michael-24

Michael-24 (Level 1) - Jetzt verbinden

02.07.2011, aktualisiert 18.10.2012, 8927 Aufrufe, 3 Kommentare

Hallo,

ich habe eine Frage zum Wlan Roaming.

Ich habe eine Fritzbox 7390 im Büro. Diese dient als DSL-Router.

Eine weitere Fritzbox 7390 steht im Wohnzimmer. Beide sind mittels WDS miteinander verbunden.

Die Fritzbox im Büro ist also als Basistation und die Fritzbox im Wohnzimmer ist als Repeater konfiguriert.

Um WDS zu verwenden muss auf beiden Fritzboxen der gleiche Wlan-Kanal eingestellt sein. Desweiteren habe ich auch beiden Fritzboxen die gleiche SSID und den gleichen Netzwerkschlüssel eingestellt. Somit müsste auch Roaming funktionieren, d. h. ein Client verbindet sich automatisch mit der besseren Wlan-Station. Soweit funktioniert die Konfiguration auch schon seit längerem.

Seit einiger Zeit hab ich nun ein iPhone und dieses bereits über WLAN an die Fritzbox gekoppelt.

Aber das Roaming funktioniert irgendwie nicht richtig. Bin ich mit dem iPhone im Wohnzimmer verbindet sich das iPhone logischerweise mit der Fritzbox 7170 im Wohnzimmer. Gehe ich nun ins Schlafzimmer, verbindet sich das iPhone mit der Fritzbox 7390. Das ist auch ok, da diese Box räumlich gesehen, die nähere ist. Aber was nun komisch ist, das das iPhone sich auf der Fritzbox 7170 nicht abmeldet. Es ist also auf beiden Wlan-Station angemeldet.

Ich nun einige Tage rumgespielt und habe folgendes festgestellt.

Wenn es der Fall ist, das das iPhone auf beiden Fritzboxen angemeldet ist, habe ich das Wifi-Modul im iPhone abgeschaltet. Nach ca. 2 Sekunden steht in der Ereignisanzeige der Fritzbox 7390 (Büro). Gerät abgemeldet. In der Ereignisanzeige der Fritzbox 7170 im Wohnzimmer steht dieser Eintrag erst nach 10 Minuten drin. Während der 10 Minuten sieht man das iPhone in der Liste mit den verbundenen Clients (in der Fritzbox unter Menü Funknetz). Schaltet man nach den 10 Minuten das Wifi-Modul im iPhone wieder ein und man befindet sich im Schlafzimmer verbindet sich das iPhone nur mit der Fritzbox 7390, so wie es sein soll! Geht man nun ins Wohnzimmer verbindet sich das iPhone wiederum mit der Fritzbox 7170 und wird von der Fritzbox 7390 abgemeldet. Und hier beginnt das Problem wieder von vorne.

Mein Sat-Receiver ist ebenfalls über eine integrierte WLAN-Karte mit der Fritzbox 7170 im Wohnzimmer verbunden. Auf dem iPhone habe ich eine App, die es erlaubt sich einen Stream eines TV-Programms des Sat-Receivers anzusehen. Das funktioniert aber nur, wenn das iPhone nicht an beiden Fritzboxen angemeldet ist. Ich hab mir eine App (PING) installiert. Ein Ping zum Sat-Receiver ist in dieser Konstelation nicht möglich. Nur wenn das iPhone an einer Basisstation angemeldet ist, funktioniert der Ping und natürlich auch das APP Live Stream.

Was ist an meiner Konfiguration falsch bzw. warum dauert es so lange, das iPhone abzumelden? Ist die Fritzbox 7170 defekt?

Gruß
Michael
Mitglied: aqui
02.07.2011, aktualisiert 18.10.2012
Das ist so wie es aussieht ein Bug in der Repeating Funktion der FritzBox. Das sieht man schon am höheren Timeout ! Hier die Frage ob du auf beiden FBs die aktuellste Firmware geflasht hast ??
Generell ist es keine gute Idee im Medien und Streaming Umfeld auf WDS Repeating zu setzen. Ein Repeater ist sowas wie ein dummer Papagei und sendet zeitversetzt quasi als Relais die Daten an den Ursprungs AP.
Das halbiert schon einmal per se die WLAN Bandbreite durch den dadurch zwangsläufigen Half-Duplex Betrieb. Wenn du noch Störungen und Überlappungen durch Nachbar WLANs hast (von den du mindestens 5 Funkkanäle entfernt sein musst !! Scan macht z.B. der freie inSSIDer ) und mit sog. "Hidden Station" Problemen beim Repeater Betrieb kämpfen musst ist die WLAN Performance meist sehr mickrig.
Besser ist es also immer den 2ten AP (oder ein zum dummen AP kastrierten WLAN Router) nie als WDS Repeater laufen zu lassen sondern immer als eigenständigen AP.
Mit flachem_Ethernet_Kabel kann man auch problemlos Kabel hinter der Fussleiste verlegen.
Falls das auch nicht gehen sollte ist immer noch einen Power LAN (D-LAN) Kopplung der APs erheblich besser als WDS Repeating:
http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...
Bedenke auch das du mit billigen Consumer APs / WLAN Routern nie ein WLAN basiertes Roaming machst, sondern immer ein Client basiertes Roaming. Das basiert meist ausschliesslich auf dem RSSI Wert den der AP an den Client zurückliefert, also nur der Feldstärke und dem Polling Wert wie oft der Client diesne abfragt. Meist ist das Treiber immanent so das du keinerlei Einfluss auf dieses Verhalten hast.
Besser also du baust dein Szenario um in ein distribuiertes WLAN statt Repeating.
Bitte warten ..
Mitglied: Michael-24
05.07.2011 um 00:18 Uhr
Ich habe die zweite Fritzbox im Wohnzimmer nun über dLan verbunden. Das Netzwerkkabel habe ich dann direkt an LAN1 Fritzbox 7170 im Wohnzimmer angeschlossen. WDS bei beiden Fritzboxen ausgeschaltet. SSID und Netzwerkschlüssel bei beiden Fritzboxen gleich eingestellt. Funkkanal habe ich automatisch vergeben lassen. Somit sind die Kanäle auf jeden Fall nicht gleich. Somit müsste doch jetzt das Roaming einwandfrei funktionieren. Tuts aber nicht.

Eigentlich das selbe Problem. Befinde ich mich mit meinem Iphone im Wohnzimmer verbindet sich das Telefon mit der Fritzbox im Wohnzimmer. Wandere ich nun ins Büro, verbindet sich das iPhone mit der Fritzbox im Büro. In der Weboberfläche der Fritzbox Wohnzimmer sieht man aber immer das iPhone als verbunden. Auch der Eintrag in der Ereignisdiagnose "Gerät abgemeldet" fehlt.

Irgendwas stimmt doch mit der Box nicht, oder? Das kann ja jetzt garnicht sein, da ja unterschiedliche Kanäle verwendet werden. Auch wenn die Funkkanäle manuell einstelle, z. B. Funkkanal auf 1 Fritzbox Büro, und Funkkanal auf 6 Fritzbox Wohnzimmer habe ich das gleiche Problem.

Schalte ich wiederum das Wifi-Modul in der Fritzbox ab, erscheint nach ca. 2 Sekunden in der Fritzbox 7390 Büro, Gerät abgemeldet. In der Fritzbox 7170 im Wohnzimmer kommt die Meldung tatsächlich erst 10 Minuten später. Während dieser Zeit, sieht man das iPhone in der Übersicht der Fritzbox 7170 als verbunden.

In den letzten Tagen ist ja eine neue Firmware für die Fritzbox 7170 erschienen. Diese habe ich bereits aufgespielt, brachte auch keine Besserung. Kann das sein, das das integrierte WLan Modul defekt ist. Leider habe ich kein weiteres WLan Gerät, mit dem ich diese Konstellation nachprüfen kann, obs nicht am iPhone liegt, aber ich denke eher an die Fritzbox 7170.

Was kann ich tun? Kennt das Problem jemand von euch?

Gruß
Michael
Bitte warten ..
Mitglied: aqui
05.07.2011 um 10:13 Uhr
Die Funkkanäle solltest du in KEINEM Fall automatisch vergeben lassen, denn das funktioniert bei keinem AP richtig...nichtmal bei den hochpreisigen Premium APs.
Ausserdem ist es auch Blödsinn, denn der AP wählt den Funkkanal dann nur mit der Situation an seinem AP Standort, nicht aber am Standort der Clients wo es eigentlich nur Sinn macht. Vergiss das also und mache das unbedingt immer manuell !!
Du solltest dafür immer einen inSSIDer laufen lassen:
http://www.metageek.net/products/inssider
und zwar dort wo sich auch deinen Clients bewegen.
Hier musst du zwingend darauf achten das dein jeweiliger AP Funkkanal mindestens 5 Kanäle vom anderen AP bzw. AUCH von den benutzen Kanälen ggf. vorhandener Nachbar WLANs im Bereich der Clients entfernt ist !!
Ferner sollte deine SSID einzigartig sein, also niemals die SSID des Herstellers verwenden sondern sowas wie "Bitschleuder" oder "Wurstsemmel" usw. Ohne Sonderzeichen.
Wenn es dann immer noch ein solches Roaming Verhalten gibt kannst du nix machen, denn dann ist das Roaming Client basierend, d.h. wird immer vom Client gesteuert. Bei einem iPhone hast du auf das Roaming Verhalten keinerlei Einfluss dann, da es ein geschlossenes System ist.
Bei vielen Intel Karten kann man im Treiber Setup z.B. "Aggressive Roaming" aktivieren was das Roaming verhalten oft verbessert.
Wirklich sinnvoll und perfekt wird es aber nur mit einem Controller basierten WLAN weil es dann nicht mehr Client bezogen ist !
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Router & Routing
Problem - Router cisco 2821 hinter Fritzbox mit WLAN (23)

Frage von Cyberurmel zum Thema Router & Routing ...

LAN, WAN, Wireless
gelöst Fritzbox 7490 - WLAN Geräte zugriff auf LAN Kamera hinter SONICWALL (25)

Frage von GoriBoy zum Thema LAN, WAN, Wireless ...

Apple
IPhone 6 im WLAN kein Zugriff auf Exchange Server (8)

Frage von montana zum Thema Apple ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (8)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...