Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

IPsec Mobile clients auf Monowall - kein Netzwerkzugriff

Frage Netzwerke

Mitglied: LayerAcht

LayerAcht (Level 1) - Jetzt verbinden

21.02.2011, aktualisiert 18.10.2012, 6485 Aufrufe, 6 Kommentare

Hallo liebe Wissenden!

Ich habe ein Problem mit IPsec auf einer Monowall. Ich möchte mich zu einem Netzwerk über das Internet mit einem Laptop verbinden.
Demnach habe ich in Monowall "Mobile clients" in Verbindung mit einem "PSK" verwendet. Auf dem Client (Laptop) verwende ich "Shrew Soft VPN"
Ich habe alles (dachte ich zumindest) eingerichtet und ich kann mich auch verbinden. Jedoch sehe ich keinen Computer im Netzwerk.
Laut Monowall (Diagnostics -> IPsec) bin ich aber verbunden.
Dann habe ich versucht die Monowall anzupingen. Das funktionierte problemlos.
Ein kurzer Blick auf die Logfiles (Diagnostics -> Logs) verriet mir folgendes:

01.
racoon: ERROR: such policy does not already exist: "192.168.1.0/24[0] 192.168.1.247/32[0] proto=any dir=out" 
02.
racoon: ERROR: such policy does not already exist: "192.168.1.247/32[0] 192.168.1.0/24[0] proto=any dir=in"
Hmm ich tippe auf Firewall...

Also hab ich erst mal google gefragt um zu schauen was es dort alles feines an Informationen gibt.
Dort hieß es in einem Thread, man solle unter Firewall -> Rules den Tab "IPsec VPN" öffnen und die Regel dort eintragen.
Tja, da fängt der Spaß erst so richtig an. Diesen Tab gibt es bei mir nämlich gar nicht.

Scheinbar hab ich auch heute Tomaten auf den Augen, oder ich sollte an meinem freien Tag einfach mal nicht "heimlich" arbeiten und versuchen die VPN Verbindung herzustellen.

Falls irgendwelche Informationen fehlen, kann ich diese gerne angeben.

Ich freue mich schon auf Eure Antworten.

Mit freundlichen Grüßen
Prof-Dr-Train
Mitglied: aqui
21.02.2011, aktualisiert 18.10.2012
Guckst du hier, das sollte dein Problem lösen:

http://www.administrator.de/wissen/ipsec-vpn-auf-m0n0wall-oder-pfsense- ...
und auch hier:
http://www.shrew.net/support/wiki/HowtoMonowall

Sofern du die Clients pingen kannst dann ist IP technisch alles OK. In der Netzwerkumgebung wirst du sie aber niemals sehen, denn wenn die die Namen mit UDP Broadcasts verteilt werden kommt das bekanntlich nicht über geroutete Interfaces was ein VPN ja gemeinhin ist.
Da hilft dann die PC statisch in die lmhosts eintragen:
http://www.administrator.de/forum/xp-home-mit-2-kabelgebundenen-und-wla ...
..oder die nackten IPs aus dem Zielnetz verwenden.
Bitte warten ..
Mitglied: LayerAcht
21.02.2011 um 18:17 Uhr
Danke
die beiden ersten links sind mir bekannt. Meine Konfiguration beläuft sich auf den 2. Link.

Jedoch kann ich nur die Firewall selbst erreichen. Keinen Rechner dahinter. Auch nicht über die IP-Adressen
Bitte warten ..
Mitglied: aqui
21.02.2011, aktualisiert 18.10.2012
Wie immer ist das dann vermutlich ein Problem der lokalen Firewall...
Siehe auch hier:
http://www.administrator.de/forum/mit-2-fritzboxen-eine-lan-to-lan-vpn- ...
Bitte warten ..
Mitglied: LayerAcht
21.02.2011 um 19:35 Uhr
Also die Firewall von dem Rechner, auf dem ich zugreifen möchte?
Diese Firewall habe ich gerade deaktiviert. gleiches Ergebnis.

Hat denn der Ausschnitt (den ich oben angegeben habe) aus dem Logfile der Monowall nichts zu sagen?
Bitte warten ..
Mitglied: aqui
23.02.2011, aktualisiert 18.10.2012
Der besagt das irgendwas mit deiner IP Adressierung nicht stimmt !
  • Hast du das hier beachtet ??
http://www.administrator.de/wissen/vpns-einrichten-mit-pptp-117700.html ...
  • Hast du das Tutorial gelesen ?
http://www.administrator.de/wissen/ipsec-vpn-auf-m0n0wall-oder-pfsense- ...
  • Betreibst du einen Router vor der Monowall und hast das beachtet: ?
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Das gilt übrigens auch für den Client solltest du kein NAT Traversal in der Monowall angeklickt haben !!
Bitte warten ..
Mitglied: LayerAcht
23.02.2011 um 21:46 Uhr
Haha, danke aqui!

Ich wusste ja, dass ich Tomaten auf den Augen habe! Ich sag nur "Goldene VPN Regeln"

Das Problem war ganz einfach und irgendwie auch dumm von mir. Mein Laptop befindet sich in dem Netz 192.168.178.0 und das Netz mit dem VPN Server 192.178.1.0
Sooo, jetzt kommt der GROßE FEHLER: Ich habe in Shrew aber eingestellt, er solle doch bitte die IP-Adresse 192.168.1.247 anstatt 192.168.178.247 benutzten.

Schon komisch... kaum macht man es richtig, funktioniert es plötzlich
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
LAN, WAN, Wireless
IPSec Mobile mit Watchguard M400 funktioniert nicht (1)

Frage von wuurian zum Thema LAN, WAN, Wireless ...

Windows Update
WSUS zeigt max. 69 Clients an (1)

Frage von TheGoodOne zum Thema Windows Update ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (17)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...