Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Netzwerke Router & Routing

GELÖST

IPv4 Fehler durch Switch

Mitglied: Kreativer.Name

Kreativer.Name (Level 1) - Jetzt verbinden

23.08.2014, aktualisiert 20:26 Uhr, 1594 Aufrufe, 10 Kommentare, 1 Danke

Hallo,

Ich habe mir einen Switch gekauft und diesen an meinen Router angeschlossen. Das Problem ist allerdings, dass ich bei allen Rechnern hinter dem Switch keine Verbindung zu dem Router bekomme. Die anderen Clients vor dem Switch sind normal verbunden und kommen auch ins Internet. Wenn ich die Rechner manuell konfiguriere (also IP-Adressen in den Adaptereinstellungen festlege), dann verbinden sie sich normal, aber sonst erhalte ich "nicht identifiziertes Netzwerk".

Bisher ging ich immer davon aus, dass das ein Fehler mit dem DHCP-Server ist, aber als ich versucht habe, mich per Explorer auf einen Client vor dem Switch zu verbinden (\\Client-Name), ging dies erfolgreich. Also habe ich einen ping auf diesen Client ausgeführt und eine IPv6 Adresse angezeigt bekommen. Nun gehe ich davon aus, dass es irgendetwas mit IPv4, dem Switch und dem DHCP-Server zu tun hat, weil ich nur so keine Verbindung bekomme.

Mein Ziel ist es allerdings, dass ich alle Geräte hinter dem Switch per LAN mit dem Router via IPv4 mit funktionierendem DHCP verbinden kann.

Mein Aufbau:
Modem -> Router -> Switch -> 2 Rechner

ps: Es sind mehrere Geräte an den Router angeschlossen, aber diese funktionieren einwandfrei.

Router: TP-Link TL-WR1042ND
Switch: TP-Link TL-SG1005D

Was könnte ich tun?
Mitglied: certifiedit.net
23.08.2014 um 19:25 Uhr
VLAN eingerichtet? Kann natürlich auch sein, dass der Switch direkt defekt ist.
Bitte warten ..
Mitglied: Lochkartenstanzer
23.08.2014 um 19:30 Uhr
Moin,

  • Mal mit ipconfig/all geschaut, ob die IPv4/v6-Konfiguration stimmt?

  • Hast Du geschaut, ob Dein swicth Multicasts korrekt behandelt? manche switche haben Probleme damit.

  • Mal ein nslookup/dig/traceroute losgelassen?

  • einfach mal einen anderen Grabbelkistenswitch von einem anderen herstelelr mal ausprobiert?

lks
Bitte warten ..
Mitglied: Kreativer.Name
23.08.2014 um 19:34 Uhr
Der Switch besitzt keine Webadresse oder so, somit kann ich schlecht ein VLAN einrichten (esseiden ich habe etwas falsch verstanden).
Das der Switch defekt ist, würde ich nicht glauben, weil der erst seit ca. 9 Stunden aus seiner Verpackung ist und der Netzverkehr ja funktioniert, wenn ich statische IPs festlege, die mir der Router erlaubt (also alle unter 192.168.2.100).
Bitte warten ..
Mitglied: Lochkartenstanzer
23.08.2014 um 19:38 Uhr
Zitat von Kreativer.Name:

Der Switch besitzt keine Webadresse oder so, somit kann ich schlecht ein VLAN einrichten (esseiden ich habe etwas falsch
verstanden).
Das der Switch defekt ist, würde ich nicht glauben, weil der erst seit ca. 9 Stunden aus seiner Verpackung ist und der
Netzverkehr ja funktioniert, wenn ich statische IPs festlege, die mir der Router erlaubt (also alle unter 192.168.2.100).

Dann schau mal, ob DHCP ordentlich funktioniert (Wireshark hilft dabei).

lks
Bitte warten ..
Mitglied: Kreativer.Name
23.08.2014 um 20:00 Uhr
Ich weiß nicht genau, worauf ich achten muss, aber ich sehe nur ein "DHCP Inform" und kurz danach ein "DHCP ACK".
Und eine Zeit später dann noch einen Broadcast im Protokoll ARP "Who has IP 169.254.239.37? Tell 0.0.0.0". Und im Protokoll ICMPv6 sehe ich etwas über dem DHCP ein Paar IPv6-Adressen mit "Neightbor Solication".
Ich habe noch nie Wireshark benutzt und ich verstehe eigentlich nichts davon (außer das, was ich mir mein Englisch verrät.)
Bitte warten ..
Mitglied: Lochkartenstanzer
23.08.2014, aktualisiert um 20:10 Uhr
http://de.wikipedia.org/wiki/Dynamic_Host_Configuration_Protocol#DHCP-N ...

Wenn Du nur einen Inform siehst und keinen request, dann ist irgendetwas mit dem DHCP auf dem client bei Dir faul. Wenn dann APiPA-Adressen durch die Gegend flitzen siehst, ist auch etwas faul an Deiner KOnfiguration.

lks
Bitte warten ..
Mitglied: Lochkartenstanzer
LÖSUNG 23.08.2014, aktualisiert um 20:26 Uhr
Nachtrag:

wenn Du wireshark gestartet hast, mach einen ipconfig /release* und einen ipconfig /renew, um zu schauen, ob das DHCP-Protokoll korretk abgewickelt wird.

lks
Bitte warten ..
Mitglied: Kreativer.Name
23.08.2014 um 20:25 Uhr
Das Problem hat sich gelöst, aber ich habe absolut keine Ahnung wie.
Was ich gemacht habe:
- Einen der Rechner direkt an den Router angeschlossen und mit Wireshark aufgezeichnet, was passiert.
- Den gleichen Rechner wieder hinter dem Switch angeschlossen und wieder mit Wireshark augezeichnet und verglichen.
- Die Netzwerkeinstellungen festgelegt, den Rechner aber direkt an den Router angeschlossen (ich bekam aber eine IP mit 169.*.*.* und nicht die von mir definierte
- Alles wieder zurückgesetzt und nochmals mit Wireshark augezeichnet und wider verglichen.
- In cmd "ipconfig /release" und danach "ipconfig /renew" eingegeben. Da kam jeweils eine Menge Text und ein paar Fehlermeldungen am Anfang

An sich würde ich es auf das letzte schieben, aber wie könnte ich den Befehl an einem Linux Computer eingeben? (der andere ist ein Linux-Rechner).
Bitte warten ..
Mitglied: Lochkartenstanzer
LÖSUNG 23.08.2014, aktualisiert um 20:36 Uhr
Zitat von Kreativer.Name:

An sich würde ich es auf das letzte schieben, aber wie könnte ich den Befehl an einem Linux Computer eingeben? (der
andere ist ein Linux-Rechner).

je nach Distribution leicht anderes. Für debin/ubuntu:

/etc/init.d/networking stop 
/etc/init.d/network-manager stop 
/etc/init.d/networking start 
/etc/init.d/network-manager start
lks

PS: Network-manager nur dann, wenn du auch einen benutzt. Sonst nicht.
Bitte warten ..
Mitglied: Kreativer.Name
23.08.2014 um 20:37 Uhr
Dies hat geklappt. Nun haben alle Rechner wieder Verbindung zum Router und Internet.

Vielen dank für die Hilfe.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Ipv4 mieten
gelöst Frage von homermgRouter & Routing23 Kommentare

Hallo Leute, ich bin seit kurzem bei einem Kabelprovider und sitze hinter NAT, das heißt ich kann von aussen ...

Debian
OpenVPN mit IPv6 - IPv4 Support
Frage von Oggy512Debian

Hallo zusammen, inzwischen bin ich auch ein "Opfer" der IPv6 Umstellung von KDG geworden, d.h. mein bisheriger OpenVPN server ...

Linux Netzwerk
OpenVPN mit fester IPv4-Adresse
Frage von devil77cLinux Netzwerk3 Kommentare

Hallo, ich habe einen Server mit sechs zusatzlichen IPv4-Adressen. Openvpn habe ich bereits erfolgreich installiert und es verbindet auch. ...

Router & Routing
IPv4- Route eintragen
gelöst Frage von DianaBauerRouter & Routing5 Kommentare

Hallo! Ich hoffe, hier kann mir jemand helfen! Ich habe eine Fritzbox 7490 die mein Wlan Signal ausgibt. Ich ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 3 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 3 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 3 TagenSicherheit12 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall10 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS9 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen9 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...

Windows Netzwerk
Zugriff auf den Desktop Ordner eines anderen Rechners in der gleichen Domäne
gelöst Frage von JensNomaWindows Netzwerk6 Kommentare

Guten Abend, ich war neulich mit unserem Admin am Tisch gesessen. Er an seinem Notebook angemeldet mit dem Domänen-Admin, ...