Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ISTFEHLER Funktion in Verbindung mit MONAT funktioniert nicht.

Frage Microsoft Microsoft Office

Mitglied: DerParte

DerParte (Level 1) - Jetzt verbinden

15.10.2007, aktualisiert 12:27 Uhr, 5761 Aufrufe, 2 Kommentare

Moin zusammen,

warum funktioniert folgende funktion nicht?

B10=WENN(ISTFEHLER(B9);"";MONAT(B9))

B9 steht das Datum im Format XX.XX.XXXX

Wenn in B9 kein Datum steht das schreibt der dennoch eine 1 statt das Feld B10 leer zulassen.
Mitglied: 8644
15.10.2007 um 09:15 Uhr
Moin,

nimm doch ISTLEER! Wenn nichts drin steht, wird das als 0 interpretiert. Und wenn ich das richtig in Erinnerung habe, beginnt Excel bei 0 zu zählen (1.1.1900).

Psycho
Bitte warten ..
Mitglied: bastla
15.10.2007 um 12:27 Uhr
Hallo DerParte!

Wenn Du tatsächlich nur überprüfen willst, ob in B9 überhaupt etwas steht, dann wie von Psycho Dad vorgeschlagen oder einfach
01.
=WENN(B9="";"";MONAT(B9))
Falls Du aber feststellen willst, ob in B9 ein Datum steht, müsstest Du eine benutzerdefinierte Funktion in VBA erstellen. Dazu mit Alt-F11 in den VBA-Editor wechseln, dort das Menü "Einfügen / Modul" verwenden, um ein neues Modu zu erstellen, und im Codefenster
01.
Function ISTDATUM(V As Variant) As Boolean 
02.
If IsDate(V) Then ISTDATUM = True 
03.
End Function
einfügen.

Ab jetzt hast Du im Arbeitsblatt die Funktion ISTDATUM zur Verfügung und kannst daher schreiben:
01.
=WENN(ISTDATUM(B9);MONAT(B9);"")
Voraussetzung ist dabei allerdings, dass die Zelle auch als Datum formatiert ist.

Grüße
bastla
Bitte warten ..
Neuester Wissensbeitrag
Heiß diskutierte Inhalte
Windows Installation
Eine etwas (wirklich) speziellere Frage: Windows 10-Installation über (11)

Frage von DerFurrer zum Thema Windows Installation ...

Linux
gelöst Boot failed: not a bootable disk (10)

Frage von Fleckmen zum Thema Linux ...

Multimedia & Zubehör
gelöst Iphone 6 prob (8)

Frage von jensgebken zum Thema Multimedia & Zubehör ...

Router & Routing
Cisco887VAW -VPN NAT-Freigabe (8)

Frage von Serial90 zum Thema Router & Routing ...