Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Habe bei Java Probleme mit dem Verlinken..

Frage Entwicklung JavaScript

Mitglied: Andru

Andru (Level 1) - Jetzt verbinden

16.01.2006, aktualisiert 22:12 Uhr, 4530 Aufrufe, 3 Kommentare

Hallo Leute,
erst mal vorab bin net so der Profi in java...

Also folgendes.. Ich bin dabei ein Menü zu erstellen diese aus einer Css-Datei einer Html-Datei und 2 JS-Dateien besteht..
Nun habe ich aber ein Problem mit dem verlinken habe volgenden Quelltext:
______________________________________________________________________________________________
var myMenu = new Array();
myMenu[0] = new Array("L","Menu0"," erster Meüspunkt "," http://www.google.de;);
myMenu[1] = new Array("M","Menu1"," zweiter menüpunkt "," menu1");
myMenu[2] = new Array("L","Menu2"," dritter Meüspunkt "," http://www.diedurstigennachbarn.de;);
myMenu[3] = new Array("L","Menu3"," vierter Meüspunkt "," http://www.lustich.de;);
myMenu[4] = new Array("M","Menu4"," fünfter Meüspunkt "," menu2");
myMenu[5] = new Array("S","","Leerzeile","");
myMenu[6] = new Array("L","Menu5"," sechster Meüspunkt"," http://www.google.de;);

var menu1 = new Array();
menu1[0] = new Array("L","Menü1.1"," Untermenü 1.1 "," http://www.google.de;);
menu1[1] = new Array("L","Menü1.2"," Untermenü 1.2 "," http://www.google.de;);

var menu2 = new Array();
menu2[0] = new Array("L","Menü2.1"," Untermenü 2.1 "," http://www.google.de;);
menu2[1] = new Array("L","Menü2.2"," Untermenü 2.2 "," http://www.google.de;);
menu2[2] = new Array("S","","Leerzeile","");
menu2[3] = new Array("L","Menü2.3"," Untermenü 2.3 "," http://www.google.de;);
_________________________________________________________________________________________________


Die hinten angelegten Links funktionieren nicht.. Habe ich da was vergessen?? Oder geht das ganrnicht so??

Bitte um eure Hilfe
Mitglied: netstorm
16.01.2006 um 14:39 Uhr
Also mit dem Code, den Du gepostet hast, hast Du jetzt 3 Arrays. Wenn das alles an Quelltext ist, dann kann ich da noch kein Menu erkennen.

CIAO Thorsten
Bitte warten ..
Mitglied: Andru
16.01.2006 um 14:47 Uhr
ist ja auch noch net allles!! aber der rest ist nen bisschen mehr!! würde glaube den rahmen strengen!! das menü funktioniert ja auch nur ich kann nix verlinken!!

was muss ich denn dazu tun? kenn mich net soo aus!!!
Bitte warten ..
Mitglied: DerKleineBruder
16.01.2006 um 22:12 Uhr
Zunächst einmal handelt es sich um JavaScript und nicht um Java.

Wenn ich den geposteten Quelltext als 1:1 Kopie deines Originals ansehe, so scheint zumindest
das führende Leerzeichen bei den URLs zuviel zu sein.

Kannst du evtl die Routinen, die du zusätzlich nutzt irgendwo zum Download anbieten,
damit ich mal schauen kann, so das Problem liegt.

Gruß
das Brüderchen
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst SQLExpress Probleme bei Backup (4)

Frage von Alternativende zum Thema Windows Server ...

Linux
Probleme beim Autostart Icewiesel im Vollbildmodus (1)

Frage von Thomas91 zum Thema Linux ...

Microsoft Office
Probleme mit Bilddarstellung im Publisher 2016 (8)

Frage von takvorian zum Thema Microsoft Office ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(2)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (36)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Windows 10
Windows Store Apps ohne Windows Store installieren (10)

Frage von keefien zum Thema Windows 10 ...

Internet Domänen
Nameserver ein Geist? (9)

Frage von zelamedia zum Thema Internet Domänen ...