Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

[Joomla] - Kein PHP-Mailversand nach update von Debian

Frage Linux Debian

Mitglied: Bright

Bright (Level 1) - Jetzt verbinden

02.10.2006, aktualisiert 14:48 Uhr, 6573 Aufrufe, 4 Kommentare

Hallo,

folgendes ist vorhanden:
-Debian Sarge
-Apache2
-Exim4
-PHP4
-->Joomla 1.0.11

Nach Update von Debian Sarge (über apt-get update und apt-get upgrade ) funktioniert der PHP Mailversand nicht mehr.
Ich kann leider nicht mehr das schuldige Update benennen, da der Fehler erst einige Tage später entdeckt wurde.
Der SMTP-Dienst von Exim4 funktioniert ohne Probleme. Ich kann über jeden Client Mails versenden.
Ich denke, dass Problem liegt irgendwo bei PHP.
Ich hab bereits die einträge in der php.ini kontrolliert und scheinen in Ordnung zu sein.

Sobald ich eine Mail in Joomla über den Mailer PHP mail function schicken möchte sagt Joomla Mail erfolgreich versendet.
Leider wird die Mail aber niemals versendet.

Jemand eine Idee?

MfG
Ralf
Mitglied: thekingofqueens
02.10.2006 um 14:23 Uhr
Ist unter Global Configuration - Mail alles richtig eingetragen?
Bitte warten ..
Mitglied: Bright
02.10.2006 um 14:36 Uhr
Meinst du in der php.ini?

bei mir gibt es zwei php.ini
/etc/php4/cli/php.ini
/etc/php4/apache2/php.ini

Bei beiden hab ich folgendes eingetragen bzw war bereits so eingetragen:

[mail function]
; For Win32 only.
;SMTP = localhost
;smtp_port = 25

; For Win32 only.
;sendmail_from = me@example.com

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
sendmail_path = /usr/sbin/sendmail

/usr/sbin/sendmail ist ein symlink auf /usr/sbin/exim4
Da Exim4 mit den befehlen zu sendmail kompatibel sein sollte wäre der Befehl richtig.

In den logfiles von Exim4 taucht beim Mailversand über PHP auch nichts auf.

Gruß
Ralf
Bitte warten ..
Mitglied: thekingofqueens
02.10.2006 um 14:42 Uhr
Nein im Joomla Backend. Du loggst dich ein und schaust mal unter Global Configuration - Mail rein.
Bitte warten ..
Mitglied: Bright
02.10.2006 um 14:48 Uhr
achso...
Ja, da passt alles.
Ich kann dort schon auf sendmail stellen.
Dann klappt die sache auch.
Aber die PHP mail funtction hat doch vor dem update auch funktioniert!?
Ich würde gerne diese funktion benutzen.

Ist kein Joomla problem.
Auf dem selben Server läuft auch Confixx und da hab ich das selbe Problem.
Bitte warten ..
Ähnliche Inhalte
Windows 10
Nach Anniversary Update kein Bluetooth Pairing möglich (4)

Frage von schuhmann zum Thema Windows 10 ...

Windows Update
Windows Update - WSUS und kein Ende (12)

Frage von the-buccaneer zum Thema Windows Update ...

Microsoft Office
gelöst Nach Office 2010 SP2 Update - Kein Sharepoint export zu Access möglich (1)

Frage von paddl82 zum Thema Microsoft Office ...

CPU, RAM, Mainboards
Nach BIOS Update - kein Bild, keine Tastatur, keine Maus (7)

Frage von PronMaster zum Thema CPU, RAM, Mainboards ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(6)

Anleitung von BassFishFox zum Thema Windows 10 ...

Heiß diskutierte Inhalte