Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Joomla - kein Zugriff auf das backend nach upload

Frage Internet CMS

Mitglied: marco-b

marco-b (Level 1) - Jetzt verbinden

21.12.2010 um 01:41 Uhr, 7985 Aufrufe, 9 Kommentare

Nach dem upload von Joomla habe ich keinen Zugriff auf das backend.
Ich hatte die Seite lokal auf meinem Rechner aufgebaut und anschließend hochgeladen.
Die Seite wird aufgerufen, beim starten des Administrationsbereiches komme ich aber nicht über die Anmeldemaske hinweg.

Nach langen Recherchen im Internet habe ich bisher folgendes probiert:

Das Passwort des Administrators (ID62) in des Datenbank neu gesetzt (nicht Klartext, sondern verschlüsselt).
Den Inhalt der Datenbanktabelle jos_session gelöscht
Cookies gelöscht

Eine Sache fällt ebenfalls noch auf:
Bein Laden der Startseite bzw. der Unterseiten erscheint oben links auf dem Bildschirm folgende Zeichenfolge:


Hat jemand eine Idee, was ich noch machen kann?

Vielen Dank im Voraus
Marco
Mitglied: Tommy70
21.12.2010 um 06:53 Uhr
Hallo

Da du die Seite lokal aufgebaut und hochgeladen hast vermute ich mal, dass deine Konfiguration nicht korrekt ist.
Hast du die Konfiguration endsprechend angepasst?
MySQL, Pfade, Domain usw.
Bitte warten ..
Mitglied: marco-b
21.12.2010 um 08:05 Uhr
Da dies meine erste Joomla Installation ist, habe ich mich an die Anweisungen unter gehalten.
Folgende Einträge habe ich in configuration.php im Bereich /* Database Settings */ geändert:

var $host = 'localhost';
var $user = 'root';
var $password = '';
var $db = 'joomla';

Die erwähnten Zeichen () bleiben stehen, wenn ich im Browser configuration.php aufrufe

Viele Grüße
Marco
Bitte warten ..
Mitglied: Tommy70
21.12.2010 um 08:10 Uhr
Nett, aber ob die Einstellungen so stimmen kann man von hier aus schwer sagen ;)
Läuft MySql wirklich auf localhost?
Hat der Benutzer wirklich kein Passwort?

Wieso machst du nicht einfach eine normale Online Installation?
Bitte warten ..
Mitglied: marco-b
21.12.2010 um 08:25 Uhr
Das waren die Joomla-Vorgaben. Ich hatte nicht vor, hier die Datenbankzugangsdaten zu veröffentlichen.
Bitte warten ..
Mitglied: Tommy70
21.12.2010 um 08:29 Uhr
Das ist schon klar, dass du uns nicht die wirklichen Daten geben sollst.
Aber du könntest meine Fragen trotzdem beantworten.

Läuft MySql wirklich auf localhost?
Hat der Benutzer wirklich kein Passwort?

Wieso machst du nicht einfach eine normale Online Installation?
Bitte warten ..
Mitglied: marco-b
21.12.2010 um 09:15 Uhr
Zitat von Tommy70:
Das ist schon klar, dass du uns nicht die wirklichen Daten geben sollst.
Aber du könntest meine Fragen trotzdem beantworten.

Läuft MySql wirklich auf localhost?
var $host = 'dbxxx.yyy.de';
Hat der Benutzer wirklich kein Passwort?
var $password = 'gibbutterbeidiefische'; (ist nicht das richtige Passwort)

Wieso machst du nicht einfach eine normale Online Installation?
Die homepage lief schon und ich wollte mich erst einmal mit php und Joomla vertraut machen.

Gruß
Marco
Bitte warten ..
Mitglied: Tommy70
21.12.2010 um 09:30 Uhr
Schau dir mal diese Seite an. Vielleicht hilft dir das weiter.
Bitte warten ..
Mitglied: Fenian
21.12.2010 um 10:23 Uhr
Die Zeichenfolge sieht mir sehr nach Byte Order Mark aus.
Dein Editor sichert scheinbar die Dateien in UTF-8 mit BOM.

BOM führt unter ISO 8859-1 zur Ausgabe von  und verhindert unter PHP z.B. das ändern von HTTP-Headern

Prüfe mal die Kodierung deiner Dateien und speichere sie ggf. ohne BOM.
Bitte warten ..
Mitglied: marco-b
21.12.2010 um 13:47 Uhr
Hallo Fenjan

wow, das hat gepaßt!
Der BOM hat sozusagen für den BOOM gesorgt.
Mit notepad++ konnte ich das Problem lösen.

Danke an alle
Marco
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Apache Server
Joomla - Aktualisierung über das Backend möglich? (3)

Frage von FA-jka zum Thema Apache Server ...

Windows Tools
Automatischer FTP-Upload ohne angemeldeten Benutzer (5)

Frage von SarekHL zum Thema Windows Tools ...

Netzwerke
gelöst Zugriff auf Server von verschiedenen VLANs aus (7)

Frage von Kroeger02 zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (22)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...