Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Katastrophale Schreibperformance im Raid 10 - P410 265MB BBWC

Frage Hardware Festplatten, SSD, Raid

Mitglied: SamuelBln

SamuelBln (Level 1) - Jetzt verbinden

03.09.2013 um 16:19 Uhr, 5811 Aufrufe, 18 Kommentare, 2 Danke

Hallo zusammen,

hier meine Konfig:
- HP ProLiant SE316M1 (=DL160 G6)
- 32 GB Ram
- P410 265MB+BBU (Cache aktiviert)
- 4x 1TB WD VelociRaptor (WDC WD1000DHTZ-0)
- Raid 1+0
- Windows Server 2012 Standard

Alle Treiber und Firmware Versionsstände sind aktuell. Am Controller hängen die 4 SATA Platten im Raid 1+0. Die Leseperformance ist nicht zu beanstanden. Nur beim Schreiben fällt die Performance plötzlich extrem. Kopiere ich eine große Datei lokal, so bewegen sich die Transferraten zwischen 0-30MB/Sek. Hat jemand eine Ahnung, was ich übersehen haben könnte?

Dank & Gruß,
Samuel
Mitglied: ollioe
03.09.2013 um 16:23 Uhr
Hallo Samuel,
hast du die Cache Einstellung, Prozentuale Aufteilung Read / Write, überprüft?
Ansonsten würde ich über das ACU einen Bericht erstellen lassen
Bitte warten ..
Mitglied: SamuelBln
03.09.2013 um 16:39 Uhr
Hallo Olli,

die R/W Ratio ist 25/75. Hier der ACU Report:

https://www.dropbox.com/s/b2vdc1yn53nfuzd/report-6073db19-00000980-00000 ...

Grüße,
Samuel
Bitte warten ..
Mitglied: ollioe
03.09.2013 um 17:36 Uhr
Hi,
im Log nix zu sehen, Config sieht gut aus, Firmware ist auch aktuell.

Bei so schlechten Werten, wobei jede einzelne HDD bei dir schneller wäre, liegt es wohl am Controller.
Habt ihr "nur" das 256 MB Pack installiert oder liegt da schon der Hund begraben? Erkannt werden 256.
Ich kenne die P4x Reihe nur mit 512MB, daher die Frage.

Dinge wie Virenscanner etc. werde ich wohl nicht ansprechen müssen.
Wie sieht es beim Kopieren von Mediadaten aus, ist es dann genau so lahm?
Mir fällt derzeit nicht mehr ein, sorry.
Bitte warten ..
Mitglied: hmarkus
03.09.2013 um 19:59 Uhr
Guten Abend,

ich bin kein Experte für RAID, aber Du schreibst, dass Du lokal kopierst. Also von dem RAID liest und gleichzeitig darauf schreibst. RAID 10 ist ein gestripter Mirror, also wird von allen Platten gleichzeitig gelesen während darauf geschrieben wird. Nach meinem Verständnis kann das kaum schneller sein, als das Kopieren einer Datei auf ein und der selben Festplatte (ohne RAID).

Als Vergleich kopiere mal eine große Datei z.B. von einer SSD auf das RAID (über SATA III oder am besten PCI-e). Dann sollte es besser klappen und zeigen, dass alles in Ordnung ist.

Markus
Bitte warten ..
Mitglied: psannz
03.09.2013 um 20:26 Uhr
Sers,

noch ne kleine Frage: Da es ein 2012er Windows Server ist: Sind Storage Spaces involviert?

Grüße,
Philip
Bitte warten ..
Mitglied: SamuelBln
04.09.2013 um 09:05 Uhr
@Olli: Kein Virenscanner aktiv.
@Markus: Da hast Du schon recht. Allerdings habe ich auch ATTO DIsk Benchmark laufen lassen. Die Schreibrate ist wirklich mies.
@Phillip: Storage Spaces sind nicht involviert. Lediglich die Datendedublizierung habe ich aktiviert.

Der Schreibvorgang startet erst sehr schnell. Hier wird vermutlich der Cache gefüllt. Dann fällt er aber plötzlich ab und pendelt sich bei 30MB/Sek ein. In Foren liest man nur von schlechter Performance beim P410 ohne BBU ... Ich habe keine Erklärung für dieses Problem. Liegt es evtl. an den Festplatten?
Bitte warten ..
Mitglied: ollioe
04.09.2013 um 09:16 Uhr
Die Festplatten sind doch eher eben nicht das Problem, die sind im Einzelbetrieb "sauschnell".
Laut deinem Bericht ist der Cache voll. Da liegt dein Verdacht sehr nahe, das die 256 MB eine zu geringe Kapazität haben.
Der BBU Cache ist voll und ab diesem Zeitpunkt sinkt die Performance.

Auch denkbar wäre, bei deiner Teststellung, dass durch den Kopiervorgang auf dem gleichen Volume sich die 25/75 Ratio "rächt".
Ich würde es testweise auf 50/50 stellen und erneut probieren.

Wie sieht es denn bei Schreibvorgängen über LAN aus? Im Gigabitnetz ist es übrigens empfehlenswert im LAN Adapter das IPV6 Protokoll zu deaktivieren, bei uns zumindest führte das aktiviert V6 zu einer sehr langsamen Verbindung.
Bitte warten ..
Mitglied: SamuelBln
04.09.2013 um 09:42 Uhr
Es gibt eine Neuigkeit. Ich habe mein System in 2 Partitionen aufgeteilt. Die Erste (Systempartition) ist rund 97,3 GB groß. Die Zweite (Datenpartition) ist 1,62 TB groß. Interessanterweise treten die Performanceprobleme bei der ersten Partition nicht auf! Hier kann ich mit 900MB/Sek ein 7GB Image lokal kopieren. Das selbe File führt bei der Zeiten Partition zu einem Performanceeinbruch nach einigen Sekunden. Beide Partitionen sind identisch formatiert. Muss ich bei großen Partitionen (>1TB) etwas bezüglich der Größe der Zuordnungseinheit beachten?

Bytes pro Sektor : 512
Bytes pro physischem Sektor : 4096
Bytes pro Cluster : 4096
Bytes pro Dateidatensatzsegment : 1024
Bitte warten ..
Mitglied: ollioe
04.09.2013 um 10:04 Uhr
AFAIK wirkt sich das Disk Alignment enorm auf die Performance aus.
Daher formatiere ich immer über Diskpart und nicht die GUI.
Um gute Werte zu erzielen siehe z.B.: http://www.techpowerup.com/articles/other/157

In Bezug auf Server Partitionen: http://serverfault.com/questions/175034/64k-cluster-size-for-sql-server ...
Bitte warten ..
Mitglied: SamuelBln
04.09.2013 um 10:54 Uhr
@ollooe: Danke für den Hinweis. Aber was ist denn nun die optimale Größe der Zuordnungseinheit bei einer 1,62TB Partition? Die Eckdaten scheinen bei mir zu stimmen ... Wie sind denn deine Erfahrungen? Ich will keine SQL Server Logfiels oder Datendateien auf der Partition unterbringen. Vielmehr soll sie zum Unterbringen von Office und Mediafiles (30KB - 4GB) dienen und 2-3 (meist Idle laufende) VMware VMs dienen. Hast Du eigentlich die Windowsseitige Komprimierungsoption auf deinen Datenlaufwerken aktiviert?
Bitte warten ..
Mitglied: ollioe
04.09.2013 um 11:10 Uhr
Wow, es gibt so viele Konstellationen die wir hier bei uns betreiben und ich prügel mich regelmäßig mit diesen Werten rum bis es ordentlich läuft.

Den Ansatz für SQL verwende ich gerne wenn es um intensive Operatoren geht, also bei richtig vielen Zugriffen. Auch eine reine Datenhalde kann in die Knie gezwungen werden wenn massig User gleichzeitig zugreifen.

Als Stripe Size nehme ich für Data Partitionen immer die größte verfügbare, max. 128.
Als Cluster Size 4096, wie bei dir auch eingestellt. Lediglich das Alignment muss / sollte man immer manuell per Diskpart übernehmen, nach der Kalkulation in dem ersten Link.
Das bestehende offset kann man sich bequem in diskpart anschauen, ist es nicht optimal bleibt leider nur neu zu partitionieren.

Bei dem Einbruch in eurem System scheint es doch das die Daten immer neu angeordnet werden müssen und dadurch die Verzögerung eintritt.
Nachvollziehbar, in so drastischer Form, ist es aber nicht.
Bitte warten ..
Mitglied: SamuelBln
04.09.2013 um 11:39 Uhr
OK, ist stelle gerade fest, dass ich auf der falschen Fährte war. Ich hatte in einer schlechten Quelle gelesen, dass es sich anbietet, die Windowsseitige Kompression von Dateien auf einer Partition zu aktivieren. Hier scheint der Bottleneck gelegen zu haben. Nachdem ich die Kompression auf der Datenpartition deaktiviert hatte, lief alles wieder reibungslos. Nichtsdestotrotz ist die Idee einer serverseitigen Kompression (zumindest von Office Files) sinnvoll. Verwendet Ihr so etwas?
Bitte warten ..
Mitglied: ollioe
04.09.2013 um 12:17 Uhr
Nope, haben wir noch nie aktiviert
Bitte warten ..
Mitglied: SamuelBln
04.09.2013 um 13:41 Uhr
OK, dann lasse ich dann mal lieber die Finger davon. Danke euch allen für die Unterstützung.
Bitte warten ..
Mitglied: kontext
05.09.2013 um 07:23 Uhr
Zitat von SamuelBln:
Danke euch allen für die Unterstützung.
Moin SamuelBln,

bitte noch die Frage als gelöst markieren: http://www.administrator.de/faq/32/

Gruß
kontext
Bitte warten ..
Mitglied: mad-manne
17.09.2013 um 12:51 Uhr
Hallo und sorry, dass ich mir hier einklinke ... ABER dein Problem scheint ja mittlerweile gelöst zu sein

Ich habe vor den gleichen HP ProLiant SE316M1 gebraucht zu kaufen und wollte mal fragen, ob du irgendwelche Probleme mit Treibern für das Gerät hattest?

Hier ( http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang ... ) ist zwar nur die Rede von WinServer 2008 x64 die Rede, aber wenn du das Teil mit Win2012 ans Laufen bekommen hast, dann sollte ich mit Server 2008 R2 eigentlich auch keine Probleme bekommen?!

Kannst du (oder andere) sonst etwas anführen, weshalb man den Server nicht unter Win2008 R2 betreiben sollte?

Vielen Dank,
Manne.
Bitte warten ..
Mitglied: SamuelBln
18.09.2013 um 08:53 Uhr
@mad-manne: Mit 2008 R2 solltest du keine Probleme bekommen. Ich habe mir trotzdem alle aktuellen 2012 zertifizierten Treiber "händisch" raussuchen müssen. Die BBU ist standardmäßig nicht dabei - am besten gleich mit bestellen.
Bitte warten ..
Mitglied: mad-manne
18.09.2013 um 13:42 Uhr
Hallo Samuel,
Danke erstmal für deine Antwort
Darf ich so unverschämt sein und fragen, ob du zufällig noch die Links zu den 2012-Treibern irgendwo parat hast?

Ich schwanke nämlich noch, ob ich von meinem Downgrade-Recht Gebrauch machen soll(also 2008R2 installieren), oder evtl. doch gleich 2012 installieren soll.

Liebe Grüsse nach Berlin(?!),
Manne.
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Festplatten, SSD, Raid
Vergleich zweier SSD-Typen im Raid-10 für den Anwendungsfall SQL-Datenbank (8)

Frage von DerWoWusste zum Thema Festplatten, SSD, Raid ...

Festplatten, SSD, Raid
gelöst Software RAID 10 mit bester Perfomance (7)

Frage von ketanest112 zum Thema Festplatten, SSD, Raid ...

Server-Hardware
gelöst Korrekte Konfiguration RAID 10 (9)

Frage von takvorian zum Thema Server-Hardware ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (17)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...