Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Kleinen Problem mit focus()

Frage Entwicklung JavaScript

Mitglied: Letavino

Letavino (Level 1) - Jetzt verbinden

01.04.2011, aktualisiert 12:10 Uhr, 4276 Aufrufe, 4 Kommentare

Guten Tag,
ich bin dabei, mit ein paar kleinen Details meine in PHP programmierte Seite zu verbessern.
Da ich sonst meist versucht habe, alles möglichst ohne JS zu lösen, stoße ich hier auf folgenden Problem:

Ich möchte beim Laden einer bestimmten PHP Seite einen Fokus auf ein Eingabefeld legen.
Dabei wäre es schön, alles was mit der speziellen Seite zutun hat auch in der gleichen PHP Datei stehen zu haben.
Mein Versuch klappt aber leider nicht, obwohl andere Funktionen von JavaScript (zb: onmouseover) funktionieren.

01.
echo
02.
          <div id="suche"
03.
                    <script> 
04.
                                <!-- 
05.
                                document.suchform.suche.focus(); 
06.
                                 // --> 
07.
                    </script> 
08.
                    <form method="post" name="suchform"
09.
                             <input type="text" name="suche"
10.
                             <input type="submit" name="suchen" value="Suchen"
11.
                    </form> 
12.
           </div> 
13.
';

Wo liegt mein Fehler?
Oder ist es unumgänglich Funktionen im HEAD zu formulieren?

Lg, Florian
Mitglied: nxclass
01.04.2011 um 14:13 Uhr
Das Problem wird sein, dass das Formelement beim Ausführen des JS codes noch nicht existiert.
01.
window.onload = function() 
02.
03.
 document.suchform.suche.focus(); 
04.
}
Erst wenn die Seite aufgebaut ist, kann man sicher sein auch auf ein Element zugreifen zu können.
Bitte warten ..
Mitglied: Letavino
01.04.2011 um 14:26 Uhr
Hört sich sinnig an.
Und 'onload' lässt die Funktion erst nach beenden des Seitenaufbaus starten?

Leider funktioniert es immernoch nicht.
Könnte es vielleicht mit dieser Zeile aus der Index zusammen hängen?

01.
<body onload="javascript:self.focus();document.form_select.str_filter.focus()">
Bitte warten ..
Mitglied: nxclass
02.04.2011 um 15:04 Uhr
ja - das überlagert sich dann ... lass es mal weg das onload Attribut.
Bitte warten ..
Mitglied: Letavino
05.04.2011 um 10:57 Uhr
Tut mir leid, dass ich erst jetzt antworten kann, aber ich bin erst heute wieder an der Arbeit um deine Idee zu testen.

Es funktioniert nun soweit alles, ohne Probleme.
Es scheint wirklich daran gehangen zu haben.

Vielen Dank für deine Hilfe!

Lg, Florian
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
Cisco 2951 VPN Problem (3)

Frage von Serial90 zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2013 Outlook 2013 Autodiscover Mailbox Problem (GUID) (4)

Frage von Systembastler zum Thema Exchange Server ...

SAN, NAS, DAS
gelöst Synolgy 1815+ - Rechte- und Richtlinien-Problem User-Ordner Home (3)

Frage von Nintox zum Thema SAN, NAS, DAS ...

Peripheriegeräte
Roccat Ryos - Support verzweifelt an Problem mit Profilen

Frage von sascha382 zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Erkennung und -Abwehr
Virenschutz - Meinungen (29)

Frage von honeybee zum Thema Erkennung und -Abwehr ...

Windows 10
gelöst Welches OS für Firmengeräte? (20)

Frage von MarkusVH zum Thema Windows 10 ...

Netzwerke
Abisolierwerkzeug (18)

Frage von SarekHL zum Thema Netzwerke ...

Exchange Server
SBS2011: POP3-Connector 10 MB Grenze Email Benachrichtigung (17)

Frage von bogi1102 zum Thema Exchange Server ...