Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kniffeliges Problem mit VPN Verbindung zu Vista Business über Linksys WAG200G

Frage Microsoft Windows Netzwerk

Mitglied: Charalambos

Charalambos (Level 1) - Jetzt verbinden

02.06.2008, aktualisiert 01.07.2008, 10030 Aufrufe, 10 Kommentare

Kniffeliges Problem bei dem Verbindungsaufbau einer VPN zu Windows Vista Business über einen Linksys WAG200G Router.

Hallo Miteinander

Ich ärgere mich seit geraumer Zeit mit einem Problem, dass so kniffelig ist, dass ich auf eure Hilfe angewiesen bin.

Es geht um den Aufbau einer VPN Verbindung von zu Hause aus in das Büro. Der Zielrechner ist mit Vista Business bespielt und entsprechend für den Aufbau einer VPN Verbindung eingerichtet - d.h. es besteht ein Benutzer mit Einwählrechten sowie ein eingehende VPN Verbindung.

Der Router ist von Linksys, das Modell ist ein WAG200G der bereits entsprechend konfiguriert ist.

Soweit so gut, bei dem Anwählen handelt es offensichtlich soweit alles aus, der einwählende Rechner ist auch auf dem besten Weg sich einzuwählen, aber kurz vor dem endgültigen aushandeln der Verbindung erscheint folgende Fehlermeldung:

Netzwerkprotokollverbindungen werden überprüft...

TCP/IP CP gemeldeter Fehler 52: Verbindung wurde nicht hergestellt, weil ein identischer Name im
Netzwerk schon vorhanden ist. Wählen Sie "System" in der Systemsteuerung, um den Computernamen zu
ändern, und versuchen Sie es erneut.

Das ist natürlich grober Unfug, da der einwählende Rechner, sowie auch der andere im lokalen Netzwerk angeschlossene Rechner, nicht den selben Namen aufweist.

Google spuckt dazu leider nichts hilfreiches aus, aber ich bin mir sicher jemand von Euch kennt die Lösung oder hat ein paar Tipps für mich!

Danke in jedem Fall für die Hilfe.
Mitglied: aqui
03.06.2008 um 10:39 Uhr
Das Problem ist nicht kniffelig sondern ganz banal und kommt zuhauf täglich hier im Forum vor.
Leider versäumst du uns ja mitzuteilen WELCHES VPN Protokoll du benutzt so das wir nun zum Raten im freien Fall gezwungen sind
Da es Windows ist, verwendest du vermutlich das PPTP Protokoll für dein VPN.
D.h. du musst beim Server den Port TCP 1723 und das GRE Protokoll (Prot. Nr.: 47) in die Port Weiterleitungsliste auf die lokale IP des Servers eintragen, andernfalls können die vom Client eingehenden PPTP Packete nicht die NAT Firewall der Serverseite überwinden und werden dort geblockt, mit der Folge das deine VPN Verbindung wie oben beschrieben hängt...
Das die Zieladresse des einwählenden Rechners die öffentliche IP des WAG Routers ist sollte dir ebenfalls klar sein ! Sofern sie nicht statisch ist kannst du sehen welche das ist wenn du mal auf die Seite www.wieistmeineip.de gehst.
Langfristig ist es bei einer nicht statischen DSL IP ratsam einen DynDNS Account auf dem Router zu aktivieren !! Der WAG bietet diese Möglichkeit im Setup !

Wenn du das entsprechend in der PWL des WAG konfigurierst sollte es auf Schlag klappen. Nähere Infos dazu gibt dir auch:

http://www.wintotal.de/Artikel/vpnxp/vpnxp.php

Ist zwar XP aber der Mechanismus und die PWL sind genau gleich wie bei Vista !!!
Bitte warten ..
Mitglied: Charalambos
03.06.2008 um 15:50 Uhr
Hallo

So banal ist das Problem aber nicht, denn ich habe schon so gut wie alle verfügbaren Artikel die über das große G zu finden sind durchgekaut.

Natürlich verwende ich den Dienst DynDNS und das PPTP Protokoll, ich habe auch den Port 1723 (TCP) direkt auf die interne IP (192.168.1.100) des Rechner weitergeleitet, aber das nützt nichts.

Das Einzige was mir nicht ganz klar ist, ist das GRE Protokoll. Wo soll ich das eintragen? Da sind nirgends Einstellungen zu machen und soweit ich es in Erinnerung habe, wird dies automatisch durch die Weiterleitung des TCP 1723 Ports gesteuert - wenn ich falsch liege lasse ich mich gerne korrigieren.
Bitte warten ..
Mitglied: aqui
04.06.2008 um 13:46 Uhr
Ja, das ist richtig. Einige Router machen das, diese Funktion nennt man dann VPN Passthrough wenn TCP 1723 in der PW Liste steht. Das solltest du aber verifizieren. Wie, das steht unten.

Du solltest aufgrund der statischen IP Adressbeziehung die du nun mit der PWL hast keine dynmaischen DHCP Adressen dem Zeilrechner vergeben, denn ändern sich die mal mit der Dynamik von DHCP ists aus mit dem VPN.
Besser also hier statische IP Settings hier benutzen die natürlich außerhalb der DHCP Adressrange liegen um keine IP Adressdopplung oder Überschneidungen zu provozieren !!

Vermutlich schlägt dann deine Firewall am VPN Zielrechner zu, denn du kommst ja mit einer externen IP Adresse rein die normalerweise sofort geblockt wird von der Win Firewall da diese nur lokale Packet durchlässt !
Das solltest du auch genau überprüfen !!

Da du nicht sicher weisst ob dein Router auch diese PPTP Packete forwardest solltest du auf dem Zielrechner mal einen Packet Sniffer installieren und generell mal überprüfen ob die PPTP Packete überhaupt dort ankommen.
Der www.WIRESHARK.org oder der MS-Net-Monitor helfen dir dabei !
So kannst du generell erstmal klären ob das PPTP Forwarding überhaupt funktioniert !!!

Es ist und bleibt aber ein banales Problem, da es meist nur an diesen einfachen Parametern scheitert....
Bitte warten ..
Mitglied: Charalambos
12.06.2008 um 16:55 Uhr
Hallo

Danke für die Antwort!

Zwischenzeitlich habe ich es nach langem telefonieren mit Linksys und weiteren Recherchen hinbekommen, dass ich über die VPN den Rechner erreichen kann.

Hierzu war ein Firmwareupdate erforderlich, es sollte für das VPN-Passthrough und PPTP zumindest die Version 1.01.06 vorhanden sein, bei IPSec geht auch die Version 1.01.05.

Leider muss unter Verwendung von PPTP immernoch die DMZ eingerichtet sein, was natürlich blöd ist. Linksys äusserte sich dazu telefonisch mit der aussage, dass es sich wahrscheinlich um einen Bug handelt und sie es bis dato nicht bestätigen könnten, da der WAG200G laut Linksys nur mittels IPSec getestet wurde.

Letzeres Problem bildet nun die lokale Anmeldung am Rechner selbst unter Verwendung des RemoteDesktop, hier lässt Vista die Verbindung nicht zu. Das wird aber wohl auf die Firewall zurück zu führen sein und ich sehe mir das morgen an.

Mal sehen was dabei herauskommt.
Bitte warten ..
Mitglied: Charalambos
25.06.2008 um 20:18 Uhr
Hallo Zusammen

Ihr werdet es nicht glauben, aber ich habe es geschafft eine Hürde zu überwinden und nun kann ich mich tatsächlich per VPN mit dem Rechner verbinden.

Jedoch besteht noch ein Problem, dass ich nicht gelöst bekomme. Wenn ich mich mit dem Vista Rechner über die VPN verbunden habe, dann kann ich aus irgend einem Grund nicht per mstsc.exe auf das System zugreifen, also per Remote Desktop arbeiten. Wenn ich die IP Adresse des Rechners eingebe, dann bekomme ich immer die Fehlermeldung, der Rechner sei nicht erreichbar oder der Remote Desktop sei nicht aktiviert.

Letzteres ist zumindest soweit eingestellt, kann es vielleicht sein dass auf beiden Rechnern, Server und Client jeweils ein identisches Konto vorhanden sein muss, damit Vista eine Verbindung zulässt? Ich glaube das irgendwo gelesen zu haben, ebenfalls auch probiert, allerdings ohne sichtlichen Erfolg.

Könnte jemand so nett sein und mir verraten welche Ports für den Remote Desktop eventuell benötigt sind und im Router noch auf den Rechner umgeleitet werden müssen? Gibt es vielleicht auch noch einen Dienst der bei Vista aktiv sein muss und von dem ich nichts weiß?

Bitte helft mir, ich bin echt am verzweifeln...
Bitte warten ..
Mitglied: Motobiker
27.06.2008 um 10:28 Uhr
Hallo , erzhäl bitte wie du das Problem gelöst hast, ich habe immer noch ein Problem damit.

Firmware. 1.01.08, 06 habe ich auch ausprobiert.
1723 wird weitergeleitet

Server log : Gre 47 wird nicht durchgelassen
Bitte warten ..
Mitglied: Motobiker
27.06.2008 um 10:29 Uhr
VPN Passtrough ist bei mir auch an
Bitte warten ..
Mitglied: Charalambos
30.06.2008 um 20:54 Uhr
Hallo

Du musst unter "Anwendungen & Spiele" einen neuen Port erstellen mit dem Protokoll 47 TCP und an den entsprechenden Rechner beziehungsweise IP Adresse forwarden. Wenn Du damit erfolg hast gebe mir bitte bescheid, denn bei mir funktioniert zwar die Anmeldung über VPN aber der RemoteDesktop nicht.
Bitte warten ..
Mitglied: Motobiker
01.07.2008 um 09:27 Uhr
Leider Erfolglos, habe ich auch vorher ausprobiert , den 47 GRE ist ja ein Protokoll, kein Port .
Also momentan habe ich VPN Passtrough , 1723 auf Server , 47 TPC , habe ich auch ausprobiert.
RDP geht problemmlos , hab einfach 3389 weitergeleitet.
Linksys schweigt sich zum problem aus und sagt dieses Problem wird nicht behandelt, die sagen mir ich soll den Server in die DMZ stellen, bin ich bescheuert ?(Spaken).
Ich bin kurz davor IPSec/L2TP auf dem Server einzurichten oder über OpenVPN zu gehen.
Bitte warten ..
Mitglied: Motobiker
01.07.2008 um 09:32 Uhr
Poste mal was du alles eingestellt hast. Bei mir geht nicht.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
VPN mit zwei Linksys WRT54GL (50)

Frage von Haegi75 zum Thema Router & Routing ...

LAN, WAN, Wireless
gelöst VPN IPSec mit Linksys Router funktioniert nicht (5)

Frage von knubbie zum Thema LAN, WAN, Wireless ...

Windows 10
Problem mit Vpn Verbindung über Shrew Soft VPN Client (5)

Frage von Hannibal87 zum Thema Windows 10 ...

Router & Routing
gelöst Linksys WRV200 als VPN Server hinter Mac Airport (20)

Frage von knubbie zum Thema Router & Routing ...

Neue Wissensbeiträge
Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(3)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
SAN, NAS, DAS
MSA 2050 RAID Konfig (27)

Frage von Leo-le zum Thema SAN, NAS, DAS ...

Netzwerkmanagement
Windows Server 2008 R2: "netsh reset" nicht verfügbar? (11)

Frage von RickTucker zum Thema Netzwerkmanagement ...

Outlook & Mail
Outlook Suche liefert kein Ergebnise mehr (8)

Frage von Bjoern-B zum Thema Outlook & Mail ...

Windows Server
gelöst "Kiosk"System für Demoversion und neue Versionen einer Anwendung (7)

Frage von kpieper zum Thema Windows Server ...