Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kniffliges Problem: XP-Pro mit User-Berecht. in W2K3 Dom., Supervisor auf Novell Server (3.20), PW leer, Zugriff Netz-LW OK, Netz-LPT NOK

Frage Sonstige Systeme Novell Netware

Mitglied: AndreasP

AndreasP (Level 1) - Jetzt verbinden

04.12.2006, aktualisiert 16:35 Uhr, 5224 Aufrufe, 3 Kommentare

Hallo,
habe hier ein etwas exotisches Problem, bei einem exotischen Kunden:
XP Pro SP 2 mit Microsoft Novell-Client (Standard-Installation), Mitglied in einer Win 2K3 Domäne mit einem Server.
Novell Server 3.20 genutzt als File, Print- und Fax-Server. Alle User des Netzes arbeiten bisher als Supervisor mit leerem Kennwort.

Wenn am Client die Anmeldung als Win-DomAdmin (mit PW) erfolgt, kann mittels
net use "g: \\Novell\Share /user:supervisor" die Datenplatte angemeldet und uneingeschränkt genutzt werden.
Danach wird mittels "net use lpt1 \\Novell\print" der Druckerport umgeleitet. Die alte Dos-Anwendung kann dann freudig vor sich hin drucken.

Erfolgt die Anmeldung am XP-Client als normaler User passiert folgendes:
Net use g: \\Novell\Share /user:supervisor -> funktioniert einwandfrei, Zugriff ebenfalls (wie oben) möglich
Net use lpt1 \\Novell\print -> Systemfehler 5: Zugriff wurde verweigert.

Muss ich das verstehen ? Warum kann ich denn als User nicht drucken ?
Laut Aussage sind die Rechte auf dem Novell-Server für Platte und Printer identisch eingerichtet.

Hat hier eine eine Idee ?

Gruß,
A.
Mitglied: markus0873
04.12.2006 um 16:02 Uhr
Hi Andreas,

Leider klappt die Lösung tatsächlich mit "net use lpt1" nur mit Administrator-Rechten. Die Druckerport-Umleitung auf LTP1 macht hier die Probleme: Die ist nämlich nur Administratoren gestattet. Die Freigabe-Berechtigungen spielen da leider keine Rolle.

Vielleicht mal ein Script unter VB oder AutoIT probieren und den Befehl als lokaler Admin ausführen lassen.


Gruß aus Hannover,

Markus
Bitte warten ..
Mitglied: AndreasP
04.12.2006 um 16:22 Uhr
Hi,
Danke für die schnelle Reaktion.

Ich kann als normaler User nicht den Druckerport umleiten ? Ich kann doch aber auch Netzwerkdrucker anmelden ?

Wenn ich das richtig verstehe, brauche ich entweder lokale Admin-Rechte (Bloß nicht), oder ich muss einmalig für den User die Umleitung in einem anderen User-Context laufen lassen, korrekt ?

Gruß,
A.
Bitte warten ..
Mitglied: Pandora
04.12.2006 um 16:35 Uhr
Hi,

habe bei mir das gleiche Problem mit alten DOS Programmen. Ich hab das bei mir so gelöst, dass ich den LPT1 im Gerätemanager einfach auf LPT2 umgestellt habe. Somit wird LPT1 nicht mehr vom System verwendet, und du kannst auch mit einfachen Benutzerrechten den Port mappen.

Gruß,
Pandora
Bitte warten ..
Ähnliche Inhalte
Monitoring
Squid als Proxy OK als GW NOK (3)

Frage von vikozo zum Thema Monitoring ...

Router & Routing
Netzwerk Problem - verworrenes Netz (4)

Frage von holladie zum Thema Router & Routing ...

Netzwerkgrundlagen
Server und Clients in getrennte Netze (2)

Frage von canlot zum Thema Netzwerkgrundlagen ...

Netzwerkgrundlagen
Netzwerk Routing mit Fritzbox als 192er Netz in ein 10er Netz (9)

Frage von kronos88 zum Thema Netzwerkgrundlagen ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
gelöst Leiten "dumme" Switches VLAN-Tags mit durch? (26)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Netzwerkgrundlagen
Kann auf Freigabe nicht Zugreifen (16)

Frage von leon123 zum Thema Netzwerkgrundlagen ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (16)

Frage von departure69 zum Thema Windows Server ...

Router & Routing
FTTH bzw FTTB Router (13)

Frage von ukulele-7 zum Thema Router & Routing ...