Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Keine Kommunikation innerhalb der VLAN Konfiguration mit M0n0wall und VLAN - Switch

Frage Netzwerke LAN, WAN, Wireless

Mitglied: ITSE-Chris

ITSE-Chris (Level 1) - Jetzt verbinden

25.04.2013 um 13:51 Uhr, 2019 Aufrufe, 2 Kommentare, 1 Danke

Hallo Leute,

ich bin zur Zeit am Aufbau eines VLAN - Netzwerkes mit Hilfe der Monowall und einem Netgear VLAN Switch.

Dabei sieht der logische Aufbau wie folgt aus:

749dc7bc79f087e1e063965aecfcf9fe - Klicke auf das Bild, um es zu vergrößern

VLAN 1 - Default VLAN
VLAN 20 - Loft
VLAN 30 - Büro

Die Einstellungen an der Monowall habe ich soweit durchgeführt und es klappt auch soweit alles.
Die Einstellungen am Switch sehen so aus:

Port 1 ist der Tagged Uplink zur Monowall
Im VLAN 20 befinden sich die Ports 2,3,4,5,6,7,8,9,10,11,12,13,14
Im VLAN 30 die Ports 15,16,17


Im VLAN 20 habe ich nun:

Port 1 Tagged
Port 2 - 14 Untagged

Im VLAN 30:

Port 1 Tagged
Port 15-17 Untagged

VLAN 1 (Default):

Port 1 Untagged
Port 18 - 24 Untagged

____________________________________
Stecke ich nun die Clients an die gewünschten Ports der VLANs, erhalten sie die IPs aus der Range, die ich in der Monowall eingetragen haben.

Bei Vlan1 : 192.168.1.100 - 199
Bei Vlan20: 192.168.100.100 - 199
Bei VLan30: 192.168.200.100 - 199

Nun mein großes Problem:
Wenn ich die Clients im selben VLAN anpingen möchte, dann klappt das nicht. Kurios dabei ist, dass ich einen Client mit der 199 am Ende der IP immer erreiche. Jedoch umgekehrt nicht. Selbst Clients aus dem fremden VLAN30, erreichen den Client aus dem VLAN20.

ZB:
192.168.100.198 ping 192.168.100.199 ERFOLGREICH
192.168.100.197 ping 192.168.100.199 ERFOLGREICH
und sogar
192.168.200.198 ping 192.168.100.199 ERFOLGREICH (VLAN30 pingt VLAN20)

ABER
192.168.100.199 ping 192.168.100.198 NICHT ERFOLGREICH
192.168.100.199 ping 192.168.100.197 NICHT ERFOLGREICH
also umgekehrt klappt der Ping nicht, was mich echt verzweifeln lässt und wieso können die Clients aus VLAN30 die in VLAN20 erfolgreich anpingen...aber auch nur den mit der 199?

Habe ich irgendwo einen großen Denkfehler oder wo liegt das Problem?
Mitglied: aqui
25.04.2013, aktualisiert 26.04.2013
Nein, einen Denkfehler machst du nicht generell ist dein Konzept so absolut korrekt.
Dein Problem ist vermutlich der NetGear Switch selber !
Eine Menge PMs die zum Thread kamen mit Problemen sind nahezu ausnahmslos NetGear Kandidaten gewesen.
Der Grund ist die leider nicht einfache und intuitive Konfiguration dieser Switches im Vergleich zu anderen.
Du solltest dich also erstmal voll nur auf den Switch konzentrieren und den erstmal separat wasserdicht testen.
NG will sehr häufig dediziert immer noch eine sog. "VLAN PID" zusätzlich zu den VLAN Portzuweisungen haben, also quasi alles doppelt.
Die Folgethreads zum obigen Tutorial behandeln das auch zum Teil.
Oft ist diese zusätzliche PID Zuweisung der Schlüssel zum Erfolg.
Nimm also erstmal den Switch nur allein, stelle so deine VLANs ein wie oben beschrieben und checke das du die interne VLAN Kommunikation sauber hinbekommst und erst dann klemmst du die Router Firewall über eine tagged Port an.
Wichtig ist das innerhalb der einzelnen VLANs die Kommunikation sichergestellt ist. Also 2 Endgeräte an Ports in einem gemeinsamen VLAN müssen untereinander anpingbar sein !
Leider muss man als Fazit sagen ist NetGear nicht immer die allerbeste Wahl wenn es um VLAN Switches geht, was nicht per se an der Marke liegt aber an der total konfusen und unübersichtlichen Art der VLAN Konfiguration der NetGear Switches
Besser also man sieht sich bei VLANs vorher beim Mitbewerb um der das erheblich besser, übersichtlicher und sinnvoller kann.

Feedback deinerseits wäre aber interessant. Ggf. kann man das VLAN Tutorial so optimieren um anderen die in die "NetGear Switch Falle" getappt sind bei VLANs so mit hilfreichen Tips zu einem schnellen Erfolgserlebnis zu verhelfen !
Bitte warten ..
Mitglied: aqui
30.04.2013 um 12:15 Uhr
Wars das denn jetzt ??
Wenn ja bitte dann auch
http://www.administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerkmanagement
gelöst Ist VLAN bei Zyxel Switch komplizierter als beim Rest? (2)

Frage von StefanKittel zum Thema Netzwerkmanagement ...

LAN, WAN, Wireless
LANCOM VLAN mit HP Switch? (1)

Frage von TBTuR0k zum Thema LAN, WAN, Wireless ...

Netzwerkmanagement
VLAN Konfiguration inkl. Management VLAN Zugriff auf NETGEAR Smartswitches (1)

Frage von tobitobsn zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...