Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Konfiguration auf Cisco 3560 zurückspielen

Frage Hardware Switche und Hubs

Mitglied: devnull

devnull (Level 1) - Jetzt verbinden

21.02.2006, aktualisiert 23.02.2006, 11809 Aufrufe, 8 Kommentare

Guten Morgen,

wir setzten mehrere Cisco Switche im Netzwerk ein. Vorsorglich habe ich die Konfiguration aller Switche per Tool ausgelesen und gesichert. Vor kurzen hat einer dieser Switche den Geist aufgegeben und wurde von Cisco gegen ein neues Gerät getauscht.

Morgen soll das Gerät hier eintreffen, danach würde ich gern an diesem 3560 Switch die Konfiguration zurücksichern. Ich habe ein Konsolenkabel. Wenn ich mich auf der Konsole eingeloggt habe, wie spiele ich diese Datei auf den Switch und speichere diese dann ab?

Für Eure hilfe währe ich dankbar !
Mitglied: Mike.ekiM
21.02.2006 um 10:26 Uhr
Normalerweise kannst des über tftp machen!
genaueres hierzu wirst du wohl im Handbuch erfahren.

Ich sag da: RTFM (Read The Fucking Manual)
Bitte warten ..
Mitglied: muhagel
21.02.2006 um 15:41 Uhr
Hier ist der Link

http://www.cisco.com/en/US/customer/products/hw/switches/ps5528/product ...

Du musst die gesicherte Konfig per TFTP in nvram:startup-config kopieren. Danach ein Reload und die gesicherte Konfig wird beim nächsten Booten geladen. Wichtig! Falls beim Reload die Meldung kommt, dass man die Konfig speichern soll, dass natürlich nicht machen, sonst wird die gerade übertragene Konfig wieder überschrieben!

Reicht das, oder soll ich es noch detaillierter beschreiben?
Bitte warten ..
Mitglied: devnull
22.02.2006 um 08:25 Uhr
Guten Morgen,

vielen Dank für Eure Antworten!

Ich werde, wenn das Gerät heute eintrifft, mal das Handbuch studieren Auf den Link bei Cisco komme ich leider nicht. Komisch, dabei sind wir Contract Owner ...

Wenn das im Handbuch beschrieben ist, sollte ich aber damit klar kommen!

Grüsse Mario
Bitte warten ..
Mitglied: devnull
22.02.2006 um 10:48 Uhr
So,

hab mir das Handbuch durchgelesen. Kann ich die Konfig im Expressmodus über Browser einspielen oder muss das per CLI durchgeführt werden?

Bei letzterem wäre ich für ausführlichere Infos dankbar, ich habe den Switch noch nicht gebootet, er ist also Werksfrisch.

Grüsse Mario
Bitte warten ..
Mitglied: muhagel
22.02.2006 um 11:11 Uhr
Mit dem Expressmodus habe ich keine Erfahrung. Kenne mich nur mit der CLI aus.
Ich kenne euer Netz nicht, wegen VLANs etc. Du brauchst grundsätzlich einen TFTP Server, auf dem deine gesicherte Konfig liegt. Den Switch musst du so konfigurieren, dass er eine Verbindung zum TFTP Server aufbauen kann, d.h. du konfigurierst z.B. im VLAN 1 eine IP Adresse aus dem Netz des TFTP Servers. Nicht vergessen, das VLAN1 mit "no shutdown" zu aktivieren. Zum Kopieren gibst du den Befehl "copy tftp nvram:startup-config" ein. Danach wirst du nach der IP Adresse des TFTP Servers gefragt und nach dem Namen deiner gesicherten Konfig. Wenn der Kopiervorgang abgeschlossen wurde rebooten. Wie bereits erwähnt, wenn du beim Rebooten gefragt wirst, ob die Konfig gespeichert werden soll, das nicht tun. Sonst wird die eben kopierte Konfig wieder überschrieben.
Bitte warten ..
Mitglied: devnull
22.02.2006 um 14:26 Uhr
Vielen Dank für die Antwort,

leider konnte ich den alten Zustand noch nicht herstellen. Über TFTP hat nicht funktioniert, vieleicht hat das "Sicherungsfile" nicht die richtige Syntax?

Es ist ja nur ein einfaches Textfile, mal als Beispiel:

... Snip ...

interface FastEthernet0/1
switchport access vlan 10
switchport voice vlan 20
no ip address
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
no mdix auto
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 10

... Snip ...

Ich habe mal gehört, man könne das einfach per Telnet reinkopieren, nur kenne ich die Befehle nicht? Eine Telnetverbindung habe ich, IPadresse konnte ich einstellen ...

Noch Tips?
Bitte warten ..
Mitglied: muhagel
22.02.2006 um 15:11 Uhr
Jetzt kommen wir der Sache näher
Du hast nicht die Konfig per TFTP weggesichert, sondern dir die angezeigte Konfig (z.B. show running-config) aus einer Session heraus in ein Textfile kopiert. Dann geht das mit TFTP nicht.
Wenn deine Konfig nicht allzu groß ist, dann würde ich alles schnell per Hand eintippen. Du kannst natürlich das Textfile in eine Session hineinkopieren. Den Text bei Windows in die Zwischenablage kopieren in die Session wechseln und mit Enter einfügen. Aber Vorsicht! Du kannst das Textfile nicht 1:1 reinkopieren. Du musst beachten in welchem Konfigurationsmodus du dich befindest, also EXEC/Global/Interface. Den Wechsel der Modi musst du in dein Textfile mit den entsprechen Befehlen einbauen. In deinem Beispiel würde das so aussehen:

Switch im EXEC Mode (switch#)

conf t
interface FastEthernet0/1
switchport access vlan 10
switchport voice vlan 20
no ip address
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
no mdix auto
auto qos voip cisco-phone
spanning-tree portfast
interface FastEthernet0/2
switchport access vlan 10
.....
exit

Wenn du so vorgehst, dann veränderst du die running-config, d.h. du solltest das über den Console Port machen, ansonsten kann es passieren, dass du dich selbst aus der Session wirfst. Zum Schluss nicht vergessen, die Konfig mit "write" zu speichern, ansonsten ist sie beim nächsten Reboot wieder weg.
Bitte warten ..
Mitglied: devnull
23.02.2006 um 07:55 Uhr
Guten Morgen,

vielen Dank für Deine Antwort @muhagel!!!

Ich habe die Konfiguration per Consolenkabel eingespielt.

Bin dabei wie folgt vorgegangen:

enable
Passwort eingeben
conf t

in kleineren Portionen reinkopieren (beim ersten Versuch alles komplett rein zu schieben funktionierte das nicht - ?? )

write
exit

Nach einen Neustart stand der Switch zur Verfügung, werde den heute ins Netzt hängen und testen.

Ich habe noch ein interessantes Programm von Cisco gefunden "Cisco Network Assistant". Damit kann man seine kompletten Cisco Netzwerkkomponenten verwalten. Es ist auch möglich diese zusammenzufassen und die Netzstruktur grafisch abzubilden.

Darin ist auch eine Sicherung der Konfigurationen enthalten, diese werden in 2 Dateien auf dem lokalen Rechner gespeichert. Also auch wieder kein TFTP. Vorteil ist aber, das die Konfiguration direkt von einer lokalen Datei wieder hergestellt werden kann, einzige Vorarbeit, IP konfigurieren und dem Switch den selben Hostname verpassen, sonst bietet er die alten Konfigdateien nicht zum Upload an.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Übungen zu Cisco Router Konfiguration
Frage von M.MarzRouter & Routing3 Kommentare

Hallo zusammen, ich fange bald bei einem Netzwerkunternehmen an, die hauptsächlich mit Cisco Routern arbeiten. Um auch selbstständig was ...

Router & Routing
Konfiguration Cisco ASA5505
Frage von YannoschRouter & Routing7 Kommentare

Guten Tag zusammen, bin gerade dabei eine Cisco ASA5505 für den Heimgebrauch zu konfigurieren. Möchte auch ein VPN mit ...

Router & Routing
Problem mit Cisco VLAN-Konfiguration
gelöst Frage von ef8619Router & Routing4 Kommentare

Hallo liebe Leute, wir haben 2 Cisco SGE2000 und SGE2000P im Stacking Mode laufen, dazu einen Cisco ISR 1921 ...

Switche und Hubs
Cisco Catalyst 2950 Konfiguration
gelöst Frage von polk14Switche und Hubs3 Kommentare

Guten Tag, ich habe eine Frage zur Konfiguration des Cisco Catalyst 2950. Ich möchte gerne auf den Cisco per ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 1 TagWindows 103 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server13 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server13 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...

Windows Tools
Software-Tool zum Entfernen von bösartigem Windows
Frage von emeriksWindows Tools11 Kommentare

Hi, siehe Betreff hat das jemals irgendjemand schonmal sinnvoll eingesetzt? (MRT) E.