Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Konfiguration Exchange Server 2003

Frage Microsoft Exchange Server

Mitglied: obergrattler

obergrattler (Level 1) - Jetzt verbinden

28.02.2005, aktualisiert 16:57 Uhr, 27538 Aufrufe, 8 Kommentare

SMTP mit Smarthost, POP über Connector

Hallo zusammen,

ich habe ein Problem mit der Konfiguration unseres Exchange Servers 2003.

ALLGEMEINE ANGABEN:
Exchange Server 2003 ist installiert auf unserem PDC (BS: Windows Server 2003), da wir bei nur 20 Clients keinen zweiten Server aufstellen wollten.
Der Server befindet sich im Uni-Netzwerk.
Server IP-Adresse ist statisch (kein DHCP konfiguriert).
Server IP-Adresse ist privat (Proxies des RZ werden für Internet verwendet).
DNS erfolgt über Weiterleitung an externen DNS-Server des RZ.
Weder Server noch Clients sind in diesem DNS eingetragen.

Bei der Konfiguration des Active Directory hab ich den Vorschlag der Installationsroutine befolgt und den folgenden Domänennamen vergeben:

"unserdomänenname.local"

Bisheriger Email Verkehr lief über Outlook-Konten auf den Clients mit POP und SMTP.

Die Konfiguration des Exchange Server 2003 soll nun einige Features ermöglichen, die nur mit Outlook und externem POP und SMTP nicht möglich waren:

- Zugriff mehrerer User auf das gleiche Email-Konto, auch gleichzeitig.
- Zugriff mehrerer User auf Kalender
- Öffentliche Ordner mit Kontakteliste
- Abwesenheits-Assistent
- etc.

VORGABE:
Die externen Email-Adressen (die schon auf sämtlichen Visitenkarten usw. bekannt sind) sollen beibehalten werden.
Mitglied: obergrattler
28.02.2005 um 13:28 Uhr
KONFIGURATION EXCHANGE:
SMTP Connector über Smarthost zum SMTP-Server des RZ zum Versenden,
Programm "POPcon v2.92" als POP Connector zum Abholen der Emails.

VERSENDEN:
Durch den Domänennamen "unserdomänenname.local" wird im AD jedem User zunächst mal eine Hauptemailadresse mit dem Suffix .local verpasst. Wenn dieser User dann senden will, kommt die Fehlermeldung, dass ".local" keine gültige TLD ist. Wenn ich die Hauptemailadresse des Users auf ".de" ändere passiert das gleiche. Erst wenn ich im Exchange System Manager die Default Policy für die Standard-Email-Adresse auch auf ".de" setze, schickt Exchange die Email weiter an den Smarthost (externer Mailserver des RZ). Dieser schickt diese jedoch nicht weiter ins Internet.

Nach den Angaben unseres RZ liegt es auf jeden Fall nicht daran, dass deren Mailserver unseren Exchange Server als Spammer-Relay erkennt, da unser Server Teil des Uni-Netzwerkes ist. Der RZ-Mailserver entscheidet lediglich anhand der IP-Adresse des Absenders, ob es sich um Spam handelt oder nicht. Da unser Server jedoch eine interne, statische IP-Adresse hat, kann er vom RZ de facto nicht als Spammer eingestuft werden. ("telnet RZ-Mailserver 25" liefert "ready").

Also liegt das Problem IMHO daran, dass der RZ-Mailserver mit unserem lokalen Email-Adressraum "username@unserdomänenname.de" nichts anfangen kann.

Daraufhin hab ich sowohl die User-Emailadressen als auch die Default Policy bei den Empfängerrichtlinien dahingehend verändert, dass nun die externe Emailadresse "username@unserrechenzentrum.de" als Hauptadresse eingerichtet ist.
Damit klappt das Versenden der Emails nach draussen wunderbar.
Bitte warten ..
Mitglied: obergrattler
28.02.2005 um 13:28 Uhr
EMPFANGEN:
Jeder User hat sowohl seine interne Emailadresse ("username@unserdomänenname.de") als auch seine externe Emailadresse ("username@unserrechenzentrum.de") im AD eingetragen.
In der Default Policy bei den Empfängerrichtlinien stehen auch beide Suffixe drin.
In POPcon sind beide als "Akzeptierte Empfängerdomänen" eingetragen.
POPcon kann die externen POP3-Konten problemlos abfragen.
Exchange Server 2003 nimmt die Emails von POPcon jedoch nur entgegen, wenn
- die externe Emailadresse die Hauptemail-Adresse des Users ist UND
- die externe Emailadresse in der Default Policy als Hauptemailadresse angegeben ist.
Ist die interne Emailadresse als Hauptemailadresse angegeben, bekommt POPcon folgende Fehlermeldung von Exchange:
"Host antwortete nicht korrekt auf das DATA Command [554. 5.5.2 No valid recipients]"

ZWISCHENFAZIT:
Wenn ich also sowohl bei den Usern im AD als auch in der Default Policy die externe Emailadresse ("username@unserrechenzentrum.de") als Hauptemailadresse einrichte, kann ich problemlos senden und empfangen. Wenn nicht, dann klappt weder das eine noch das andere.

EIGENTLICHES PROBLEM:
Wir sind nicht die einzigen, die die externen Emailadressen des Rechenzentrums verwenden. Andere Mitarbeiter der Uni, die nicht in unserem AD existieren, weil sie an einem ganz anderen Institut arbeiten, haben auch Emailadressen des Rechenzentrums ("username@unserrechenzentrum.de"). Wenn aber nun einer unserer Mitarbeiter eine Email an einen Mitarbeiter außerhalb unseres Institutes schicken will, der auch eine Emailadresse des Rechenzentrums besitzt, gibt Exchange die folgende Fehlermeldung zurück:
"Das E-Mail-Konto ist in der Organisation, an die diese Nachricht gesendet wurde, nicht vorhanden."
Das liegt ganz einfach daran, dass unser Exchange Server glaubt, er wäre für die ganze Domäne "unserrechenzentrum.de" verantwortlich, was ja nicht der Fall ist.
Wenn die externen Email-Adressen jedoch als Hauptemailadressen fungieren müssen, kann ich die Option "Diese Exchange-Organisation ist für die gesamt E-Mail-Übermittlung an diese Adresse verantwortlich" in der Default Policy der Empfängerrichtlinien nicht deaktivieren, da das Kästchen für die Hauptemailadresse inaktiv ist.

WAS KANN ICH TUN? WÄRE DANKBAR FÜR HINWEISE ALLER ART.

obergrattler

COME TO WHERE THE OBERGRATTLER IS ...
Bitte warten ..
Mitglied: Br4inbukz
28.02.2005 um 15:00 Uhr
Hallo grüße dich! An welcher Uni bist du denn?
Normaler betreiben die doch auch selber Exchangeserver? Warum nicht einfach nen stinknormalen Domänencontroller installieren, und die Exchangesachen auf deren Rechnern laufen lassen? Finde ich komfortabler, auch wegen Outlook Webaccess etc.
Nun gut zu deinem eigentlichen Problem. Es sollte da irgendwo eine Option geben, wo du einstellen kannst "Für unbekannte Nutzer weiterleiten an ................"
Dann sollten halt auch die Mails an user_eines_anderen_lehrstuhls@rechenzentrum.de an die Rechenzentrum weitergeleitet werden, da er ja kein User in der Domäne hat, dem diese Mailaddy zugeordnet ist.
Bitte warten ..
Mitglied: obergrattler
28.02.2005 um 15:31 Uhr
Hallo Br4inbukz,

danke für deine Antwort. Wir sind an der TU München. Das LRZ (Leibniz Rechenzentrum) betreibt keine Microsoft Exchange Server. Da läuft alles über UNIX (Email-Konten mit AFS)und da hab ich weder Ahnung von noch Zugriff drauf.
Ich such mal diese Option "Für unbekannte Nutzer weiterleiten an ....". Falls ich das nicht finde, melde ich mich nochmal. Schon mal danke für den Hinweis ...

obergrattler

COME TO WHERE THE OBERGRATTLER IS ...
Bitte warten ..
Mitglied: obergrattler
28.02.2005 um 15:55 Uhr
Hallo nochmal,

ich finde diese Option leider nirgendwo. Könntest du mir bitte sagen, wo ich da genau nachschauen sollte? Irgendwie steh ich auf dem Schlauch... Danke.

obergrattler

COME TO WHERE THE OBERGRATTLER IS ...
Bitte warten ..
Mitglied: obergrattler
28.02.2005 um 16:21 Uhr
Nochmal Hallo nochmal,

ich glaub ich hab's jetzt doch gefunden:
Kann es sein, dass du folgende Option gemeint hast?

Exchange System Manager -
Server -
UnserServername -
Protokolle -
SMTP -
Virtueller Standardserver für SMTP - Eigenschaften
Nachrichten
"Alle E-mails mit nicht ausgewerteten Empfängern weiterleiten an Host:"
Hier FQDN unseres RZ-Mailservers eingeben.

Nur interessehalber hätte ich da noch eine weitere Frage:
Ebenfalls bei Eigenschaften von "Virtueller Standardserver für SMTP" gibt es noch einen Reiter "Übermittlung" und darunter einen Button "Erweitert".
Bei diesen "Erweiterten Übermittlungsoptionen" kann man unter Smarthost auch den FQDN eines Mailservers eintragen. Dieser ist in meiner Konfiguration jedoch leer.
Aus welchen Gründen sollte man hier einen externen Mailserver eingeben?

Zur Information:
Eigentlich sollen ja sowieso alle Mails über den externen Smarthost geschickt werden. Dies ist jedoch bereits hier konfiguriert, dachte ich:

Exchange System Manager -
Connectors -
NamedesSMTPConnectors - Eigenschaften
Reiter Allgemein -
"Gesamte Mail über diesen Connector an diese Smarthosts weiterleiten"
Hier war bereits der FQDN unseres RZ-Mailservers eingetragen, als das ursprüngliche Problem auftrat.

Also wäre der Eintrag des Smarthosts bei den "Erweiterten Übermittlungseinstellungen" dann "doppelt gemoppelt" oder erfüllt er einen anderen Zweck???

Sorry für meine komischen Fragen aber ich hatte bis vor einer Woche noch nie einen Exchange Server aus der Nähe gesehen.

obergrattler

COME TO WHERE THE OBERGRATTLER IS ...
Bitte warten ..
Mitglied: Br4inbukz
28.02.2005 um 16:50 Uhr
Jop das war der Eintrag den ich gemeint hatte. *smile* wußte nicht mehr aus dem Kopf genau wo das war, aber hast es ja gefunden.

Also das mit den erweiterten Einstellung ist so, das man da wie gesagt ne Smarthost einstellt, unter anderem wenn man ihn als Relay nutzen will, von wegen der Authentifizierung etc.
Habe ich jedenfalls hier so bei mir, da werden alle Mails an den Relayserver von Arcor übermittelt und können aber eine beliebige Mailabsendeadresse haben.

In deinem Fall denke ich mal ist das wirklich doppelt gemoppelt.
Weil es bei mir wirklich so ist, das er dann automatisch Mails die in die eigene Domäne gehen nicht dadrüber verschickt, sondern direkt an die Postfächer zustellt und automatisch dann Mails die nicht in der Domäne bei Usern stehen, ins Netz verschickt sprich an den Arcor Relayserver übergibt.

Gruß Roman
Gruß Roman
Bitte warten ..
Mitglied: obergrattler
28.02.2005 um 16:57 Uhr
Hallo Roman,

alles klar. VIELEN DANK für Deine Hilfe.
Dieses Forum ist echt Klasse.

Fabian aka obergrattler

COME TO WHERE THE OBERGRATTLER IS ...
Bitte warten ..
Ähnliche Inhalte
Suche Projektpartner
Installtion und Konfiguration Microsoft Exchange Server
gelöst Frage von runasserviceSuche Projektpartner2 Kommentare

Hallo, für die Installtion und Konfiguration eines Microsoft Exchange Server (10 Benutzer) auf einem System vor Ort (Berlin / ...

Exchange Server
Exchange Server 2013 - Konfiguration mit TLD
Frage von MikeyyExchange Server2 Kommentare

Moin, habe mir auf meinem Testserver einen Exchange Server 2013 auf der Basis eines 2012R2 Standard Servers installiert, welcher ...

E-Mail
Exchange 2013 Konfiguration
Frage von Enel85E-Mail1 Kommentar

Guten Abend, ich möchte nach der Grundinstallation meines Exchange 2016 (fertig), E-Mail-Adressen einrichten und den Exchange so konfigurieren, dass ...

Exchange Server
Exchange 2003 (Windows Server 2003)
gelöst Frage von ET-StudentExchange Server6 Kommentare

Hallo alle zusammen ich hab auf einem alten Server Microsoft Server 2003 und Exchange 2003 installiert und es läuft ...

Neue Wissensbeiträge
Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 3 StundenVerschlüsselung & Zertifikate

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 14 StundenWindows 102 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 16 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner3 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen13 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...