Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Linux Linux Tools

Konfigurationsproblem fetchmail

Mitglied: Maik87

Maik87 (Level 2) - Jetzt verbinden

28.07.2006, aktualisiert 15.08.2006, 10134 Aufrufe, 14 Kommentare

Wo ist "Auslieferungsmodus" hin . . . ?

Hallo Gemeinde,

ich habe mir von www.heise.de die Anleitung mal zu Herzen gefasst, in der beschrieben wird, wie man auch Suse 10.1 einen Emailserver macht. Das ist echt genial beschrieben. Also wer das mal vor hat, nur ran

Ich komme bis zu dem Punkt, wo ich den Auslieferungsmodus im YAST einstellen soll. Doch der Punkt ist in meinem YAST nicht drin!! Er muss bei "Eingehnde Mail" ganz unten sein. Da ist aber nichts!! Ich habe Screenshots von anderen gesehen, die haben den Punkt.

Wo ist der? Wieso habe ich den nicht??

<img src=" 9fb9629dcad1cc39eb208e510fdb11d8-yast - Klicke auf das Bild, um es zu vergrößern">
Mitglied: elCativo
28.07.2006 um 13:35 Uhr
Bau dir deine fetchmail.conf auf der Konsole.Sollte in etwas so aussehen
poll pop.schalkerkobold.de proto pop3

user "web40p10" with password "**" is user "hartwig" here
Die fetchmail.conf muss dann noch mit "chmod 710 fetchmail.conf" die richtige Berechtigung bekommen und dann sollte dein Fetchmailer sauber laufen.

P.S. Die gestrichelten Linien sind nur zur Trennung da und müssen nicht in die fetchmail.conf
Bitte warten ..
Mitglied: Maik87
28.07.2006 um 13:45 Uhr
Du meinst wohl die fetchmailrc !?

Das habe ich schon so eingetragen . . .

Aber wo biege ich ihm sonst bei, dass er die Mails an Cyrus weiterleiten soll??
Also den Auslieferungsmodus auf "An Cyrus IMAP Server"
Bitte warten ..
Mitglied: elCativo
28.07.2006 um 15:11 Uhr
Das machst du mittels Procmail.
Die Datei dafür ist die procmailrc.
Übrigends bei meinen Slackware Systemen heißt die Datei fetchmail.conf bei Suse heißt sie fetchmailrc.
Bitte warten ..
Mitglied: Maik87
03.08.2006 um 12:26 Uhr
Die Datei finde ich nicht...

Wo soll die denn sein?

Selbst

find . -name procmailrc -print

bringt keinen erfolg...
Bitte warten ..
Mitglied: elCativo
03.08.2006 um 13:21 Uhr
schau mal mit "which procmail" ob es überhaupt installiert ist.
Müsste dann eine Antwort in der Form kommen "/usr/bin/procmail" oder "/bin/procmail".
Mldet er hingegen das kein procmail installiert ist einfach per yast nachinstallieren.
Eigentlich braucht procmail wenn es global tätig ist keine Anpassungen.Wenn du es Userabhängig nutzen willst (einbinden von Spamassassin) dan musst du die Datei ".procmailrc" im Homeverzeichnis des Users bearbeiten.Achtung der Punkt sagt das es eine versteckte Datei ist die man erst sieht per "ls -al" oder bei Suse kann man auch "la" nehmen.
Bitte warten ..
Mitglied: Maik87
08.08.2006 um 09:31 Uhr
Ich hab den Rechner mal neu installiert, jetzt ist der Punkt da *gg*

Naja, läuft soweit alles, ich kann darüber Mails rausschicken, mit 'nem Emailproggi die Postfächer abrufen, das Serevr greift auf die Postfächer bei meinem Provider zu . . .

Einziger Haken:

Er ruft die Mail ab (löscht sie) stellt sie aber nicht in einem Postfach bereit. Sie ist also weg....
Bitte warten ..
Mitglied: elCativo
08.08.2006 um 20:31 Uhr
Wie schon gesagt schau mal nach ob "procmail" auf dem System installiert ist.Der daemon sorgt dafür das die Mails ins Postfach eingeliefert wird.
Als zweites schau in deine "aliases" Datei ob deine User dort angelegt sind nach dem Schema
mailuser: lokaler User
Wichtig ist der Doppelpunkt gefolgt von einem Tab.Die Datei ist unter "/etc/postfix"
Danach einmal "newaliases" eingeben damit die aliases.db neu aufgebaut wird und ein "rcpostfix reload" kann auch nicht schaden.
mit "telnet localhost 25" kannst du probieren ob dein Postfix läuft und ansprechbar ist.Wenn nicht die Susefirewall konfigurieren das SMTP erlaubt wird.Pop3 und Imap kann man auch gleich noch freischalten.
Bitte warten ..
Mitglied: Maik87
09.08.2006 um 20:39 Uhr
Ja, Procmail ist drauf. Aber es gibt keine .procmailrc im Homverzeichnis und in etc is auch nichts drin.

Muss das Program noch konfiguriert werden? Was ist, wenn ich das an "Cyrus IMAP Server" zustellen lasse? Geht das trotzdem mit Procmail weiter?

ich habe den Auslieferungsmodus zum Test schon auf Direct gestellt, ohne Erfolg.

Das einzige, was mir aufgefallen ist, dass die Mails in /var/spool/mail[benutzername] landen.
Bitte warten ..
Mitglied: elCativo
10.08.2006 um 05:50 Uhr
Jetzt kommen wir dem Problem näher.
In der Datei main.cf von Postfix zu finden unter /etc/postfix musst du einstellen das die Mail nicht nach /var/spool/mail sondern nach $HOME/Mail zugestellt werden.
Der Parameter dafür heisst "home_mailbox = Mail" .
Danach stellt Postfix die Mail im Ordner Mail der Homeverzeichnisses zu.Dann erscheint sie auch korrekt im Imap-Server.
Bitte warten ..
Mitglied: Maik87
10.08.2006 um 18:38 Uhr
Der Ausschnitt sieht so aus:

  1. The home_mailbox parameter specifies the optional pathname of a
  2. mailbox file relative to a user's home directory. The default
  3. mailbox file is /var/spool/mail/user or /var/mail/user. Specify
  4. "Maildir/" for qmail-style delivery (the / is required).
#home_mailbox = Mailbox
#home_mailbox = Maildir/

  1. The mail_spool_directory parameter specifies the directory where
  2. UNIX-style mailboxes are kept. The default setting depends on the
  3. system type.
#mail_spool_directory = /var/mail
#mail_spool_directory = /var/spool/mail



Das ist doch alles auskommentiert, oder??

Was muss ich genau ändern?

Danke für die ganze Mühe.
Bitte warten ..
Mitglied: elCativo
11.08.2006 um 17:26 Uhr
Entferne mal die # vor "home_mailbox = Maildir/" und gib ein "rcpostfix restart" ein.
Du solltest dann im Homeverzeichnis ein Verzeichnis Mail haben darin werden dann die Mails von Postfix abgelegt und dein Cyrus Imap Server stellt dir diese dann zur Verfügung.
Bitte warten ..
Mitglied: Maik87
14.08.2006 um 23:01 Uhr
Soweit so gut . . .

Es kommt aber nichts an!! Meldung in /var/log/mail

Aug 14 22:57:21 mail postfix/local[7716]: F25F11CB95: to=<hartwig@localhost.mail.schalkerkobold>, orig_to=<hartwig@localhost>, relay=local, delay=1, status=bounced (maildir delivery failed: link to /home/hartwig/Maildir/new/1155589041.V303I1eM215474.mail: Permission denied)

Der Ordner existiert und hat von / an chmod 777
Bitte warten ..
Mitglied: elCativo
15.08.2006 um 05:31 Uhr
Ändere als User root mal den Besitz des Ordners mittels "chown hartwig.mail Maildir" .Damit hat die Gruppe mail das Recht auf den Ordner zuzugreifen.Dann sollte die Mail dort landen.
Bitte warten ..
Mitglied: Maik87
15.08.2006 um 12:24 Uhr
Nee, leider nichts zu machen . . .

Angenommen es würde so laufen, hätte ich dann auch den gewünschten Spamfilter und Virenfilter vorgeschaltet??

Hat nicht jemand mal ein Image von einem funktionsfähigen Server hochgeladen?
Bitte warten ..
Ähnliche Inhalte
E-Mail
Fetchmail für User
Frage von Fears313E-Mail3 Kommentare

Hallo Zusammen Ich habe nun meinen eigenen Mailserver und möchte ihn für Family & Friends anbieten. Ich möchte nun, ...

Windows Server
DirectAccess - Konfigurationsproblem mit Netzwerkadapter
Frage von Maik20Windows Server10 Kommentare

Hallo, ich versuche gerade einen DirectAccess-Server aufzusetzen. Dazu halte ich mich an folgendes Tutorial Einzige Abweichung, ich habe nicht ...

Router & Routing
VPN Netgear Prosafe Konfigurationsproblem
gelöst Frage von JukeboxmichlRouter & Routing5 Kommentare

Hallo! Ich habe seit Jahren mit Hilfe der Netgear Prosafe Software auf dem Notebook einen Tunnel zu meinem Netgear ...

E-Mail
Zusammenspiel zwischen lokale Benutzer und fetchmail
Frage von lord-iconE-Mail

Aktuell hole ich meine Emails noch direkt von meinen Mailserver ab (Server im Web mit fester IP) Ich würde ...

Neue Wissensbeiträge
Router & Routing

PfSense als Addon auf QNAP

Information von magicteddy vor 2 StundenRouter & Routing

Moin, für Spielereien eine ganz nette Idee aber ich fürchte das soetwas auch als echte Firewall genutzt wird: In ...

Datenschutz

Teamviewer kommt für IoT-Geräte wie den Raspberry Pi

Information von magicteddy vor 9 StundenDatenschutz

Moin, jetzt werden IoT Geräte endgültig zur Wanze? Anscheinend kann man auf einem Dashboard seine Geräte visualisieren Ich stelle ...

Microsoft

Letzte Updates für Win10 und Server2016 müssen bei Bedarf über den Update catalogue in den WSUS importiert werden!

Tipp von DerWoWusste vor 14 StundenMicrosoft1 Kommentar

automatisch kommt da nichts an im WSUS und auch nicht im SCCM. Siehe Hinweise zum Bezug der jeweils neuesten ...

Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 3 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Preis für Wartungsvertrag ok?
gelöst Frage von a-za-zNetzwerkmanagement22 Kommentare

Hallo! Mal ne Frage, weil ich mich mit dem akzeptablen Preis für einen Reaktionszeitvertrag nicht auskenne. Meine Firma hat ...

Windows Netzwerk
Ist ein Portforwarding auf einen PC ohne lauschendes Programm ein (großes) Sicherheitsproblem?
Frage von PluwimWindows Netzwerk13 Kommentare

Hallo zusammen, zur Fernwartung eines Rechners an einem anderen Ort nutze ich VNC. Da dieser Rechner einfach nur eine ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS10 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...

Windows Server
Terminal Server 2016 erkennt Berechtigungen nicht
gelöst Frage von Thomas2Windows Server10 Kommentare

Hallo Administratoren, folgendes Problem stellt sich dar: Es gibt zwei Windows Server 2016, die als Terminal Server fungieren. Jetzt ...