Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Konfigurationsproblem PC mit zwei IPs

Frage Netzwerke

Mitglied: AsciWhite

AsciWhite (Level 1) - Jetzt verbinden

07.05.2009, aktualisiert 17:10 Uhr, 3267 Aufrufe, 5 Kommentare

Hallo

IST Situaltion:
1 PC mit einer Netzwerkkarte, 2 Router und 2 verschiedene DSL Anschlüsse

PC1 ist folgendermaßen konfiguriert:

prim. IP: 192.168.48.52
sec. IP: 10.204.201.52
prim. Sub: 255.255.255.192
sec. Sub: 255.255.255.0

prim. Gate: 192.168.48.11 <-- Router 1
sec. Gate: 10.204.201.254 <-- Router 2

DNS: 192.168.48.11

route print gibt mir diese Routingtabelle zurück und die schaut für mich korrekt aus:

Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x2 ...00 21 5d xx xx xx ...... Intel(R) Wireless WiFi Link 5100 - Paketplaner-Miniport
0x30003 ...00 23 8b xx xx xx ...... Broadcom NetXtreme Gigabit Ethernet - Paketplaner-Miniport
0x40005 ...00 22 69 xx xx xx ...... Treiber für Bluetooth-LAN-Zugangsserver - Paketplaner-Miniport
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 10.204.201.254 192.168.48.52 20
0.0.0.0 0.0.0.0 192.168.48.11 192.168.48.52 20
10.0.0.0 255.0.0.0 10.204.201.254 192.168.48.52 1
10.204.201.0 255.255.255.0 10.204.201.52 192.168.48.52 20
10.204.201.52 255.255.255.255 127.0.0.1 127.0.0.1 20
10.255.255.255 255.255.255.255 192.168.48.52 192.168.48.52 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.48.0 255.255.255.192 192.168.48.52 192.168.48.52 20
192.168.48.52 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.48.255 255.255.255.255 192.168.48.52 192.168.48.52 20
224.0.0.0 240.0.0.0 192.168.48.52 192.168.48.52 20
255.255.255.255 255.255.255.255 10.204.201.52 2 1
255.255.255.255 255.255.255.255 10.204.201.52 40005 1
255.255.255.255 255.255.255.255 192.168.48.52 192.168.48.52 1
Standardgateway: 192.168.48.11
Ständige Routen:
Netzwerkadresse Netzmaske Gatewayadresse Anzahl
10.0.0.0 255.0.0.0 10.204.201.254 1

Per Autostart wird die Route: 10.0.0.0 255.0.0.0 10.204.201.254 1 hinzugefügt um nur den Zugriff auf einen einzelnen Server mit einer Webanwendung auf den zweiten Router mit der zweiten DSL Leitung umzuleiten.

Problem ist jetz seit ein paar Tagen, dass der Zugriff aufs Web scheinbar zusammenbricht. DSL Leitung für "normales" Web (Router1) läuft aber korrekt.

Seltsamer Effekt ist dieser bei einem Traceroute auf t-online.de:
Hier funktioniert der Zugriff per Browser wie gewohnt

Routenverfolgung zu t-online.de [62.153.159.92] über maximal 30 Abschnitte:
1 <1 ms <1 ms <1 ms 192.168.48.11
2 48 ms 50 ms 50 ms 217.0.118.168
3 48 ms 50 ms 50 ms 87.186.248.178
4 63 ms 63 ms 63 ms 0113699-1-1-gw.ULM.DE.net.DTAG.DE [194.25.10.94]
5 65 ms 65 ms 63 ms 217.6.25.154
6 64 ms 65 ms 62 ms t-online.de [62.153.159.92]
Ablaufverfolgung beendet.

Aber mitten im Betrieb, ohne erkennbaren Grund verändert der PC1 seinen Routing-Pfad und die Seite kann nicht mehr angezeigt werden.

Traceroute auf t-online.de zeigt dann:
Routenverfolgung zu t-online.de [217.6.164.162] über maximal 30 Abschnitte:
1 1 ms 1 ms 1 ms 10.204.201.254
2 66 ms 70 ms 69 ms 172.20.217.211
3 75 ms 78 ms 78 ms 172.20.245.202
4 61 ms 63 ms 60 ms 0113751-1-1-gw.f.de.net.dtag.de [194.25.10.73]
5 64 ms 63 ms 64 ms 217.89.74.2
6 65 ms 60 ms 60 ms www.t-online.de [217.6.164.162]
Ablaufverfolgung beendet.

Ein Ping kommt übrigens auch zu t-online durch, nur wird im Browser nichts angezeigt, außer Webseite wird geladen... Fehler....

Nach unbestimmter Zeit "normaliesiert" sich das ganze wieder und funktioniert wie zuvor um dann irgendwann mal wieder verrück zuspielen .... :-O
Bin für alle Hilfen dankbar ;)

MfG
Mitglied: aqui
07.05.2009 um 17:40 Uhr
Mmmhhhh, das ganze Konstrukt ist unsinnig und im IP Stadard auch so nicht supportet.

Wenn man dich recht versteht, dann fährst du mit 2 separaten IP Netzen auf einem Draht, was so zwar geht aber IP technisch eben nicht supportet ist und damit problematisch ist.
Dein Netz sieht vermutlich so aus:

21115885992602fad95e02355d9e3453-dualnetz - Klicke auf das Bild, um es zu vergrößern

Die Route 10.0.0.0 255.0.0.0 10.204.201.254 ist normalerweise kompletter Unsinn, denn du routets statisch das Netzwerk 10.0.0.0 mit einer 8 Bit Maske an ein Gateway was dieses 10er Netz selber inkludiert !
Folglich ist die ganze Route überflüssig und führt auch zu nichts, denn sie basiert auf einem Masken Mismatch und kann niemals so sinnvoll sein.

Erstmal müsste man mal verstehen, was du überhaupt mit diesem IP Kuddelmuddel Adressdesign erreichen willst ???
So ist es mehr oder weniger unsinnig und kann schon im Ansatz nicht sauber funktionieren !!
Außerdem stimmt deine Angabe "eine Netzwerkkarte" ja ebenfalls nicht wie du oben selber sehen kannst: Du hast ja mindestens 3 im Rechner !!
Gig LAN, WLAN und LAN über Bluetooth was nach Adam Riese ja 3 IP Netze sind !!
Bitte warten ..
Mitglied: HubertN
07.05.2009 um 19:42 Uhr
Zitat von AsciWhite:
Per Autostart wird die Route: 10.0.0.0 255.0.0.0 10.204.201.254
1 hinzugefügt um nur den Zugriff auf einen einzelnen Server mit
einer Webanwendung auf den zweiten Router mit der zweiten DSL Leitung
umzuleiten.

Dieses Mischmasch von Netzen ist tatsächlich überflüssig. Wenn du es korrekt haben willst, dann
- baue eine zweite Netzwerkkarte ein (bzw. nutze die vorhandenen Möglichkeiten),
- konfiguriere die normale Internetverbindung normal mit Standardgateway
- setze eine permanente Route mit "route -p add ..." um einzelne Zieladresse über die zweite Karte zu routen.

Wenn du nur eine Netzwerkkarte in Betrieb nehen kannst (Notebook ?!), dann benutze trotzdem nur ein Netz und setze die pwrmanente Route für die eine Adresse
Bitte warten ..
Mitglied: mrtux
08.05.2009 um 08:18 Uhr
Hi!

Zitat von aqui:
Dein Netz sieht vermutlich so aus:
dualnetz.jpg

Dank dem Diagramm kommt man wenigstens ein bisserl mit wie er es meint.

Ich würde sagen: "Der Aufsichtsbeamte hat sich vom ordnungsgemässen Zustand des Ziehungsgerätes und der 49 IP-Adressen überzeugt.

Vermutlich sollte es Zufallsgenerator oder irgend eine binäre Schaltung werden. In der Hausinstallation gabs zu meiner Zeit (ist 25 Jahre her) Kreuzschaltungen.

Mein Tipp: Gemütlich an die Kaffeemaschine laufen, einen riesengroßen Pott Kaffee holen und sich dann ganz langsam und entspannt darauf Vorbereiten nochmal neu anzufangen. Sorry aber das ist Kuddelmuddel aber kein Netzwerk.

mrtux
Bitte warten ..
Mitglied: Possi1980
08.05.2009 um 10:21 Uhr
Asci White (Mitglieder-ID: 10903)
Mitglieder StatusMitglieder StatusMitglieder StatusMitglieder StatusMitglieder Status
Level 1 - Frischling
Name: D. Wagner
Mitglied seit: 16.03.2005, letzter Login: 08.05.2009
Mitglieder-Status: Level 1 (16.25 Administrator Punkte)

Schwerpunkt: Windows Server
Geschlecht: männlich
Beruf: Server- und Netzwerkspezialist/in
Bitte warten ..
Mitglied: AsciWhite
06.10.2010 um 09:48 Uhr
und was willst du mir mit diesem Post sagen, Possi?
so viel schlauer wie ich scheinst du selber nicht zu sein, also spar dir diese billigen mobbingversuche... FRISCHLING!
Bitte warten ..
Ähnliche Inhalte
Netzwerke
gelöst PC "verliert" Domänennetzwerk bei mehreren IPs auf (dem) einen NIC des PCs (4)

Frage von Overload zum Thema Netzwerke ...

Switche und Hubs
Welche IPs am Switchport (19)

Frage von rudeboy zum Thema Switche und Hubs ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...

Neue Wissensbeiträge
Windows Installation

Unorthodoxer Weg, um an einen Offline-Installer für Adobe Flash zu kommen

(8)

Tipp von beidermachtvongreyscull zum Thema Windows Installation ...

Datenschutz

Gefährdeter Datenschutz: Firefox löscht lokale Datenbanken nicht

Information von BassFishFox zum Thema Datenschutz ...

Firewall

PfSense OpenVPN beschleunigen

Tipp von Dobby zum Thema Firewall ...

Utilities

CCleaner 5.33 mit Malware infiziert

(27)

Information von SeaStorm zum Thema Utilities ...

Heiß diskutierte Inhalte
Utilities
CCleaner 5.33 mit Malware infiziert (27)

Information von SeaStorm zum Thema Utilities ...

Festplatten, SSD, Raid
gelöst Problem mit DELL 815R Server und Windows Bluescreen (24)

Frage von Leo-le zum Thema Festplatten, SSD, Raid ...

Windows Systemdateien
Windows bootet nicht mehr Fehlermeldung 0xc0000098 (19)

Frage von franzgoerlich zum Thema Windows Systemdateien ...

Windows Netzwerk
Dateien mit Intelligenz per GPO ins Programmverzeichnis (14)

Frage von erwin.t zum Thema Windows Netzwerk ...