Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wie konfiguriere ich einen Gateway-Server unter Ubuntu Server 10.04 richtig und sicher?

Frage Linux Ubuntu

Mitglied: JT-131

JT-131 (Level 1) - Jetzt verbinden

07.11.2011, aktualisiert 15:32 Uhr, 5394 Aufrufe, 2 Kommentare

Hallo zusammen,
ich habe mal wieder ein kleines Problem bzw. eine Frage zu einem Ubuntu-Server.

Zu meinem System bzw. Netzwerk.

IPs:
Router -> 192.168.0.1
Notebook im Netz per WLAN -> 192.168.0.101
Ubuntu Server eth0 -> 192.168.0.105
Ubuntu Server eth1 -> 192.168.1.1 mit DHCP Range 192.168.1.2 - 192.168.1.4 ( Da eine Testumgebung )
Test PC IP vom DHCP -> 192.168.1.2


Auf meinem Ubuntu-Server 10.04 soll ein Gateway-Server konfiguriert werden undzwar soll der Test PC eine IP vom DHCP des Servers bekommen und über eth0 ins Internet gehen...
Mein Problem derzeit ist, der Test-Pc kann jeden beliebigen Rechner in beiden Netzen pingen, allerdings nur weche aus dem 192.168.1.0 Netz können auch ihn pingen...
Ins Internet geht er gar nicht...

Bisher habe ich ip-forwading aktiviert unter:
/proc/sys/net/ipv4/ip_forward

und sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

Vielleicht habe ich ja auch die Netzwerk-Interface falsch konfiguriert?
Hier die konfiguration:

auto eth0
iface eth0 inet static
address 192.168.0.105
network 192.168.0.1
netmask 255.255.255.0
broadcast 192.168.0.255
gateway 192.168.0.1

auto eth1
iface eth1 inet static
address 192.168.1.1
network 192.168.1.0
netmask 255.255.255.0
broadcast 192.168.1.255
gateway ?? # Vielleicht liegts ja hier am nicht eingetragenen Gateway... Wobei ich da auch gerade auf dem Schlauch stehe was da eingetragen werden soll...



Wäre nett wenn mir jemand helfen könnte

Liebe Grüße
JT-131
Mitglied: nxclass
07.11.2011 um 16:33 Uhr
Evtl reicht Dir ja schon mal ein kleiner Link: http://wiki.ubuntuusers.de/Dnsmasq#Gateway
Bitte warten ..
Mitglied: JT-131
07.11.2011 um 16:53 Uhr
Mh, DHCP funktioniert ja anscheinend also die Rechner ziehen sich die passenden IPs...
Vermutlich liegt es an den iptables die ich gesetzt habe...

Woran könnte es sonst noch liegen außer an den geposteten sachen?

Eventuell könnte man das Problem ja auch mit Routen lösen, da weiß ich aber leider nicht wie das geht...
Hier einmal ein Ausschnitt aus "route -n":

Ziel.....................Router.............Genmask............Flags.Metric...Ref&Use.....Iface
192.168.1.0......0.0.0.0.............255.255.255.0....U........0...........0....................eth1
192.168.0.0......0.0.0.0.............255.255.255.0....U........0...........0....................eth0
0.0.0.0................192.168.0.1...0.0.0.0..................UG.....100......0....................eth1
0.0.0.0................192.168.0.1...0.0.0.0..................UG.....100......0....................eth0
0.0.0.0................192.168.1.1...0.0.0.0..................UG.....100......0....................eth1


Ist da was falsch dran?
Ich hoffe man kann es lesen...
Bitte warten ..
Ähnliche Inhalte
Linux Netzwerk
gelöst Brücke br0 erstellen mit eth1 und wlan0 unter Ubuntu-server 16.04 (2)

Frage von dysti99 zum Thema Linux Netzwerk ...

Ubuntu
gelöst Nextcloud Snap 11.01 Ubuntu Server 16.04 files antivirus keine Funktion (1)

Frage von horstvogel zum Thema Ubuntu ...

Windows Server
Windows Server 2016 VPN richtig konfigurieren (1)

Frage von junior zum Thema Windows Server ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...