Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Konfigurieren von PPP over Ethernet - Cisco Router

Frage Netzwerke Router & Routing

Mitglied: emporio-divine

emporio-divine (Level 1) - Jetzt verbinden

06.08.2008, aktualisiert 07.08.2008, 8200 Aufrufe, 8 Kommentare

Hallo folks

habe hier einen Cisco Router 800 Serie stehen und bin auf ein paar Probleme bei der Konfiguration gestoßen.

Also das grundlegende Problem ist: der Router hat ein integriertes ADSL Modem aber ich möchte mich mit SDSL verbinden.
Jetzt gibt es die Möglichkeit einen Standard Ethernet Port so zu konfigurieren dass darüber die PPP Verbindung läuft.


Hier mal die config soweit:
01.
interface FastEthernet3 
02.
 description Switchport 
03.
 duplex half 
04.
 pppoe enable group global 
05.
 pppoe-client dial-pool-number 1 
06.
 no cdp enable 
07.
08.
interface Vlan1 
09.
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$ 
10.
 ip address 10.100.1.3 255.255.252.0 
11.
 ip nat inside 
12.
 ip virtual-reassembly 
13.
 ip tcp adjust-mss 1412 
14.
15.
interface Dialer1 
16.
 ip address negotiated 
17.
 ip accounting output-packets 
18.
 ip mtu 1492 
19.
 ip nat outside 
20.
 ip virtual-reassembly 
21.
 encapsulation ppp 
22.
 dialer pool 1 
23.
 dialer remote-name GDJSDSL 
24.
 dialer enable-timeout 1 
25.
 dialer-group 1 
26.
 no cdp enable 
27.
 ppp authentication chap callin 
28.
 ppp chap hostname feste-ip5/XXXXXXXXXX@t-online-com.de 
29.
 ppp chap password 7 XXXXXXXXXXX
Das funktioniert soweit.
Jetzt das eigentliche Problem:
Ich muss jetzt quasi das FastEthernet3 in das Vlan1 integrieren.
Das soll über ein Virtual Private Dial up Network funktionieren (VPDN)
Aber sobald ich eine VPDN Gruppe erstellen will kommt dieser hier:

01.
Router(config)#vpdn group 1 
02.
03.
% Invalid input detected at '^' marker.

Was ich im Endeffekt brauche:
Ich muss die Adresse konfigurieren wohin die Anfragen getunnelt werden - also quasi ins VLAN1
Momentan hab ich zwar ne verbindung mit dem SDSL aber ich kanns nicht nutzen weil die beiden Ports nicht miteinander "verknüpft" sind.

Ich hoffe jemand versteht mein anliegen :/
Mitglied: Arch-Stanton
06.08.2008 um 17:55 Uhr
Ich denke nicht, daß ich mich irre, wenn ich sage, daß Du einen SDSL-Router brauchst. Im Normalfall stellt der Provider dieses Gerät und richtet es so ein, daß Du Deinen eigenen Router dahinter stellst und alle Anfragen auf Deine Kiste weitergeleitet werden.

Gruß, Arch Stanton
Bitte warten ..
Mitglied: aqui
06.08.2008 um 18:16 Uhr
Aber auch wenn es klappen sollte ist es Unsinn was du oben schreibst denn der Router ist ein ROUTER !! und kann natürlich zwischen beiden Interfaces routen !!

Du hast ja bei VLAN auch richtig ip nat inside und beim Daler Interface ip nat outside konfiguriert so das das sauber funbktionieren sollte !!

Vermutlich hast du nur dem NAT Prozess vergessen zu sagen WAS er NATen soll mit

ip nat inside source list 101 interface Dialer1 overload
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 101 permit ip 10.100.0.0 0.0.3.255 any


Damit sollte es einwandfrei klappen !
Bitte warten ..
Mitglied: emporio-divine
07.08.2008 um 08:08 Uhr
Aber auch wenn es klappen sollte ist es Unsinn was du oben schreibst denn der Router ist ein ROUTER !! und kann natürlich zwischen beiden Interfaces routen !!
Was ist Unsinn?



Stimmt ich habe dem NAT noch nicht gesagt was er NATen soll.
Hab das jetzt mal so übernommen, funktioniert aber leider immer noch nicht.
Vielleicht hab ich noch was anderes vergessen?

was ich nicht verstehe: 0.0.3.255 ???
Bitte warten ..
Mitglied: aqui
07.08.2008 um 09:22 Uhr
Unsinn ist das du keine Verbindung zw. LAN und DSL hast. Ein Router routet immer dazwischen und du hast ja einen Router mit dem Cisco....

Die 0.0.3.255 ist die inverse Maske zur Subnetzmaske deines LANs was ja den NAT inside Prozess macht !!! Sie gibt dem NAT Prozess die Range mit mit welchen Adressen der NAT inside Prozess laufen soll !!

Dort auf deinem LAN Interface hast du ja das Netz 10.100.0.0 mit einer 22 Bit Maske (255.255.252.0) wie du ja an deiner Konfig oben selber sehen kannst. Damit hast du nutzbare Endadressen von 10.100.0.1 bis 10.100.3.254 !!!

255.255.252.0 ergeben invers 0.0.3.255 wie du ja sicher selber weisst wenn du binär rechnest ! Daher diese etwas krumme inverse Maske, die aber aus deiner 22 Bit Maske vom 10.100.0.0 Netzwerk resultiert.

Noch ein Tip:
Meist gibt man dem Router die unterste oder die oberste Adresse in seinem IP Adressbereich auf dem LAN, damit er nicht mitten drin ist im Hostbereich wie bei dir.
Das wäre dann die 10.100.0.1 /22 oder eben die 10.100.3.254 /22 auf dem Cisco um es sauber zu haben und die Gefahr einer Überschneidung zu minimieren !!
Letztlich aber kosmetisch. Wenn dir die .1.3 besser gefällt funktioniert das auch...
Bitte warten ..
Mitglied: emporio-divine
07.08.2008 um 09:55 Uhr
Danke für die kurze Erklärung.
Hab mir schon sowas in der Art gedacht.
Beim Subnetting bin ich noch nicht vollends durchgestiegen, muss immer noch in diversen Hilfen nach schauen: "Wie war das nochmal?"

Wenn ich die 255.255.252.0 binär rechne komme ich auf: 11111111.11111111.11111100.0
Aber wie rechne ich binär invers?
255.255.0.0 wäre 0.0.255.255?
255.255.255.0 wäre 0.0.0.255?

Der NAT inside Prozess verwendet inverse Masken - NAT outside in diesem Fall revers. Weißt du warum?
Oder sollte ich mir zu dem Thema vielleicht doch besser noch mal ins NATing einlesen :P


Zu deinem Tipp.
Danke.
Leider sind 10.100.0.1 und 10.100.0.2 schon durch 2 andere Router belegt


Nochmal zu meinem Problem:
Ich finds auch Unsinn dass ich keine Verbindung bekomme.
Der Dialer1 wählt sich ja ein und erhält die feste IP Adresse von der TCom.
Das Modem ist an den IF FE 3 angeschlossen.
Das Vlan1 an den IF FE 0.

Interface Dialer1 ist in der source-list 101
und mit "access-list 101 permit ip 10.100.0.0 0.0.3.255 any" hat er ja auch die route.

Die Firewall hab ich vorerst deaktiviert, damit ich sicher sein kann dass die vielleicht doch nicht was blockt.

Wie gesagt ich finds auch Unsinn und ich bekomm hier noch die Kretze weils nich funktioniert ^^

Ok nochmal ganz nüchtern - was könnte noch eine Fehlerquelle sein, oder wo könnte ich ansetzen?
Bitte warten ..
Mitglied: aqui
07.08.2008 um 10:12 Uhr
Deine obige Masken Rechnung ist richtig !!!

Das wird deswegen so bei Cisco angegeben weil diese IP Adressen durchgelassen werden. Die Maske wird binär verknüpft mit der Regel der ACL und da müssen diese Bits eben auf 1 stehen !

"....Leider sind 10.100.0.1 und 10.100.0.2 schon durch 2 andere Router belegt..."

Kein Problem: Dann nimmst du eben die oberste IP Adresse die 10.100.3.254 !!!


Troubleshooting:
Wenn du die PPPoE Verbindung über den Dialer 1 etabliert hast (show int dialer 1) und auf dem Router drauf bist kannst du dann diese IP Adresse pingen ??

Kannst du vom Router IP adressen im 10.100.0.0 /22 Netz pingen ??

Kannst du vom 10.100.0.0er Netz den Router pingen und auch die IP vom Dialer 1 Interface ??

Hast du "ip nat inside source list 101 interface Dialer1 overload" konfiguriert ??

Was ergibt bei dir ein ""debug dialer packets" oder debug ip nat" ??
(Achtung: Danach unbedingt wieder "undebug all" eingeben !!!)
Bitte warten ..
Mitglied: emporio-divine
07.08.2008 um 10:35 Uhr
Wenn du die PPPoE Verbindung über den Dialer 1 etabliert hast (show int dialer 1) und auf dem Router drauf bist kannst du dann diese IP Adresse pingen ??

01.
ROUTER#show int dialer 1 
02.
Dialer1 is up (spoofing), line protocol is up (spoofing) 
03.
  Hardware is Unknown 
04.
  Description: SDSL 
05.
  Internet address will be negotiated using IPCP 
06.
  MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
07.
>t clearing of "show interface" counters 16:01:21 
08.
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
09.
  Queueing strategy: weighted fair 
10.
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
11.
     Conversations  0/0/16 (active/max active/max total) 
12.
     Reserved Conversations 0/0 (allocated/max allocated) 
13.
     Available Bandwidth 42 kilobits/sec 
14.
  5 minute input rate 0 bits/sec, 0 packets/sec 
15.
  5 minute output rate 0 bits/sec, 0 packets/sec 
16.
     0 packets input, 0 bytes 
17.
     0 packets output, 0 bytes
Du meinst die öffentliche WAN-IP ?
>"nicht erreichbar"

Kannst du vom Router IP adressen im 10.100.0.0 /22 Netz pingen ??
Ja

Kannst du vom 10.100.0.0er Netz den Router pingen und auch die IP vom Dialer 1 Interface ??
vom 10.100.0.0er Netz kann ich den Router pingen aber die IP von Dialer 1 IF nicht.
Dialer 1 hat ja auch keine IP adresse. Wenn dann nur die ausgehandelte vom Provider.

Hast du "ip nat inside source list 101 interface Dialer1 overload" konfiguriert ??
Ja

Was ergibt bei dir ein ""debug dialer packets" oder debug ip nat" ??
(Achtung: Danach unbedingt wieder "undebug all" eingeben !!!)
Keine veränderung

Liegt wohl am dialer 1?
Ich würde jetzt das lo0 konfigurieren...! ???
Bitte warten ..
Mitglied: emporio-divine
07.08.2008 um 14:12 Uhr
Ich hab jetzt alles über den haufen geworfen.
Weil ich von Cisco erfahren habe dass das mit dem Router nicht möglich ist.
Ich müsste ein Switch anhängen und die Schnittstelle als Trunk konfigurieren.
2 Vlans einrichten und die Route entsprechend setzen.
Da die Lösung aber auf langfristige Sicht nur Probleme machen wird hab ich jetzt nen 851 Route angehängt mit Wan-Interface.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
VoIP hinter Cisco Router (23)

Frage von PharIT zum Thema Router & Routing ...

Netzwerkmanagement
SSH auf Cisco Router aktivieren, allerdings ohne line vty (8)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Router & Routing
gelöst Cisco Router C886VAJ-K9 WLAN? (19)

Frage von oce zum Thema Router & Routing ...

Router & Routing
Übungen zu Cisco Router Konfiguration (3)

Frage von M.Marz zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...