Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kopieren auf Freigabe unter VMware bringt Fehlermeldung nnn kann nicht kopiert werden Pfad zu lang

Frage Microsoft Windows Netzwerk

Mitglied: 50tausend

50tausend (Level 1) - Jetzt verbinden

05.09.2008, aktualisiert 06.09.2008, 8927 Aufrufe, 1 Kommentar

Kopieren auf Freigabe unter VMware bringt Fehlermeldung 'nnn kann nicht kopiert werden: Pfad zu lang'

Dirngende Hilfe benötigt... Hallo an alle:
Ich habe einen neuen PC mit VMware-Server ausgerüstet um verschiedene Testszenarien schnell parat zu haben. Die Installation war soweit auch Problemlos; ich will damit sagen, dass zu Anfang keine Netzwerkprobleme auftraten.
Irgendwann und warum auch immer, funktionierte die Anwendung auf der VMware nicht mehr richtig. Die Dateien die ich auf die VM übertrage bleiben ca. 10 Sekunden von dem 'Sender' geöffnet'. Damit ich die Sache etwas einfacher kontrollieren kann habe ich eine Freigabe auf der VM eingerichtet mit folgenden Parametern:
- Freigabe: Jeder, Ich, Admin's Vollzugriff
- NTFS-Berechtigung: Jeder, Ich, Admin's, System: Vollzugriff
Das Netz ist ganz simpel:
VM:
- 192.168.2.40 255.255.255.0
- Arbeitsgruppe: AG
- Firewalldienst ist deaktiviert
- WinXP Pro SP2
Host
- 192.168.2.30 255.255.255.0
- Arbeitsgruppe: AG
- Firewall: Kaspersky 2009 (war zu Testzwecken auch schon deaktiviert) Einstellung: Vertrauenswürdiges Netzwerk (lässt also den gesamten Datenverkehr zu)
- WinXP Pro SP3

So nun zum Fehler: auf dem Host habe ich eine Verknüpfung zu der Freigabe angelegt. Kopiere ich nun Dateien in diese Freigabe passiert folgendes:
Host:
- die Datei erscheint nicht in dem Verzeichnis
- es erscheint beim Aktualisieren der Ordneransicht die Eieruhr über dem Ordner
- nach ca. 10 Sekunden erhalte ich die Fehlermeldung 'nnn kann nicht kopiert werden: Pfad zu lang' (um es gleich zu sagen: der Pfad ist weder zu lang noch mit Sonderzeichen versehen: \\VMname\Marktplatz

VM:
- die Datei erscheint sofort im Verzeichnis
- die Datei wird weiterhin als geöffnet gekennzeichnet unter Computerverwaltung > Freigegebene Ordner > Geöffnete Dateien
- nach den o.g. 10 Sekunden ist die Datei nicht mehr durch den User des Hosts geöffnet
- eine kleine Datei (TXT mit 3k) wurde steht fehlerfrei zur Verfügung, größere Zip's oder PDF's mit 100k sind korrupt.

Weitere Konfigurationen:
VMware:
- Ethernet Bridged; Connected
- die VMware ist installiert auf dem Host mit WinXP SP3

Das habe ich schon geprüft:
- Ping ist ok
- Namensauflösung funktionierte gestern nicht, jetzt klappts auf einmal !?!?!? In der Netzwerkumgebung erscheinen beide Arbeitsplätze
- Netztransfer mit Packetyzer (Ethereal) überprüft. Ich kann dazu aber nur sagen, dass eine Menge SMB-Pakete auf dem VM ankommen, dass darauf geantwortet wird und die letzten beiden Pakete folgende sind:
- von .40 nach .30 - TCP: [TCP Dup ACK 6646#1] netbios-ssn > 1029 [ACK] ...
- von .30 nach .40 - TCP: [TCP ACKed lost segment] 1029 > netbios-ssn [RST] ...
- alle Netzwerkeinstellungen sind mehrmals geprüft.

Jetzt fällt mir gerade ein, dass ich wegen Platzproblemen auf einer Partition diese VM verlegt habe und mit 'Keep' in der VMware bei der Neueinrichtung die Verlegung bestätigt habe. Es könnte sein, dass dieses Problem zeitlich damit in Verbindung stehen könnte.

Der Vollständigkeit wegen hier die Konfigurationsdateien der VMware:

.vmdk:
  1. Disk DescriptorFile
version=1
CID=4abf5de5
parentCID=ffffffff
createType="monolithicFlat"

  1. Extent description
RW 83886080 FLAT "Windows XP Professional-flat.vmdk" 0

  1. The Disk Data Base
#DDB

ddb.virtualHWVersion = "4"
ddb.geometry.cylinders = "16383"
ddb.geometry.heads = "16"
ddb.geometry.sectors = "63"
ddb.adapterType = "ide"
ddb.toolsVersion = "6534"

.vmsd:
snapshot.lastUID = "8"
snapshot.numSnapshots = "1"
snapshot.current = "8"
snapshot0.uid = "8"
snapshot0.filename = "windows xp professional-Snapshot8.vmsn"
snapshot0.displayName = "VMware Server Undopoint"
snapshot0.description = "VMware Server 1.0.6 build-91891"
snapshot0.type = "1"
snapshot0.createTimeHigh = "284121"
snapshot0.createTimeLow = "900877184"
snapshot0.numDisks = "1"
snapshot0.disk0.fileName = "Windows XP Professional.vmdk"
snapshot0.disk0.node = "ide0:0"

snapshot1.uid = "8"
snapshot1.filename = "windows xp professional-Snapshot8.vmsn"
snapshot1.parent = "7"
snapshot1.displayName = "VMware Server Undopoint"
snapshot1.description = "VMware Server 1.0.6 build-91891"
snapshot1.type = "1"
snapshot1.createTimeHigh = "284121"
snapshot1.createTimeLow = "900877184"
snapshot1.numDisks = "1"
snapshot1.disk0.fileName = "Windows XP Professional-000001.vmdk"
snapshot1.disk0.node = "ide0:0"

.vmx
config.version = "8"
virtualHW.version = "4"
scsi0.present = "TRUE"
memsize = "768"
ide0:0.present = "TRUE"
ide0:0.fileName = "Windows XP Professional-000002.vmdk"
ide1:0.present = "FALSE"
ide1:0.fileName = "auto detect"
ide1:0.deviceType = "cdrom-raw"
floppy0.fileName = "A:"
Ethernet0.present = "TRUE"
displayName = "40 Archiv"
guestOS = "winxppro"
priority.grabbed = "normal"
priority.ungrabbed = "normal"

ide1:0.autodetect = "TRUE"

workingDir = "."
ide0:0.redo = ""
ethernet0.addressType = "generated"
uuid.location = "nn nn nn nn nn nn nn nn-nn nn nn nn nn nn nn nn"
uuid.bios = "nn nn nn nn nn nn nn nn-nn nn nn nn nn nn nn nn"
ethernet0.generatedAddress = "00:0c:29:6a:aa:f4"
ethernet0.generatedAddressOffset = "0"

ide1:0.startConnected = "TRUE"

tools.syncTime = "TRUE"

usb.present = "FALSE"

usb.autoConnect.device0 = ""

numvcpus = "1"
ide1:0.exclusive = "FALSE"
floppy0.startConnected = "FALSE"

checkpoint.vmState = ""
checkpoint.vmState.readOnly = "FALSE"

ethernet0.connectionType = "bridged"
ethernet0.vnet = "VMnet0"

floppy0.present = "FALSE"
Mitglied: 50tausend
06.09.2008 um 10:18 Uhr
Bei der Fehlersuche konnte ich jetzt einiges Ausschließen:
Ein weiterer VMware-Client kan problemlos Daten senden, löschen und empfangen aus dieser Freigabe. Das gleiche gilt für einen physikalischen PC im Netzwerk.

Interessant ist, dass der Host zu einer Freigabe auf dem physikalischen PC problemlos Dateien senden kann.

Also kann der Fehler nur noch an der Verbindung zwischen Host und VMware zu suchen sein.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Vmware
VMWARE 5.50: von USB Platte VM auf den Datastore kopieren (1)

Frage von l.scheper zum Thema Vmware ...

Windows 10
Fehlermeldung Pfad nicht verfügbar (2)

Frage von Stefan.Brandl zum Thema Windows 10 ...

Netzwerkmanagement
NLB mit SMB Freigabe ist nicht in der Netzwerkumgebung sichtbar (1)

Frage von Gissmo85 zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...