Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kopieren von großen Dateien sehr langsam

Frage Microsoft Windows Server

Mitglied: uhau007

uhau007 (Level 1) - Jetzt verbinden

01.10.2012 um 14:47 Uhr, 13544 Aufrufe, 22 Kommentare

Hoi,

ich muß das Problem leider hier nochmal aufgreifen.
Wenn man große Dateien auf einen Windows Server 2008 R2 kopiert hab ich schon immer (seit es 2008 gibt) das Problem, das die Geschwindigkeit unter aller Sau ist.

Also immer neue Treiber, autotuninglevel aus usw gemacht. Dann bekommt man ja die Geschwindigkeit einigermassen in den Griff, wobei ich bis heute nicht verstehe warum ich dann mit 8-9MBit/s in einem Giga Netz rumkopieren muß das im Grunde 80-90 schaffen sollte.

Viel hab ich da bisher in alte Infrastruktur hineininterpretiert. Alte Switche, alte Kabel usw.

Jetzt bin ich tatsächlich an einer Baustelle wo ALLES funkelnagel neu ist.

Ein Windows 2003 Server und ein Windows 2008 R2 Server ich kopiere von 2003 nach 2008 eine 200GB Datei es startet mit 20MBit/s und falle innerhlb der 1 Minute auf 600KBit/s.

Also die alte Leier (Treiber waren neu) autotuninglevel ausgeschaltet Prüfsummen deaktiviert usw.

Dann startet das kopieren mit 80MBit/s (oh, Wunder es geht doch) nach ca 5 Min fällt die Rate auf 35MBit/s und nach weiteren 15 min auf 12MBit/s. Danach pendelt sich das ganze bei bei 9MBit/s ein. So werden aus den am Anfang angezeigten groben MS Schätzungen der Gesamtdauer von 40min am Ende doch 4:35 Stunden.

Woran kann den das jetzt noch liegen? Ich hab keine Idee warum es immer langsamer wird. Schreibcache der Festplatten wäre ja schon viel früher voll und nicht erst nach 5min bzw. dann nach 20 min richtig voll.

Jemand eine Idee?


Gruß
Uwe

Mitglied: Lochkartenstanzer
01.10.2012 um 14:57 Uhr
Zitat von uhau007:
Jemand eine Idee?


Moin,,
hast Du schonmal Rohdatenraten mit NetIO gemessen? Werden die 80MB/s wirklich erreicht? ich denke das sind eher Cache-effekte. es ist typeisch, dafür, daß die mit hohen Werten losgehen und dann die druchschnittliche Transferrate stetig runtergeht, weil die Anzeige nur den durchschnitt zeigt und nicht den aktuellen wert.

lks
Bitte warten ..
Mitglied: uhau007
01.10.2012 um 15:14 Uhr
Mit NetIO hab ich es nicht gemessen, aber zw. 2 Debian (gleiche Hardware nicht die selbe) braucht es 51min.
Wenn ich über den Totalcommander den Festplattenplatz anschaue, werden in den ersten 5min (80MBit/s) auch tatsächlich 18GB der Datei übertragen. Es müssten zwar (theoretisch) 24GB sein aber mit 18 in 5min wäre ich ja höchst zufrieden wenn es permanent wäre.

Das mit dem Durchschnitt dachte ich auch, aber es ist auffällig, das es ca 5min 75-80 hält und dann sehr schnell auf 35 abfällt, die hält er dann ca 15min um dann wieder schnell auf 12 zu fallen.
Bitte warten ..
Mitglied: wiesi200
01.10.2012 um 15:41 Uhr
Hallo,
also nur so nebenbei. Die von dir angepeilten Werte krieg ich zusammen.
Nur ist auf der einen Seite ein großes SAN und auf der anderen eine SSD.
Bitte warten ..
Mitglied: uhau007
01.10.2012 um 15:50 Uhr
Ok, ist aber momentan bei mir so.
Und rein rechnerisch sollte es ja auch funktionieren.
Vielleicht muß ich ja die Frage anders stellen.

Wielange braucht ihr den um eine 200GB Datei von einem Server auf den anderen in einem Gigabit Lan zu kopieren?
Theoretisch sollte es ja gehen (und geht auf den Debians ja auch und die haben auch nur SAS Platten)
Bitte warten ..
Mitglied: MrNetman
01.10.2012 um 16:08 Uhr
Die Geschwindigkeit zu ereichen ist eigentlcih keine Hexerei.

80Mbit/s bekomme ich sogar aufs Notebook. Mit Fast Ethernet.
Aber ich hatte auch lange Probleme mit der Geschwindigkeit, es waren um die 12MBit/s. Bis ich dann das Notebook komplett neu aufgesetzt und alle Treiber von Hand eingespielt habe. Jegliches Recovern hat das nicht geschafft.

Die neueste Hardware aus der obigen Beschreibung stammte aus dem Jahr 2005.

Gruß
Netman
Bitte warten ..
Mitglied: NetWolf
01.10.2012 um 18:32 Uhr
Grüß Gott,

sorry, wir wissen zu wenig über deine Umgebung.

Vermutlich wird es bei dir ähnlich wie bei vielen anderen sein: die Anti-Virus-Programme auf beiden Servern bremsen die Geschwindigkeit.

Bedenke: deaktivieren bringt keine Änderung, erst Deinstallieren bringt eine merkliche Änderung!!

Grüße aus München
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: Lochkartenstanzer
01.10.2012 um 18:35 Uhr
Zitat von uhau007:
Mit NetIO hab ich es nicht gemessen, aber zw. 2 Debian (gleiche Hardware nicht die selbe) braucht es 51min.

Dann soltlest Du vielleicht Netio o.ä anschmeißen und die Durchsätze mit TCP/UDP und NetBIOS messen.

Dann hat man mal einen Anhaltswert.

lks
Bitte warten ..
Mitglied: Dobby
01.10.2012 um 19:36 Uhr
Hallo uhau007,

der Vorredner NetWolf hat da schon den Antivirenscanner angesprochen, das ist das eine, aber wie sieht es denn nun wirklich mit Deinem Server aus sag doch bitte einmal etwas zu der Hardware Ausstattung des Servers und den Aufgaben die der Server alle übernimmt bzw. die Dienste die der Server bereitstellt und bitte auch für wen und wie viele!!!!!!!!

- Server Hardware CPU/RAM/HDD/NIC´s
- xyz Mitarbeiter
- xyz Dienste
- xyz Netzwerkkarten
- xyz Switche Layer 2 oder 3, Verwaltbar, mit LAG Unterstützung, Blockierend oder nicht?

1. Also wenn Du eine so große Datei hast oder mehrere Dateien, könnte man doch dem Antivirus sagen (einstellen) das er nur Dateien bis xyz MD/GB scannen soll.

2. Schon einmal was von Jumboframes gehört? Je größer die Pakete aufgeteilt sind um so schneller der
Versand und Empfang, nicht die Dateien selber!!!!!!
Am Server bitte Jumbo Frames auf 16128 Byte einstellen, am Switch und den dazu gehörigen Ports ebenso und dann zum Schluss auf den Klient PC´s

3. Hat der Server mehrere Netzwerkkarten und Du kannst dort ein LAG aufsetzen bringt das auch noch einmal "Dampf" auf die Leitung mal eine 10K drehende Platte als Cache und Temp Verzeichnis in den Server gesteckt oder sogar zwei (bitte kein Raid 0 anlegen)

4. Mehr Speicher in den Server einbauen und vor allen anderen Dingen wenn es denn möglich ist
ECC/REg. oder so genannten "Server RAM" (viel mehr)

5. Mal an andere Netzwerkkarten gedacht 10 GB Fiber Karten (FC´s)

6. Die Switche stapeln (stacken) und keine Kupfer uplinks

7. Schnellere Festplatten im NAS / Server verbauen

8. Einen guten Raid Controller verbauen mit üppigem Cache

9. Einen Layer drei Switch organisieren und nicht nur alles den Router oder die Firewall erledigen lassen. Verwaltbar, stapelbar, nicht blockierend!!!!

10. Netzwerk Topologie überdenken und DMZ anlegen damit nicht der gesamte Netzwerkverkehr ins LAN
läuft und die Switche überlastet!!!!

11. Den Klient PC bessere Netzwerkkarten und mehr RAM spendieren

Puh so das war ja ein Ritt, also einige Sachen lassen sich alleine erledigen und bringen etwas, aber
wiederum einige andere Punkte sollten nur in Kombination mit anderen Punkten richtig greifen.

So und nun lass mal was von Dir hören.

Aber bitte nicht Single Core CPU / 2 GB RAM / Netzwerkkarten für den PC und der Switch ist ein dummer
Switch, also nicht einmal ein SmartSwitch.

Gruß
Dobby
Bitte warten ..
Mitglied: uhau007
01.10.2012 um 20:06 Uhr
Also zur Hardware (Alle 4 Server sind Baugleich) Die AD läuft auf dem 2008 R2
Fujitsu RX300 S7
2 x 6C Xeon E5-2630
2x 8 GB DDR3 1600 R ECC
Festplatte 6x600GB SAS 6G 10k 2,5''
RAID Ctrl SAS 6G 5/6 512MB

Der Switch ist ein
HP 5120-24G EI Switch (Der ist Layer 3)

Das Zeug steht momentan nur zum Testen dieses Problems da.
Switch
2 Netzwerkkabel (neu Cat6a) 1m
die 4 Server (2x Windows, 2x Debian) aber immer nur jeweils 2 angeschlossen
Kein Router, kein Internet
Deshalb auch kein Virenscanner
Außer AD und DNS nichts installiert.
Win 2003 R2 als Memberserver in der AD
Feste IP`s

Jetzt bin ich nicht mehr vor Ort, aber morgen früh werf ich NetIO an.
Das mit den Jumbo Frames werd ich auch noch testen, ich hab aber gelesen, das das dann wiederrum Probleme beim Netzverkehr mit DB`s macht.
Und der Sinn dahinter ist ja nicht diese Testumgebung schnell zu bekommen sondern herauszufinden was man in Produktiv Umgebungen besser machen kann und da findet dann natürlich auch noch anderer Verkehr statt.

Gruß
Uwe
Bitte warten ..
Mitglied: MrNetman
01.10.2012 um 20:09 Uhr
200GByte Datei hatte ich doch beinahe überlesen.
Was soll das sein?
Praxis oder Test?
Normalerweise braucht kein OS mit solchen Dingern umgehen.

Gruß
Netman
Bitte warten ..
Mitglied: uhau007
01.10.2012 um 20:23 Uhr
Das ganze soll am WE .vmdk (VMWare virtuelle Festplatten) hin und her schupsen.

Momentan in dieser Testumgebung (Die ja fast volle Leistung bringen sollte, da ja sonst nichts los ist)

Vielleicht gehts aber auch einfach ums Prinzip.
Teure Hardware (Sag nicht das das oben beschriebene aus dem Media Markt kommt) und eine einfache, messbare Funktion geht nicht. Bzw. geht für 5 min und dann gehts in den Keller.
Warum, ich will es verstehen.
Reicht uns das nicht einfach manchmal?

Gruß
Uwe
Bitte warten ..
Mitglied: Dobby
01.10.2012 um 21:10 Uhr
Hallo Uwe,

das mit den Jumboframes kann man doch auch austesten, zum Einen mit der Größe der Frames und zum Andren
wer diese aktiviert bekommt! Aber grundsätzlich würde ich das bei allen Servern, Switchen und Klient
PS´s einstellen! Denn der Verwaltungsaufwand wird geringer (Overhead) und somit das gesamte Netz für alle Beteiligten beschleunigt.

Mann kann auch LAG´s mit bis zu 8 Kabeln anlegen statisch oder Dynamisch.
Die CAT. 6a Kabel sind natürlich schon schön, aber alleine sind die nichts wert!
Meinst Du nicht das Du noch ein bisschen Speicher spendieren solltest?
Oder sollten die Platten schuld sein das nach 5 Minuten Schluss ist mit lustig????

Wie schon gesagt ein oder zwei Platten pro Server als zusätzliche Swap oder Temp Einheiten wären auch schön. Besonders unter Debian wäre es schön wenn Du zwei Swap Partitionen hast und diese auch noch ganz am Anfang der jeweiligen Festplatte anlegst!

Gruß
Dobby
Bitte warten ..
Mitglied: uhau007
01.10.2012 um 21:31 Uhr
das mit den Jumboframes kann man doch auch austesten

Werd ich machen

Mann kann auch LAG´s mit bis zu 8 Kabeln anlegen statisch oder Dynamisch.

Sorry, was ist ein LAG.

Die CAT. 6a Kabel sind natürlich schon schön, aber alleine sind die nichts wert!

Was meinst du mit alleine?

Meinst Du nicht das Du noch ein bisschen Speicher spendieren solltest?

16GB sind doch reichlich

Oder sollten die Platten schuld sein das nach 5 Minuten Schluss ist mit lustig????

Hab ich im verdacht, nur ist mir nicht klar warum dann nach 5min schluß ist. Das müsste doch bei Cacheproblemen schon viel früher anfangen


Wie schon gesagt ein oder zwei Platten pro Server als zusätzliche Swap oder Temp Einheiten wären auch schön.
Besonders unter Debian wäre es schön wenn Du zwei Swap Partitionen hast und diese auch noch ganz am Anfang der
jeweiligen Festplatte anlegst!

Unter Debian hab ich eine Swap. Aber dort besteht ja auch kein Problem. Wenn ich zw. den Windowsmaschinen die 51 min schaffe bin ich ja schon zufrieden. Aber 4:35h sind einfach zu viel.

Gruß
Uwe
Bitte warten ..
Mitglied: Lochkartenstanzer
01.10.2012 um 22:00 Uhr
Zitat von uhau007:
Unter Debian hab ich eine Swap. Aber dort besteht ja auch kein Problem. Wenn ich zw. den Windowsmaschinen die 51 min schaffe bin
ich ja schon zufrieden. Aber 4:35h sind einfach zu viel.


Für solche Fäle gibt es ja auch noch das turnschuhnetzwerK:

  • Hotplug-Padde in eine Kiste rein.
  • Alles draufgespielt (bei 200GB sollten da nicht viel mehr als 30 Minuten brauchen)
  • Pladde raus und in andere Kiste rein.

Wenn die nicht zu arg außeinanderstehen Bist Du unter den 50 Minuten.

BTW: Wie schnell ist denn der Platten-IO, d.h. wenn Du die 200MGB-Datei ganz nach /devb/null dumpst?

lks
Bitte warten ..
Mitglied: Dobby
01.10.2012 um 22:29 Uhr
Hallo Uwe,

Eine LAG ist eine Link Aggregation Group man bündelt Kabel zu einer einzigen fetten Leitung!
LAG Switch 1
LAG Switch 2
LAG Server


Die JumboFrames verkleinern den "Verbindungsaufwand", denn wenn die 200 GB von Dir, zu 5000 Paketen oder nur zu 100 Paketen aufgeteilt werden ist nicht egal, denn der "Verwaltungsaufwand" für das Senden und Empfangen und somit der gesamte anfallende so genannte "Overhead" fällt oder singt rapide und das beschleunigt die Verbindung mitunter immens!

Wie schon beschrieben, haben einige "Sachen" alleine einen gewissen Effekt bei Deinem "Problem" und mitunter nur in Kombination mit einigen anderen "Sachen" zusammen.

Wenn 16 GB reichlich sind und alle anderen von mir gemachten Angaben Dich nicht weiterbringen, aber
in Verbindung mit mehr RAM die ganze Sache auf einmal eine ganz andere Gestalt annimmt, weißt Du schon
einmal was ich mit "alleine" meinte und mit mehr RAM meine ich eben: " RAM kann nur durch eines ersetzt
werden und das ist noch mehr RAM." Gerade in Verbindung mit Deiner Datenbank von der ja auch oben im Beitrag nichts steht!!!!

Du hast natürlich recht, denn mit 16 GB RAM ist ein Server für gewisse Anwendungen und Dienste gut
gerüstet, aber Du kopierst hier mal eben 200 GB über das Netzwerk und nicht 5 GB bis 50 GB!!!!!!!

HP 5120-24G EI Switch (Der ist Layer 3)
Hast Du dir einmal überlegt das Du vielleicht auch zwei oder besser drei Switche stapelst und die Server an die Switche per LAG anbindest? Ist die Last vielleicht zu viel für den einem Switch und da sind die normalen Klient PC´s noch nicht mit drinnen!!!

Hab ich im verdacht, nur ist mir nicht klar warum dann nach 5min schluß ist. Das müsste doch bei
Cacheproblemen schon viel früher anfangen
Warum? Das fängt erst an wenn der Cache überläuft und nicht wenn er voll ist, sondern genau auf der anderen Seite wenn er weiter befüllt wird aber nicht schnell genug geleert wird!!

Wie groß ist denn Deine Auslagerungsdatei auf dem Server?
Man nimmt 1,5x dem Wert fix, des verbauten RAM´s als einen guten Mittelwert, aber bei Problemen kann man das auch erhöhen!!!
Ich würde das auf zwei weiteren Festplatten machen wollen und zwar immer auf der ganzen Festplatte
oder auf der ersten Partition.

Viele Wege führen zum Ziel ich denke das es bei Dir oder Deinem Problem nicht nur eine einzige Sache sein wird.

Gruß
Dobby
Bitte warten ..
Mitglied: MrNetman
02.10.2012 um 10:02 Uhr
wie kopierst du eigentlich?
Mit dem Windows Explorer und CIFS Protokoll?
Sind die VMs wirklich nicht aktiv?
Gibt es eine alternative Kopiermethode?

Die thoretische Bandbreite wird ja anfangs erreicht. Danach kommen andere Dinge zum Tragen, die nicht dem Netzwerk geschuldet sind. Was ist, wenn die TCP-Zähler Schierigkeiten bekommen? Eine Datei ist ein Stream. Soblad etwas stockt, muss wiederholt und angefragt werden.

Alternative Kopiermethden:
FTP
Downloadmanager
Teracopy

Gruß
Netman
Bitte warten ..
Mitglied: Wern2000
04.10.2012, aktualisiert um 14:56 Uhr
Bevor man an Tuning geht wäre fehlersuche angepasst.

Was passiert wenn Du die 200GB Datei auf einen normalen PC kopierst bzw zurück kopierst?

Schon mal im Tastmanager/Netzwerk nachgeschaut was wirklich durch geht?
habs eben mit einer 100GB Datei probiert anfangs auslastung ca 90-98% nach 3-4 Minuten dann bis zum schluss ca 50-70% auslastung.

schon mal einen anderen switch ausprobiert? Selbst ein noname 30€ 5 Port switch schaft bei einem user ca 100-110 MB/sek
schon mal eine andere Netzwerkkarte ausprobiert? Hatte schon eine NIC die bei großen Dateien fehler gemacht hat und das Ziel war dann beschädigt.
Flowcontroll zum Test ausgeschaltet?
greifen wärend der Datenübertragung andere User drauf zu? Wenn mehrere User gleichzeitig drauf zugreifen ist da ganz schnell nur noch die hälfte oder noch weniger möglich. Ganz böses Faul sind Defragmentierung, Indexerstellung, Backup. Dann sind oft nur noch 10MB/sek oder weniger möglich.


gruss
Bitte warten ..
Mitglied: uhau007
04.10.2012 um 15:30 Uhr
Hoi,

sorry, ich bin leider momentan krank und kann deshalb nichts testen.
Soweit ich es noch weis, zeigt es im Taskmanager/Netzwerk am Anfang 60% und fällt dann auf 12,5% ab.

Eine andere NIC hatte ich in dieser Testumgebung jetzt noch nicht.

Wo schalte ich den Flowcontrol aus? Auch im Netzwerkartentreiber?

Nein in dieser Umgebung gibt es keine anderen User. Alles andere ist auch ausgeschaltet.

Gruß
Uwe
Bitte warten ..
Mitglied: Wern2000
04.10.2012 um 15:55 Uhr
im Treiber und im Switch
schon mit crossover-kabel versucht um switch als fehlerquelle auszuschließen?
Bitte warten ..
Mitglied: Lochkartenstanzer
04.10.2012 um 16:40 Uhr
Zitat von Wern2000:
im Treiber und im Switch
schon mit crossover-kabel versucht um switch als fehlerquelle auszuschließen?

Heutztage benötigt man keine Crossover Kabel, wenn man keine Legacy-hardware hat.

lks
Bitte warten ..
Mitglied: Wern2000
04.10.2012 um 17:14 Uhr
sicher?
was ist wenn der Switch einen defekt hat der erst auftritt wenn viel traffik da ist?
Bitte warten ..
Mitglied: Lochkartenstanzer
04.10.2012 um 20:38 Uhr
Zitat von Wern2000:
sicher?
was ist wenn der Switch einen defekt hat der erst auftritt wenn viel traffik da ist?

Was hat ein Crossover Kabel mit eione defekt im switch zu schaffen? Selbst die Endgeräte könne alle, falls sie nicht gerade legacy-Hardware sind, auto mdi-x.


Natrülich sollte man auch mal unetr Ausschluß des swithces testen, aber dafür benötigt man keine Crossover-Kabel mehr.

lks
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Batch & Shell
USB - Autorun kopieren von Dateien (6)

Frage von draycon zum Thema Batch & Shell ...

Windows Server
Server sehr langsam bei vielen kleinen Dateien (5)

Frage von MichiBLNN zum Thema Windows Server ...

C und C++
Dateien in Ordner kopieren anhand vom Teil eines Dateinamen (22)

Frage von onlyforu8373 zum Thema C und C ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...