Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Kopieren eines Windows-7-Clients auf identische Hardware

Frage Microsoft

Mitglied: fabgg6

fabgg6 (Level 1) - Jetzt verbinden

14.10.2009 um 16:19 Uhr, 30228 Aufrufe, 26 Kommentare

Ich bin an einer Schule für die Administration der Rechner zuständig, bin aber weitgehend Autodidakt, wie viele meiner Kollegen.

Bisherige Installationen neuer Computer (oder von Rechnern mit schwerwiegenden Software-Fehlern) habe ich immer durch Anlegen eines Sysprep-Klones und dessen Verteilung mittels Boot-CD und Antwortdatei übers Netz vorgenommen. Bei Windows 9x und 2000 hat dies anstandslos geklappt. Bei XP wurde aber meine Antwortdatei ignoriert, was bei gerade mal 17 Installationen aber nicht so schlimm war. Jetzt kommen aber größere Mengen auf mich zu. Deshalb meine Fragen, auf die ich trotz Suche noch keine sicheren Antworten gefunden habe.

zu Windows XP:

1. Wo müsste die Antwort-Datei (erstellt mit setupmgr.exe vom 14.4.08) liegen und wie müsste sie heißen, damit sie garantiert gefunden wird?
2. Mit welchen Parametern müsste Sysprep.exe evtl. gestartet werden? (Ich hatte alles immer im Ordner C:\sysprep).

zu Windows 7:

3. Kann ich von meinem ideal installierten und vorkonfigurierten Rechner erneut mit einem beliebigen Image-Programm ein Abbild machen oder muss ich das Microsoft-Paket verwenden (Windows PE und ImageX aus dem WAIK).
4. Kann ich danach ebenso mit Sysprep (vermutlich neue Version) alle "individuellen" Einstellungen des Rechners löschen und das Image auf andere Rechner übertragen?
5. Reicht es dann, einen USB-Stick mit der Autoattend.xml (erstellt mit Windows System Image Manager für Windows 7) am zu installierenden Rechner zu verwenden bzw. heißt die Datei bei Windows 7 noch so?
6. Kann man Sysprep und den Windows SIM für Windows 7 irgendwo einzeln herunterladen oder gibt's das nur im WAIK-Paket (KB3AIK_DE.iso)?

Es wäre schön, wenn jemand die eine oder andere Frage sicher beantworten könnte. Sonst muss ich demnächst wohl einfach probieren.

Grüße, GG.
Mitglied: fabgg6
14.10.2009 um 19:51 Uhr
Nach etwas Recherche würde ich nun auf Frage 1 antworten, dass sysprep.inf tatsächlich im Verzeichnis c:\sysprep liegen sollte. Es gibt nur offenbar einige Änderungen zur Windows-2000-Version, so dass einige Einstellungen nicht mehr automatisch vorgenommen werden.

Auf Frage 2 würde ich antworten, dass sysprep für den Willkommensbildschirm oder ein Mini-Setup gestartet werden muss. Ausprobieren kann ich das hier zuhause nicht. Was passiert, wenn man sysprep ohne Parameter startet, steht natürlich nirgendwo.

Zu den weiteren Fragen lese ich gerade http://wiki.winboard.org/index.php/Windows_7_verteilen.

Mal sehen...

Edit (2009-10-14-23:07)

So, ich habe mir jetzt einen groben Überblick verschafft und finde das Verfahren ein wenig verwirrend. Wie soll ich zuerst eine Antwortdatei erstellen, wenn ich noch gar nicht weiß, was Windows 7 bei der Erstinstallation fragen wird. Logischer erscheint mir da schon der Überwachungsmodus, den ich mir so vorstelle, dass alle meine Änderungen an der Installation bzw. meine Eingaben mitgeschrieben werden. Das, was da raus kommt, wäre für mich die Antwortdatei. Naja, vielleicht hat noch jemand anderes das Glück, eine derartige Installation vorzunehmen und berichtet hier über seine Erfolge. Ich komme sicher erst im November dazu. Die Ausschreibung ist ja gerade erst vorgestern veröffentlicht worden.

Edit (2009-10-14-23:25)

Je mehr ich in den Anleitungen lese, umso mehr drängt sich mir das Gefühl auf, dass das alles viel zu kompliziert für meine Bedürfnisse ist. Ich möchte ja keine eigene Computerfirma aufmachen und Tausende unterschiedlicher PCs ausliefern. Ich möchte eigentlich nur:

1. einen PC mit Windows 7 versorgen, alle Treiber und Anwendungsprogramme installieren und für unser Netzwerk konfigurieren
2. den Rechner generalisieren, so dass ich ein Abbild von ihm auf alle baugleichen Rechner übertragen kann
3. Das Abbild mit möglichst wenigen Einstellungen auf 16 andere Rechner übertragen.

Geht das wie bisher mit sysprep für Windows 7 oder nicht?
Bitte warten ..
Mitglied: Kirschi
15.10.2009 um 08:24 Uhr
Praktische Erfahrung mit Win 7 clonen habe ich noch nicht aber hier ist ein Link mit einem Beitrag über Vista. Hier das WAIK Handbuch.
Sollte das wirklich soo kompliziert sein, würde ich mich nicht scheuen, die 16 Rechner so zu installieren. Bei der geringen Anzahl ist man sowieso nicht viel schneller mit der automatischen Methode.
Gruß
Andreas
Bitte warten ..
Mitglied: ichbindernikolaus
15.10.2009 um 11:10 Uhr
Ich bin gerade dabei, dass HowTo vom winboard mal durchzuspielen.
Ist eigentlich alles ganz fix gemacht und geht gut von der Hand.

Das einzige Problem, über dass ich gerade gestolpert bin, ist diese 100MB große Bootpartition von Win7.
Diese wird beim Start der WinPE-CD als Laufwerk C: eingebunden, die eigentliche Win-Partition jedoch als D: .
Mal schauen ob man mit dem "imagex"-Befehl auch diese Bootpartition sichern und anschließend wiederherstellen kann.

In ein bis zwei Stunden weiß ich es.

Zu Deiner Frage 3 aus dem Ursprungskommentar:
Also ich habe sowohl mit Acronis als auch mit 'ner alten Ghost-CD ein Image von Win7 gezogen.
Beides hat funktioniert, beides konnte man auch problemlos wieder aufspielen.

Allerdings scheint das nicht so 100%ig geklappt zu haben, da das mit dem Image aufgesetzte System unglaublich träge in der Bedienung war und Programme erst nach laaaanger Wartezeit oder auch gar nicht gestartet hat.
(Hardware war identisch mit der des Wirtsystems und auch komplett eingebunden, das Event-Log hat keine auffälligen Meldungen rausgeworfen).
Bitte warten ..
Mitglied: ichbindernikolaus
15.10.2009 um 13:10 Uhr
hmpf...
"Die Konfiguration des Systems konnte nicht abgeschlossen werden.
Starten sie den Computer neu, um die Konfiguration fortzusetzen."

Das bekomme ich zu sehen, wenn ich das frisch betankte System starte.
Quasi als Endlosschleife, auch abgesicherter Modus etc. ändern daran leider nichts.

In's Blaue vermutet denke ich, dass man die oben erwähnte 100MB-Startpartition nicht einfach so kopieren kann.
Mal weiterbasteln
Bitte warten ..
Mitglied: ichbindernikolaus
15.10.2009 um 15:14 Uhr
Sooo, einige Dellen in meinem Schreibtisch und viele Seiten Tutorial im Netz später...

...es gibt wohl einen Bug in Windows 7, der ein problemloses Sysprep verhindert.
Und zwar ist das wohl der "Windows Media Player-Netzwerkfreigabedienst".
Dieser muss deaktiviert werden, da er eine Datei im Zugriff hält, die das Sysprep behindert.

Bin jetzt gerade dabei, mein Win7-Wirtsystem neu aufzusetzen, da auch das System nach dem Sysprep nicht mehr funktionierte. (was auch auf einen Fehler im System selbst und nicht in der Festplattenpartitionierung o.ä. schließen lässt).
Wenn das durch ist, werde ich sowohl mit ImageX als auch mit Acronis 11 mal in Image ziehen und schauen was passiert.
Acronis wäre ja 'ne Ecke besser, da man beim Wiederaufspielen des Images die Partitionen nicht per Hand anlegen muss.

(bin wieder am basteln)
Bitte warten ..
Mitglied: fabgg6
15.10.2009 um 18:30 Uhr
Zitat von Kirschi:
Praktische Erfahrung mit Win 7 clonen habe ich noch nicht aber
[http://download.microsoft.com/download/7/4/7/74705261-1315-428b-89fc-2dff6ba8dab6/betriebssysteme_01_08_vista.pdf
hier] ist ein Link mit einem Beitrag über Vista.
[http://technet.microsoft.com/de-de/library/cc748933%28WS.10%29.aspx
Hier] das WAIK Handbuch.
Sollte das wirklich soo kompliziert sein, würde ich mich nicht
scheuen, die 16 Rechner so zu installieren. Bei der geringen Anzahl
ist man sowieso nicht viel schneller mit der automatischen Methode.
Gruß
Andreas

Ja. Die Microsoft-Seite habe ich schon durch und das Handbuch überflogen. Das WAIK für Windows 7 hatte ich mir ja heruntergeladen. Daher die Flut von Informationen, die mich beinahe erdrückt hat.

Uuuuuuuuff.

Aber 16 Rechner einzeln installieren, werde ich mir verkneifen. Unter Win98, 2000 und XP hat es ja auch (größtenteils) geklappt.

Danke für Deine Anmerkungen.
Bitte warten ..
Mitglied: fabgg6
15.10.2009 um 18:31 Uhr
Kann man hier keinen Beitrag löschen? Ich hatte das betreffende Zitat vergessen.

Siehe unten.
Bitte warten ..
Mitglied: fabgg6
15.10.2009 um 18:33 Uhr
Zitat von ichbindernikolaus:
... Allerdings scheint das nicht so 100%ig geklappt zu haben, da das mit
dem Image aufgesetzte System unglaublich träge in der Bedienung
war und Programme erst nach laaaanger Wartezeit oder auch gar nicht
gestartet hat.
(Hardware war identisch mit der des Wirtsystems und auch komplett
eingebunden, das Event-Log hat keine auffälligen Meldungen
rausgeworfen).

Hattest Du vor der Image-Erstellung Sysprep durchlaufen lassen?

Ich habe mir mittelweile eine unattended.xml von einem User kopiert und will die mal Stück für Stück durchgehen. Habe auch ne ganze Menge Seiten gefunden, auf denen Tipps stehen. Ich kann es nur nicht ausprobieren, da ich das Win7 erst in ca. 2 Wochen bekomme. Und gerade jetzt hätte ich Zeit ...

In der genannten unattended.xml gibt es auch ein paar Einträge zum Servicing. Aber was sie bedeuten, ...

<selection name="Internet Games" state="false" />
<selection name="More Games" state="false" />
<selection name="TabletPCOC" state="false" />
<selection name="WindowsGadgetPlatform" state="false" />
<selection name="MediaPlayback" state="false" />
<selection name="MediaCenter" state="false" />
<selection name="OpticalMediaDisc" state="false" />
<selection name="WindowsMediaPlayer" state="false" />
Bitte warten ..
Mitglied: Kirschi
15.10.2009 um 19:03 Uhr
Hallo Joyrider,

mit welcher Version von Acronis hattest Du Probleme? Die aktuelle 2010 soll Win 7 eigentlich unterstützen.
Bitte warten ..
Mitglied: ichbindernikolaus
15.10.2009 um 20:16 Uhr
Hallo Kirschi,

hatte es erst mit einer uralten Server-Version probiert und dann zuhause nochmal mit True Image 11 Home.
Ansich hat ja auch alles geklappt, nur war das Klonsystem aus nicht auffindbaren Gründen elend langsam.

@fabgg6:
Nope, bei den Versuchen hatte ich es noch ohne Sysprep gemacht.
Werde mich morgen gegen Mittag nochmal an die Geschichte hocken.
Dann mit:
- Win7 Pro
- WAIK for Win7 (hatte vorhin irrtümlich die ältere Version für Vista genommen)
- deaktiviertem MediaPlayer-Dienst
Bitte warten ..
Mitglied: support-he
16.10.2009 um 10:06 Uhr
Hi,

soo ... habe die ersten Notebooks mit Win7 "verteilt" (wir benutzen momentan ausschließlich die Enterprise-Edition in 64Bit-Variante).

Clonen läßt sich die Installation problemlos mit Ghost (wir nutzen Ghost-Solution 1.1 - also uralt!), man muß nur nach dem Restore die Win7-CD zur Reparatur benutzen (nehme mal an, daß der Bootsektor repariert wird).

NewSID zerstört Win7 leider.

Aber da ja sysprep jetzt fester Bestandteil von Win7 ist -> C:\windows\system32\sysprep, kann man damit die Installation in den Erststartmodus versetzen, der auch eine neue SID erzeugt.
Also einfach vorm ghosten sysprep machen (verallgemeinern/gereralize nicht vergessen) und ansonsten alles wie gehabt ...

Was mir leider noch nicht gelungen ist, ist das Erstellen eines angepaßten Default-Users:

Einfaches Kopieren eines existierenden Users per Filesystem und Rechte geben funktionierte ja noch nie und auch bei Win7 nicht (wegen der personalisierten Pfade in der ntuser.dat).
Per Profildialog kopieren funktioniert jetzt witzigerweise nur noch für das Default-Profile selbst , und eine unattended-DVD dafür zu basteln, wie es Microsoft empfiehlt, ist mir momentan einfach zuviel Arbeit - das muß einfacher gehen ...
Da wäre ich für helfende Tipps sehr dankbar!

HTH
Peter
Bitte warten ..
Mitglied: fabgg6
16.10.2009 um 11:18 Uhr
Zitat von support-he:
Hi,

soo ... habe die ersten Notebooks mit Win7 "verteilt" (wir
benutzen momentan ausschließlich die Enterprise-Edition in
64Bit-Variante).

Glückwunsch!

C:\windows\system32\sysprep, kann man damit die Installation in den
Erststartmodus versetzen, der auch eine neue SID erzeugt.

Das habe ich vor ein paar Jahren auch erst falsch gemacht. Damals gab es Stress im Netz.

Also einfach vorm ghosten sysprep machen (verallgemeinern/gereralize
nicht vergessen) und ansonsten alles wie gehabt ...

Welche Parameter hast Du genutzt? Ich will die folgenden ausprobieren:

/unattend:unattend.xml liest die angegebene Antwortdatei
/generalize löscht sonstige spezielle Einstellungen
/oobe out of the box (mit gleicher Hardware)
/shutdown fährt zwangsweise herunter

> Was mir leider noch nicht gelungen ist, ist das Erstellen eines
angepaßten Default-Users:

Ich habe gelesen, man sollte bei Anmeldung als Administrator den zuvor eingerichteten User komplett löschen. Danach wird ein Default User über die Domäne verteilt. Ob's tatsächlich so funktioniert?

Gruß, GG.
Bitte warten ..
Mitglied: fabgg6
16.10.2009 um 22:22 Uhr
Wie macht man das mit der 100-MB-Bootpartition beim Imaging? Ich werde vermutlich Acronis verwenden, da ich mich damit auskenne.

7. Muss ich gleich beide Partitionen in ein Image packen?
8. Wie schreibe ich das zurück? Macht das Programm dann aus einer Partition gleich zwei?
9. Muss ich die Bootpartition auch dann kopieren, wenn ich eine Grundinstallation von Windows 7 durch ein Image mit allen benötigten Anwendungen ersetze?

Je mehr ich lese, umso mehr Fragen ergeben sich.
Bitte warten ..
Mitglied: Kirschi
17.10.2009 um 08:12 Uhr
Zitat von fabgg6:
Wie macht man das mit der 100-MB-Bootpartition beim Imaging? Ich werde
vermutlich Acronis verwenden, da ich mich damit auskenne.

7. Muss ich gleich beide Partitionen in ein Image packen?
Ja, ein Image der gesamten Festplatte wäre meine Wahl (meine Daten liegen auf einer 2. Platte).
8. Wie schreibe ich das zurück? Macht das Programm dann aus
einer Partition gleich zwei?
Image ist ein Abbild, wenn bei 7. ja dann 8. auch ja
9. Muss ich die Bootpartition auch dann kopieren, wenn ich eine
Grundinstallation von Windows 7 durch ein Image mit allen
benötigten Anwendungen ersetze?
würde ich machen, weiß gar nicht ob man hier überhaupt wählen kann, oder ob Acronis sowieso "alles" zurückspielt.

Je mehr ich lese, umso mehr Fragen ergeben sich.
Immer frag, wir werden dabei ja auch nicht dümmer.
Gruß
Andreas
Bitte warten ..
Mitglied: ichbindernikolaus
17.10.2009 um 09:51 Uhr
Moin moin zusammen.

Kirschi hat es ja schon geschrieben, ohne die 100MB-Partition geht gar nichts.
Wenn die fehlt, kommt beim Booten nur die altbekannte "NTLDR fehlt"-Meldung.

Ich hab mein Image jetzt auch mit Acronis gemacht, da es mir mit Imagex zu aufwändig ist.

Scheinbar ist Windows aber zickig, was die Größe dieser 100MB-Partition angeht.
Habe das Image gestern auf eine 40GB-Festplatte zurückgespielt (das Master-Image kommt von einer 80GB-Platte) und dann möchte Acronis die Part-Größen dynamisch anpassen (sprich die Boot-Partition etwas verkleinern.) Und schon war's nix mehr mit booten.
Bitte warten ..
Mitglied: fabgg6
19.10.2009 um 22:47 Uhr
Also bei Acronis kann man Häkchen machen bei MBR sowie jeder einzelnen Partition jeder einzelnen Festplatte. Die einen Rechner bekommen wir mit installiertem Windows 7. Hier wird es schon eine W7-Bootpartition geben, die ich neu befüllen kann. Vielleicht geht es aber auch so. Das auszuprobieren ist kein Drama.

Die zweite Gruppe Rechner arbeitet derzeit aber noch mit XP. Hier will ich die Bootpartition C: löschen und bei der Neuinstallation W7 daraus zwei Partitionen machen lassen. Für den Musterrechner sollte das genügen. Wie mache ich es aber bei den anderen Rechnern?

Variante A: Partition C: löschen und Akronis die Arbeit machen lassen.
Variante B: Partition löschen und händisch eine 100-MB- sowie eine große Partition erstellen und dann das Image aufspielen.
Variante C: Von Installations-DVD starten, Partitionen anlegen lassen, Installation abbrechen und stattdessen Images aufspielen.

Hat jemand schon etwas davon probiert?
Bitte warten ..
Mitglied: ichbindernikolaus
20.10.2009 um 16:43 Uhr
hmm...
...also bei uns hier intern gibt es standardmäßig nur die Partition C: .
Von daher kann ich auf jedem Rechner vollkommen stressfrei das Acronis-Image mit kompletter Löschung aller existierenden Partitionen drüberkippen.

Bei Deiner Variante A wäre ich vorsichtig, dass Acronis die 100MB-Partition nicht dynamisch an die Gesamtgröße der Zielfestplatte anpasst.
Denn wenn die Größe abweicht, ist nix mehr mit booten.

Die Varianten B und C sind eigentlich vom reinen Zeitaufwand her nicht machbar... denke ich.

An Deiner Stelle würde ich mir vermutlich die kleinste gebräuchliche Festplatte im Unternehmen schnappen (sagen wir mal 'ne 80GB-Platte), darauf das System einrichten und das Image ziehen.
Anschließend beim Wiederherstellen die Partitionsgrößen 1 zu 1 aus dem Image übernehmen, auch bei größeren Festplatten.
Die Partition im Zweifel später wieder groß zu ziehen oder fix eine zweite Partition anzulegen wäre ja dann kein Aufwand mehr.
Bitte warten ..
Mitglied: fabgg6
20.10.2009 um 22:10 Uhr
Zitat von ichbindernikolaus:
...also bei uns hier intern gibt es standardmäßig nur die
Partition C: .

Ich denke, Windows 7 legt bei der Installation eine (möglicherweise versteckt, auf jeden Fall aber mit keinem Laufwerksbuchstaben versehene) eigene Boot-Partition von 100 MB Größe an. Ist das nicht so?

Ich habe bisher ja noch keine Windows-7-DVD in der Hand. Morgen wird bestellt (Chefin war im Urlaub) und geliefert wird schätzungsweise Mitte nächster Woche. Also ist das darauffolgende Wochenende für erste Versuche mit Windows 7 reserviert. Bis dahin kann ich nur lesen und spekulieren.
Bitte warten ..
Mitglied: Kirschi
21.10.2009 um 19:31 Uhr
> Zitat von ichbindernikolaus:
...Windows 7 legt bei der Installation eine (möglicherweise versteckt, auf jeden Fall aber mit keinem
Laufwerksbuchstaben versehene) eigene Boot-Partition von 100 MB Größe an. Ist das nicht so?

Ja, Win 7 (seit 4 Tagen in Betrieb ) legt eine 100MB Partition an: Name "System-reserviert" NTFS, Sytem, AKtiv, Primäre Partition.
Im Gegensatz dazu ist c: Startpartition, Auslagerungsdatei, Absturzabbild, Primäre Partition.
Bitte warten ..
Mitglied: gaston2k
22.10.2009 um 21:37 Uhr
Nabend Zusammen..wir installieren Win7 übers Netzwerk mit einem Server 2008R2 Standart und eingerichtetem Bereitstellungsdienst . Das einrichten der Festplatte ( C: 100GB D: Rest ) auf dem zu Installierendem System erfolgt bei uns über eine XML Datei die der boot.wim übergeben wird
Bei diesem verfahren wird keine 100 mb Partition erstellt und Win 7 läuft auch definitiv ohne.
Das gleiche gilt für Systeme die wir mit imagex geklont und per Bereistellungsdienst auf Serien aufgesetzt haben... keine 100mb Partition und alle laufen einwandfrei!!!
Bitte warten ..
Mitglied: fabgg6
22.10.2009 um 22:04 Uhr
Guten Abend Gaston.

Kann oder muss man bei der Installation entsprechend auswählen?

Das Verfahren über die boot.wim habe ich mir auch schon angesehen. Es kommt mir aber zu kompliziert vor. Außerdem will ich nicht erst lange rumprobieren sondern lieber auf bekanntes zurückgreifen.
Bitte warten ..
Mitglied: gaston2k
22.10.2009 um 22:55 Uhr
Hallo fabgg6,

bei der Installation von DVD hast du keine Auswahlmöglichkeit und wenn du keinen Bereitstellungsserver zur verfügung hast kannst du meines Wissens nach nur den Weg über WINPE und imagex gehen und etwa 2 bis 3 stunden Arbeit investieren ,dafür hast du hinterher aber leichtes Arbeiten da das rückspielen von einem fertigen System nur ein bruchteil der Zeit beträgt. Du must einen Rechner mit Win7 Installieren wenn er fertig ist drückst du beim erneuten hochfahren die tasten " STRG+Windowstaste+F10"
damit startest du den auditmode beim das sysprepfenster schon geöffnet ist und nicht geschlossen werden sollte. Jetzt kannst alles weitere Installieren was für dich wichtig ist bzw alles löschen was du nicht brauchst.wenn du fertig bist den rechner mit Sysprep versiegeln. Nun den Rechner mit der WINPE-CD auf der zwingend imagex drauf sein sollte wieder hochfahren und mit imgex ein ein abbild auf ein USB medium erstellen.
Jetzt solltest du eine Wim datei mit deinem fertigen Rechnerabbild auf deinem medium haben.das abbild kannst du dann in die setup.wim auf der Installtions_Cd einfügen.....fertig

Wenn du genauere Hilfe brauchst und noch etwas Zeit hast ( die wir ja nie haben ) wäre ich am Sonntag gerne wieder da
Bitte warten ..
Mitglied: fabgg6
23.10.2009 um 13:00 Uhr
Hallo Gaston2k und alle anderen Interessenten,

ich habe vor, es so wie bisher zu machen. Die Vorgehensweise habe ich bereits weiter oben beschrieben. Betriebssystem und alle Anwendungs-Software installieren und konfigurieren, Sysprep mit Antwortdatei, Image mittels Acronis Trueimage auf Server speichern und dann auf jeden der Einzelrechner übertragen, Minisetup ausführen, um Name und IP zu vergeben (alles andere steht hoffentlich schon in der Antwortdatei).

Neu (für mich) ist diese "überwachte" Installation, deren Sinn ich nicht so ganz einsehe. Ich übertrage ja sowieso alle Installationen und Konfigurationen mit meinem Image.

Die Frage mit der Sonderpartition wäre aber schon wichtig. Zwar kann Acronis Trueimage auch mehrere Partitionen in einem Rutsch sichern und wiederherstellen, allerdings müsste vorher vielleicht entsprechend partitioniert werden. Das wird wohl dieses boot.wim-Image automatisch mit machen. Sonst wüsste ich nicht, wozu es gut sein sollte.

Ich finde das im WAIK beschriebene Verfahren unnötig kompliziert.

Was alles schief gehen kann, werde ich sehen, wenn ich dabei bin. Ich muss Win7 auf zwei verschiedenen Rechnertypen installieren bzw. konfigurieren. Die eine Gruppe ist neu, da ist das Windows 7 mit allen Treibern schon drauf. Da muss ich "nur" unsere etwa 50 Anwendungsprogramme installieren und einrichten. Auf den anderen Rechnern ist XP drauf. Da will ich von Grundauf neu beginnen. Eine Drüberinstallation ist ja auch nicht so ohne weiteres möglich, wie ich bisher immer gelesen habe.
Bitte warten ..
Mitglied: fabgg6
18.11.2009 um 16:49 Uhr
Zwischenbilanz (was geht und was nicht):

Achtung: Upgrade-Version

Wir haben die Upgrade-Version von Windows 7 Professional open Education verwendet. Zuvor war Windows XP SP3 installiert. Man bootet den PC normal, legt die DVD ein, startet hier Setup.exe und muss anschließend "Neuinstallation" wählen. Ein wirkliches Upgrade geht von Windows XP aus nicht. Der alte Windows-Ordner wird in Windows.old umbenannt und kann nach der Installation komplett gelöscht werden. Gleiches gilt für den alten Programmordner. Der neue besteht aus zwei Teilen: "Program Files" und "Program Data". Überhaupt ist alles "internationalisiert". Der neue Benutzer-Ordner heißt Users" und der neue Dokumente-und-Einstellungen-Ordner "Documents and Settings". Im Windows-Explorer sieht man bei der deutschen Version aber die deutschen Namen: "Programme", "Benutzer" und "Dokumente und Einstellungen".

Bei der Upgrade-Version (ist auch die 35-Euro-Studentenversion sowie der Family-Pack) wird keine 100-MB-Boot-Partition angelegt, wenn die Festplatte bereits komplett verwendet wird.

Nach der Installation wird ein Default-Profil vom Rechner verwendet. Für das Netz muss man das Default-Profil auf dem Server ergänzen. Ich weiß aber noch nicht wie.

Das Default-Profil vom Rechner verwendet dessen Startmenü und dessen hinzugefügte Desktopsymbole. Alles andere wird im individuellen Profil gespeichert, solange man kein servergespeichertes Default-Profil an der richtigen Stelle hat. So muss sich der Anwender die Symbole für "Computer" oder sein eigenes Home-Verzeichnis selbst auf dem Desktop anzeigen lassen (Rechtsklick - Anzeigen) oder die gewünschte Größe der Icons anpassen. Das erfordert ein wenig Spielerei, was für unsere Schüler aber gleich eine kleine Übung ist. Wir haben Mitte Oktober einen Aushang gemacht, der auf das kostenlos kopierbare "Windows 7 - auf einen Blick" hinwies und die meisten Schüler bzw. Lehrer haben es sich wohl auch bei Microsoft Press runtergeladen (Aktion war nur bis zum 31. Oktober).

Die Aktivierung geht nur, wenn man den Schlüssel zuvor eingegeben hat. Ich hatte den Schritt zunächst übersprungen und bin nach zwei Wochen Installieren, Konfigurieren und Testen dann auf "Windows aktivieren" gegangen. Man wird nicht automatisch zur Eingabe seines Keys aufgefordert. Stattdessen bricht der Vorgang mit einer unzutreffenden Fehlermeldung (Zeitüberschreitung) ab.

Ich habe alle Nutzer bis auf den nicht löschbaren Gast (deaktiviert) und den Voll-Administrator gelöscht. Anschließend habe ich die noch nicht aktivierte Installation mit allen Nutzerprogrammen und Voreinstellungen ohne Sysprep geklont und auf einen anderen Rechner kopiert. Das geht. Man kann anschließend den Rechner umbenennen, in einer Arbeitsgruppe anmelden, NewSID ausführen und zurück in die Domäne wechseln. Allerdings gibt es für Windows Vista/Seven kein NewSID mehr. Der Durchlauf mit NewSID kann die Nutzekonten auch zerstören. Auf jeden Fall beendet es seine Arbeit nicht. Wahrscheinlich ist nur ein Teil der SID geändert worden, was zu größeren Komplikationen führen kann als mehrere Rechner mit gleicher SID. Hier gibt es wohl Schwierigkeiten mit Netzwerküberwachungs- und Fernwartungsprogrammen. Das habe ich aber nur gelesen.

Anschließend angemeldete Domänennutzer finden ihren Netzwerkordner "Eigene Dateien" (bei uns Netzlaufwerk H:\, versteckte Freigabe) unter dem dafür vorgesehenen (von vorn herein angepinten) Symbol in der Taskleiste und auch auf dem Desktop, wenn sie das entsprechende Symbol aktivieren. Außerdem kommt man dorthin, wenn man im Startmenü auf seinen Benutzernamen klickt. Im Ordner "Dokumente" findet man seine alten "Eigenen Dateien", darin evtl. Ordner wie "Eigene Videos", "Eigene Bilder" usw. Die gibt es unter Windows 7 dann noch einmal. Das Profil wird erweitert. Alle Profileinstellungen müssen neu vorgenommen werden (Aussehen, Symbolleisten im Office, Drucker usw.), es sei denn, man befolgt die Anleitung von Microsoft zu diesem Thema.

Hier gibt es das für Vista: http://www.microsoft.com/downloads/details.aspx?FamilyID=311f4be8-9983- ..., natürlich nur in Englisch. Für Windows 7 dürfte es aber genauso sein. Immerhin ist Windows 7 ja eigentlich Windows 6.1. ;)

Das Sysprepen ist auf jeden Fall der bessere und sicherere Weg (c:\windows\system32\sysprep\sysprep.exe /unattend:unattend.xml /generalize /oobe /shutdown). Das anschließende Mini-Setup ist aber ein Sensibelchen. Auf verschiedene Dienste reagiert es allergisch. So muss man den Windows-Mediaplayer-Netzwerkfreigabedienst vor dem Sysprep deaktivieren. Aber auch andere Dienste stehen einer Wiederbelebung des Images im Wege. Dazu gehören verschiedene Virenscanner. Welche (externe) Dienste sonst noch Schwierigkeiten machen, muss jeder selbst merken. Die Fehlermeldung "Die Konfiguration konnte nicht abgeschlossen werden. Ein Neustart ist erforderlich ..." erscheint während der Sequenz "Starten von Diensten". Sonst könnte man Sysprep nur ohne Generalisierung durchführen. Dann wird aber (meines Wissens) auch keine neue SID erzeugt.

http://www.administrator.de/Windows_7_und__sysprep.html

Vielleicht kann man da auch über die Antwortdatei eine Besserung erreichen, dazu fehlt mir aber die Zeit. In der unattend.xml habe ich nur relativ wenige Sachen (Administratorprofil kopieren, Treiber belassen, Nutzer und Organisation, Spracheneinstellungen, Displayeinstellungen, wobei nur die ersten beiden wirklich wichtig sind), alles mit dem Windows SIM vom WAIK eingetragen.

Soweit bin ich nun gerade. Morgen wird der bisher einzige aktivierte Rechner im Alltagsbetrieb getestet und übermorgen das Image auf die übrigen 15 Rechner verteilt, geminisetupt und Windows aktiviert.

Wenn alles zur Zufriedenheit läuft, kann dieser Thread vielleicht als "gelöst" markiert werden.

Gruß, GG.
Bitte warten ..
Mitglied: fabgg6
18.11.2009 um 17:02 Uhr
Zwischenbilanz (Frage-Antwort-Teil):

Zitat von fabgg6:
1. Wo müsste die Antwort-Datei (erstellt mit setupmgr.exe vom
14.4.08) liegen und wie müsste sie heißen, damit sie
garantiert gefunden wird?

Name und Ort sind egal. Man muss nur Pfad und Name kennen.

2. Mit welchen Parametern müsste Sysprep.exe evtl. gestartet
werden? (Ich hatte alles immer im Ordner C:\sysprep).

bei baugleichen Rechnern:

c:\windows\system32\sysprep\sysprep.exe /unattend:<pfad und name der antwortdatei>.xml /generalize /oobe /shutdown


zu Windows 7:

3. Kann ich von meinem ideal installierten und vorkonfigurierten
Rechner erneut mit einem beliebigen Image-Programm ein Abbild machen
oder muss ich das Microsoft-Paket verwenden (Windows PE und ImageX aus
dem WAIK).

Zumindest bei der Upgrade-Version von Windows 7 geht das, da hier keine 100-MB-Bootpartition angelegt wird.

4. Kann ich danach ebenso mit Sysprep (vermutlich neue Version) alle
"individuellen" Einstellungen des Rechners löschen und
das Image auf andere Rechner übertragen?

Jo. Windows sollte zuvor aber noch nicht aktiviert sein.

5. Reicht es dann, einen USB-Stick mit der Autoattend.xml (erstellt
mit Windows System Image Manager für Windows 7) am zu
installierenden Rechner zu verwenden bzw. heißt die Datei bei
Windows 7 noch so?

USB-Stick ist überflüssig. Die Antwortdatei wird ja schon beim Sysprep-Aufruf "verarbeitet".

6. Kann man Sysprep und den Windows SIM für Windows 7 irgendwo
einzeln herunterladen oder gibt's das nur im WAIK-Paket
(KB3AIK_DE.iso)?

Ich habe nun das WAIK verwendet, da ich auf die Frage keine Antwort gefunden habe. Vermutlich gibt es den SIM aber nirgendwo einzeln.

Grüße, GG.
Bitte warten ..
Mitglied: fabgg6
21.11.2009 um 12:53 Uhr
Abschluss:

Also, es funktioniert tatsächlich. Es kann aber sein, dass dies nur für die Upgrade-Version gilt. Mit der "Vollversion" werde ich in einigen Wochen zu tun haben. Falls dort eine 100-MB-Bootpartition erstellt wird, werde ich sehen, ob man auch hier mit einem normalen Image-Programm arbeiten kann.

Ich habe nun also folgendes gemacht.

Anfangszustand: 17 PC (AMD64x2-2500/2 GB RAM/160 GB HDD/nvidia 512 MB) mit Windows XP Professional SP3
Windows-Server-2003-R2-Domäne

  • Booten des Musterrechners auf XP
  • Einlegen der Windows-7-Upgrade-DVD
  • Starten der Datei setup.exe
  • Auswahl der kompletten Neuinstallation (das andere geht nur von Vista aus)
  • Installation des Betriebssystems, Nachladen von Treibern (online)
  • Aktivierung des eingebauten Administrators (inklusive Passwort)
  • Anmeldung als Administrator, Vornehmen von Einstellungen (IP, Proxy, Domäne usw.)
  • Löschen des zuvor eingerichteten Users (mit Administratorrechten)
  • Anmeldung als Domänenadministrator (alte Profileinstellungen von 2000/XP wurden erkannt und übernommen)
  • Installation und teilweise Konfiguration von 45 Anwendungsprogrammen und Tools (via Server)
  • Einrichten eines übersichtlichen Startmenüs für diese Programme (z.B. Büroanwendungen, Multimedia, Naturwissenschaften)
  • Installation der Netzwerkdruckertreiber
  • Testen
  • Erstellen einer Antwortdatei unattend.xml mit individuellen Einstellungen für unsere Installation
        • Beibehaltung der Gerätetreiber: generalize - MSW-Pnp-Sysprep: PersistAllDeviceInstalls
        • Netzwerkeinstellungen: specialize - MSW-DNS-Client ... / MSW-TCPIP-Interfaces ...
        • Ländereinstellungen: MSW-International-Core ...
        • Bildschirmauflösung: MSW-Shell-Setup ...
Ich hatte noch andere Einstellungen versucht, die zunächst nicht bemängelt,
beim Setup des mit Sysprep versiegelten Rechners aber als falsch abgelehnt wurden.
Das hat viel Zeit gekostet, bis ich irgendwann den Kanal voll hatte.
  • Versiegeln des Rechners mit c:\windows\system32\sysprep\sysprep.exe /unattend:c:\unattend.xml /generalize /oobe /shutdown
  • Booten von einer CD und Anfertigen eines Images mit Acronis Trueimage auf CD (Home 10.0)
  • Übertragen des Images auf die anderen Rechner
  • Booten dieser Rechner, Mini-Setup und Vornahme von Einstellungen
Nicht hinbekommen habe ich, dass man beim Hochfahren keinen Benutzer einrichten muss
und das Administratorkonto automatisch aktiviert ist. Schwierigkeiten gab es auch mit dem
installierten Antivirenprogramm. Die Installation des Images brach beim Starten der Dienste ab.
Nach Deinstallation des Avira-Programms ging es dann. Die Windows-Aktivierung habe ich an allen
Rechnern (auch dem Musterrechner) erst am Schluss vorgenommen.

Endzustand: 17 PC (AMD64x2-2500/2 GB RAM/160 GB HDD/nvidia 512 MB) mit Windows 7 Professional 32 Bit Upgrade (OpenE)
Windows-Server-2003-R2-Domäne

Die Nutzer können sich anmelden und mit ihren bisherigen Verzeichnissen arbeiten. Anmeldeskripte funktionieren. Die Profile werden auf dem Server gespeichert, sind jetzt aber deutlich umfangreicher. Außerdem bekommen die Ordner verschiedener Nutzer im Windows-Explorer alle denselben Namen "Eigene Dokumente". Kann man das irgendwo umstellen (etwa "echte Ordnernamen anzeigen"). Fremdprogramme, wie der Salamander, zeigen die korrekten Namen an. Auch auf dem Windows-2003-Server ist dies so.

Ob die alten Gruppenrichtlinien abgearbeitet werden und ich nur ergänzen, oder ob ich sie komplett neu erstellen muss, weiß ich noch nicht. Das ist nächste Woche dran. Außerdem wird es wahrscheinlich jede Menge weiterer Probleme geben.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows 10
Windows 10 Clients laden Updates nicht von WSUS Server (7)

Frage von Alternativende zum Thema Windows 10 ...

Windows 10
gelöst Windows 10 Clients Netzwerkzurgriff, aber keine Internetverbindung (4)

Frage von MS6800 zum Thema Windows 10 ...

Windows Netzwerk
Windows 10 Clients am SBS 2011 (20)

Frage von sklchris zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...