Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Warum kopiert die Batch nicht?

Frage Entwicklung Batch & Shell

Mitglied: 84075

84075 (Level 2)

06.11.2009, aktualisiert 09.11.2009, 3336 Aufrufe, 6 Kommentare

Wieso geht das nicht????

Wenn ich in C:\tmp kopiere dann klappts wunderbar...nur nicht in Dok. u Einst. ?!?!?!?! Habe aber die Anführungszeichen?!?! Führe das alles mit Admin Rechten aus?!?!?!

@echo off
set frompath= "C:\tmp\Installation.bat"
for /f "eol= tokens=1" %%i in (Z:\list.txt) do copy /v /y %frompath% %%i\C$\"Dokumente und Einstellungen"\"All Users"\Startmenü\Programme\Autostart
Mitglied: RogerWilco2009
06.11.2009 um 12:45 Uhr
Mit den Anführungszeichen maskierst Du Sonderzeichen und Leerstellen. in "All Users" ist auch eine Leerstelle! Die Anführungszeichen müssen den ganzen Pfad umfassen, soweit ich weiß...
Bitte warten ..
Mitglied: 84075
06.11.2009 um 12:56 Uhr
so klappt es auch nicht:

@echo off
set frompath= "C:\tmp\Installation.bat"
for /f "eol= tokens=1" %%i in (Z:\list.txt) do copy /v /y %frompath% %%i\C$\"Dokumente und Einstellungen\All Users\Startmenü\Programme\Autostart"
Bitte warten ..
Mitglied: Iwan
06.11.2009 um 12:56 Uhr
jaja, die böse Formatierungshilfe hier im Forum... ganz schwer zu finden und vor allem zu nutzen....
und im übrigen sagt der Bauer "tach" wenn er reinkommt...

mal abgesehen von den fehlerhaften Anführungszeichen wird das mit dem Startmenü auch nicht ganz klappen
wenn einer der beiden grossen B's nicht was anderes sagen, müsste es so funktionieren
getestest unter XP Pro SP3:
01.
@echo off 
02.
set frompath= "C:\tmp\Installation.bat" 
03.
for /f "eol= tokens=1" %%i in (Z:\list.txt) do copy /v /y %frompath% "%%i\C$\Dokumente und Einstellungen\All Users\STARTM~1\Programme\Autostart"
Bitte warten ..
Mitglied: icsat
06.11.2009 um 12:58 Uhr
Hallo cyaency,

ich glaube Dein Problem liegt im Umlaut (ü) beim Startmenü.

Entweder kannst Du "Startmenü" durch "Startm~1" ersetzen,
oder ein einfaches "chcp 1252" am Anfang des Skriptes sollte auch funktionieren.


Gruß icsAT
Bitte warten ..
Mitglied: 5t8d1e
06.11.2009 um 13:14 Uhr
Hallo cyaency,

es wäre auch schön, wenn du dein Frage nur einmal stellst und nicht mehrere Threads öffnest. Bitte schliessen dann die anderen "doppelten" Threads.

Torsten
Bitte warten ..
Mitglied: 84075
06.11.2009 um 13:21 Uhr
erst mal TACH))))

also ich danke dir! natürlich lag es am "ü" MENSCH!!! Naja auf jeden Fall klappt es jetzt - LOB an IWAN
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Xcopy-script kopiert nur 1 datei? (2)

Frage von f0rml0s zum Thema Batch & Shell ...

Windows 7
Kopierte Dateien im Hintergrund anzeigen (1)

Frage von MichiBLNN zum Thema Windows 7 ...

Neue Wissensbeiträge
Multimedia

Raspberry Pi als Digital-Signage-Computer

Information von BassFishFox zum Thema Multimedia ...

Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(15)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
Freigabe aus anderem Netz nicht erreichbar (21)

Frage von McLion zum Thema Router & Routing ...

Windows Server
Kennwort vergessen bei Hyper vserver 2012r (20)

Frage von jensgebken zum Thema Windows Server ...

Batch & Shell
Batch Programm verhalten bei shoutdown -p (19)

Frage von Michael-ITler zum Thema Batch & Shell ...

Festplatten, SSD, Raid
Raidcontroller funktioniert nur, wenn unter Legacy-Boot gestartet wird (13)

Frage von DerWoWusste zum Thema Festplatten, SSD, Raid ...