Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Warum kopiert die Batch nicht?

Frage Entwicklung Batch & Shell

Mitglied: 84075

84075 (Level 2)

06.11.2009, aktualisiert 09.11.2009, 3305 Aufrufe, 6 Kommentare

Wieso geht das nicht????

Wenn ich in C:\tmp kopiere dann klappts wunderbar...nur nicht in Dok. u Einst. ?!?!?!?! Habe aber die Anführungszeichen?!?! Führe das alles mit Admin Rechten aus?!?!?!

@echo off
set frompath= "C:\tmp\Installation.bat"
for /f "eol= tokens=1" %%i in (Z:\list.txt) do copy /v /y %frompath% %%i\C$\"Dokumente und Einstellungen"\"All Users"\Startmenü\Programme\Autostart
Mitglied: RogerWilco2009
06.11.2009 um 12:45 Uhr
Mit den Anführungszeichen maskierst Du Sonderzeichen und Leerstellen. in "All Users" ist auch eine Leerstelle! Die Anführungszeichen müssen den ganzen Pfad umfassen, soweit ich weiß...
Bitte warten ..
Mitglied: 84075
06.11.2009 um 12:56 Uhr
so klappt es auch nicht:

@echo off
set frompath= "C:\tmp\Installation.bat"
for /f "eol= tokens=1" %%i in (Z:\list.txt) do copy /v /y %frompath% %%i\C$\"Dokumente und Einstellungen\All Users\Startmenü\Programme\Autostart"
Bitte warten ..
Mitglied: Iwan
06.11.2009 um 12:56 Uhr
jaja, die böse Formatierungshilfe hier im Forum... ganz schwer zu finden und vor allem zu nutzen....
und im übrigen sagt der Bauer "tach" wenn er reinkommt...

mal abgesehen von den fehlerhaften Anführungszeichen wird das mit dem Startmenü auch nicht ganz klappen
wenn einer der beiden grossen B's nicht was anderes sagen, müsste es so funktionieren
getestest unter XP Pro SP3:
01.
@echo off 
02.
set frompath= "C:\tmp\Installation.bat" 
03.
for /f "eol= tokens=1" %%i in (Z:\list.txt) do copy /v /y %frompath% "%%i\C$\Dokumente und Einstellungen\All Users\STARTM~1\Programme\Autostart"
Bitte warten ..
Mitglied: icsat
06.11.2009 um 12:58 Uhr
Hallo cyaency,

ich glaube Dein Problem liegt im Umlaut (ü) beim Startmenü.

Entweder kannst Du "Startmenü" durch "Startm~1" ersetzen,
oder ein einfaches "chcp 1252" am Anfang des Skriptes sollte auch funktionieren.


Gruß icsAT
Bitte warten ..
Mitglied: 5t8d1e
06.11.2009 um 13:14 Uhr
Hallo cyaency,

es wäre auch schön, wenn du dein Frage nur einmal stellst und nicht mehrere Threads öffnest. Bitte schliessen dann die anderen "doppelten" Threads.

Torsten
Bitte warten ..
Mitglied: 84075
06.11.2009 um 13:21 Uhr
erst mal TACH))))

also ich danke dir! natürlich lag es am "ü" MENSCH!!! Naja auf jeden Fall klappt es jetzt - LOB an IWAN
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Batch & Shell
gelöst Batch kopiert immer wieder die gleichen Dateien (1)

Frage von nobbi49 zum Thema Batch & Shell ...

Batch & Shell
Dateinamen nach Zeichnen abschneiden - Batch-Shell (9)

Frage von cberndt zum Thema Batch & Shell ...

Batch & Shell
CMD Verschlüsslung ( Batch ) (11)

Frage von clragon zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...