Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Korrekte VLAN Konfiguration Mikrotik RB2011UiAS

Frage Netzwerke Router & Routing

Mitglied: daarma

daarma (Level 1) - Jetzt verbinden

02.11.2014, aktualisiert 03.11.2014, 1438 Aufrufe, 6 Kommentare

Hallo allerseits,

mir wurde neulich schon hinsichtlich Hardware-Auswahl schon geholfen und nun habe ich - glaube ich - ein Konfigurationsproblem.

Ursprüngliche Problemstellung nochmal:

Für eine Gruppe von insgesamt ca. +/-100 Benutzern (nicht alle gleichzeitig) sollen zwei WLANs bereitgestellt werden. Eins davon soll hinsichtlich Internet-Zugriff unlimitiert sein, das andere soll in Form einer White-List auf einige wenige HTTPS-Websites beschränkt sein. Ebenso sollen im Letzteren andere Anwendungen, wie Mail, FTP etc. nicht erlaubt sein.
Eine explizite Administration der Benutzer sollte nicht notwendig sein - das Passwort vom ersten WLAN soll geheim bleiben, das vom anderen (dem limitierten) quasi publik.

Der Internetzugang ist per LAN vorhanden (Fritzbox 7270). Der Router dazu soll unangetastet bleiben.

Als HW habe ich mittlerweile angeschafft:
- VLAN-fähiger Switch Zyxel GS-1910
- Zwei AP Draytek Vigor 900
- Router Mikrotik RB2011UiAS-RM

Ich bin im Moment dabei, die prinzipielle Funktionsfähigkeit zu prüfen. Folgendes habe ich gemacht bis jetzt:
- AP bzgl. SSIDs, VLANs etc. konfiguriert
- Switch bzgl. VLANs konfiguriert
- Im Mikrotik die VLANs ans richtige Interface konfiguriert, DHCP-Server für jedes VLAN aufgesetzt. Für den WAN (ether1) Port einen DHCP-Client konfiguriert (Adressen-Bezug von der Fritzbox klappt auch). Die Default-Konfiguration des Mikrotik wurde nicht aktiviert.

Schematischer Aufbau derzeit

(WAN)---FB7270---Mikrotik---Switch---AP---Notebook

Solange ich unter den VLANs kommuniziere, funktioniert alles erwartungsgemäß. Der Mikrotik routet wie er soll.
Sobald ich aber die Fritzbox aus einem der VLANs anpinge, kriege ich keine Antwort. Der Ping vom Mikrotik aus (d.h. dessen Kommandozeile) funktioniert aber.

Ich vermute, dass es daran liegt, dass die Antwort auf den Ping untagged daherkommt und der Zyxel-Switch sie verwirft. Der Router fasst das VLAN-Tag nicht an, soweit ich das beurteile...
Wie konfiguriert man sowas prinzipiell? Oder mache ich einen Gedankenfehler?

Danke & Grüße
daarma
Mitglied: tkr104
LÖSUNG 03.11.2014, aktualisiert um 18:37 Uhr
Zitat von daarma:

Ich vermute, [...]

Moin,

ich vermute das du der Fritzbox noch sagen musst welche Netze hinter dem Mikrrotik Router sind, sonst routed die FB ja nicht dahin.

VG,

Thomas
Bitte warten ..
Mitglied: colinardo
LÖSUNG 03.11.2014, aktualisiert um 18:37 Uhr
Zitat von tkr104:
ich vermute das du der Fritzbox noch sagen musst welche Netze hinter dem Mikrrotik Router sind, sonst routed die FB ja nicht
dahin.
würde ich auch sagen das da die statischen Routen auf der Fritzbox fehlen, oder wenn das nicht gewünscht ist kannst du alternativ die zwei VLANs auf dem Mikrotik NATen mit einer Firewall Masquerading Regel (SRCNAT).

Grüße Uwe
Bitte warten ..
Mitglied: aqui
LÖSUNG 03.11.2014, aktualisiert um 18:38 Uhr
Praktische Beispiele dazu findest du hier:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
bzw. hier:
http://www.administrator.de/contentid/245872#comment-942279
und
http://www.administrator.de/wissen/vlan-mit-mikrotik-rb750gl-und-tp-lin ...

Zu 98% ist es aber die fehlende statische Route auf der FB zu den VLAN IPs. Die Grundlagen zu so einem Routing Szenario die auch die statischen Routen auf den Internet Routern detailiert beschreiben findest du hier in diesem Forumstutorial:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Das sollte dein Problem eigentlich sofort lösen. Wie immer sind Traceroute und Pathping hier deinen Freunde
Bitte warten ..
Mitglied: daarma
03.11.2014 um 18:37 Uhr
Die statische Route hat auf der Fritze tatsächlich gefehlt... Habe ich total verpeilt.

Trotzdem Frage ich mich, wie das am Zyxel mit den VLAN Tags funktioniert. Die ping-Antwort dürfte doch nicht getaggt sein, denn die FB beherrscht das ja nicht. Der Mikrotik macht auch nichts mit dem Tag (oder?) und am betreffenden Zyxel-Port ist "Tagged only" und "Ingress Filtering" aktiviert. Ich würde es gerne verstehen...

Vielen Dank euch auf jeden Fall!

War sicher nicht die letzte Frage, aber erstmal geht ja alles

Grüße
daarma
Bitte warten ..
Mitglied: colinardo
03.11.2014, aktualisiert um 19:29 Uhr
Der Switch sollte nur an seinem Trunk-Port Pakete taggen (also der Port der mit dem Mikrotik verbunden ist) und der Mikrotik nur den Port der mit dem Switch verbunden ist. Gehen Pakete vom Switch über den Trunk an den Mikrotik und von dort an die Fritzbox werden die Tags auf dem Mikrotik aus dem Paket entfernt, und auf dem Rückweg Richtung Switch wieder hinzugefügt. Der Switch kann dann die Pakete wieder den entsprechenden VLANs zuordnen. An den Ziel-Switchports für das jeweilige VLAN wird dann aus den Paketen das Tag wieder entfernt, und landet dann ungetaggt wieder beim Client.

Steht aber auch alles detailliert erklärt in Aquis Tutorial zu VLANs:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...

Grüße Uwe
Bitte warten ..
Mitglied: daarma
03.11.2014 um 20:14 Uhr
Danke, Uwe.

Dass der Mikrotik die Rück-Pakete automatisch wieder korrekt taggt, war mir nicht klar.
Die Tags hören in meinem Setup allerdings nicht beim Switch auf, denn ich habe ja noch zwei Multi-SSID-fähige APs. Die sind natürlich auch jeweils mit einem Trunk mit dem Switch verbunden.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
IP-Adresse eines Mikrotiks als VLAN-Switch (1)

Frage von Dragan123 zum Thema Router & Routing ...

LAN, WAN, Wireless
Mikrotik - VLAN, Switching, Bonding (20)

Frage von Alex29 zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
VLANs in WLANs bei Mikrotik-Routern (9)

Frage von coltseavers zum Thema LAN, WAN, Wireless ...

Netzwerkmanagement
gelöst VLAN Konfiguration-Verständis-Frage (Problem bei der korrekten Einrichtung - Cisco) (44)

Frage von Skyemugen zum Thema Netzwerkmanagement ...

Neue Wissensbeiträge
Multimedia

Raspberry Pi als Digital-Signage-Computer

(1)

Information von BassFishFox zum Thema Multimedia ...

Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(15)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Server
Kennwort vergessen bei Hyper vserver 2012r (21)

Frage von jensgebken zum Thema Windows Server ...

Router & Routing
Freigabe aus anderem Netz nicht erreichbar (21)

Frage von McLion zum Thema Router & Routing ...

Batch & Shell
Batch Programm verhalten bei shoutdown -p (19)

Frage von Michael-ITler zum Thema Batch & Shell ...

Festplatten, SSD, Raid
gelöst Raidcontroller funktioniert nur, wenn unter Legacy-Boot gestartet wird (14)

Frage von DerWoWusste zum Thema Festplatten, SSD, Raid ...