Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

KVM, ubuntu, LTO laufwerke passthrough

Frage Linux Ubuntu

Mitglied: punktik

punktik (Level 1) - Jetzt verbinden

25.10.2012, aktualisiert 19:02 Uhr, 3545 Aufrufe, 7 Kommentare

Hallo,

ich habe ubuntu 12.04 server, kvm als virtualisierungsgrundlage, eine SAS-HBA von adaptec und einen Quantum LTO-4 Bandlaufwerk.

PCI Passthrough funktioniert, die Karte wird im Gast-System (windows 2003 r2 x64) erkannt, aber sobald ich den Laufwerk einschalte friert der host und der gast, also der Server ist ganz eingefroren und nicht mehr ansprechbar.
Manchmal kann ich noch auf dem Bildschirm "BUG: soft lockup - CPU#5 stuck for 23s!" beobachten, logs schweigen zundiesem Thema.

Was mache ich falsch?
Wo kann ich den Fehler suchen?
Danke für die Beiträge.
Mitglied: kingkong
25.10.2012 um 19:06 Uhr
Hast Du in letzter Zeit vielleicht ein Kernelupgrade gemacht? Dann schau mal hier; betrifft zwar hier CentOS, aber das sieht nach einem Kernelproblem aus (eine mögliche Lösung wäre demnach, wieder zu einem älteren Kernel zurück zu gehen): http://bugs.centos.org/view.php?id=5823&nbn=3
Bitte warten ..
Mitglied: punktik
25.10.2012 um 20:16 Uhr
Danke für den Antwort, erstmal.

Yep, habe ich gemacht, da mit dem vorherigen es gar nicht ging: der Kernel ist gleich beim booten ins panik geraten.
Momentan ist 3.2.0-32-generic, der vorherige war 3.2.0-23-generic.
Bitte warten ..
Mitglied: AndiEoh
30.10.2012 um 12:53 Uhr
Ganz ehrlich...
Mach das nicht. Das durchreichen von Geräten ist relativ neu und bei Hochleistungsgeräten wie schnellen Bandlaufwerken die zudem noch einen konstanten Datenstrom benötigen eh nicht zu empfehlen. Nicht alles was man irgendwie virtualisieren kann ist auch dafür geeignet.

Gruß

Andi
Bitte warten ..
Mitglied: punktik
30.10.2012 um 22:59 Uhr
Der grund dafür liegt in der Mangel der Hardware und Platz für diese Hardware. Die Maschine sollte alte Windows NT-Backups restoren können und neue Backups und Archive mit Autoloader und Bacula schreiben. Das letzte tut Sie bereits (falls sie gerade nicht wegen kvm abstürzt), und das erste ist in Arbeit.

Gibt es einen Weg?
Bitte warten ..
Mitglied: AndiEoh
31.10.2012 um 12:45 Uhr
Sinnvoller wäre es sicher die alten Backups, die als Archiv verwendet werden temporär wieder herzustellen und mit dem neuen System zu sichern. Allerdings solltet Ihr daran arbeiten Backup und Archiv nicht zu mischen.

Gruß

Andi
Bitte warten ..
Mitglied: punktik
31.10.2012 um 22:11 Uhr
Diese Gedanke hat durchaus ihre Daseinsberechtingung. Nur sind es ca. 120 Tapes. Die sind wirklich als Archiv da, und werden ab und zu gebraucht. Und das Laufwerk soll im Serverraum bleiben.
Andere Server dafür habe ich nicht, wäre auch Verschwendung.
Die Frage ist warum geht der Host-System in Kernel-Panic wenn ich das Bad-Laufwerk einschalte?
Da habe ich noch keinen Atwort finden können, deswegen ist dieser Posting hier.
Bitte warten ..
Mitglied: AndiEoh
02.11.2012 um 13:51 Uhr
Die tatsächlich Antwort kann dir nur ein Kernelprogrammierer oder der Hersteller deiner CPU / deines BIOS geben. Eventuell liegt es auch noch am verwendeten HBA. Das Problem ist technisch interessant aber nichts was ich in der Praxis supporten würde. Deshalb bleib ich bei meinem Ratschlag: Wenn du dir in Zukunft viel Arbeit und Ärger ersparen willst migrier den Inhalt der Bänder und denk mal darüber nach warum Backup Bänder nicht wirklich als Langzeit-Archiv taugen.

Gruß

Andi
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Ubuntu
Probleme bei der Einrichtung vom Subnetz KVM Ubuntu 16.04

Frage von TomNick100 zum Thema Ubuntu ...

Ubuntu
Ubuntu 14.04 mit lto 6 und LSI h310 adapter probleme (1)

Frage von Schi-schi zum Thema Ubuntu ...

Windows Server
Laufwerke werden nicht immer gemappt (Windows) (7)

Frage von YotYot zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...