Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Warum läuft unter Win XP innerhalb eines Programmes ein .mp3 file, und in win7 nicht?

Frage Multimedia

Mitglied: Truckermane

Truckermane (Level 1) - Jetzt verbinden

12.06.2011 um 22:53 Uhr, 3760 Aufrufe, 13 Kommentare

Hallo, ich hoffe mein Problem ist nicht allzu speziell,

Ich habe folgendes Problem, in einem Programm namens UMIS laufen an bestimmten Stellen Audiofiles im .mp3 Format ab.
Unter Windows XP klappt das auch tadellos, jedoch in Windows 7 Starter nicht mehr. Der Rest des Programmes macht seine Aufgabe, und das Audiofile, wenn ich es auswähle, und im Mediaplayer ausführe, ist ebenfalls zu hören. nur eben im Programm nicht.
Woran könnte das liegen?

Danke schon mal im Voraus

Gruss Mane
Mitglied: kopie0123
12.06.2011 um 23:56 Uhr
Hey,

klingt nach einem Fehler im Programm.

hast Du es schon mal im Xp Modus ausgeführt?

Gruß
Bitte warten ..
Mitglied: Truckermane
13.06.2011 um 01:29 Uhr
Ja, doch da geht gar nix, kann nicht mal die optionen auswählen, welche im originalen xp von Haus aus eingestellt sind.
Bitte warten ..
Mitglied: Haytech
13.06.2011 um 10:25 Uhr
Moin Moin,
es wäre möglich, das auf dem XP System ein zusätzlicher Player für UMIS installiert ist. Ausserdem könnte im Audiomixer der UMIS als "Stumm" konfiguriert sein. Versuche die XP Maschine zu Virtualisieren dann klappt es bestimmt.
Bitte warten ..
Mitglied: Truckermane
13.06.2011 um 10:36 Uhr
Guten Morgen, da UMIS direkt von SD-Karte läuft, also nichts installiert ist, kann meiner Meinung nach auch kein extra Player installiert sein. Ich glaube dass der XP-Modus im win7-Starter nicht läuft. Das ganze soll nämlich auf einem Netbook laufen.
Zur Erklärung : UMIS ist ein mobiles Informationssystem, das ein Freund von mir angestossen, und von Fraunhofer-Institut entwickelt wurde.Doch für FI ist das Projekt abgeschlossen, deshalb bekommt er von denen keine Unterstützung mehr. Und
die haben das auf Win-XP und Win-CE entwickelt. Ich möchte ihm helfen, darum bin ich nun hier.

Gruss Mane
Bitte warten ..
Mitglied: Haytech
13.06.2011 um 10:59 Uhr
Hallo,
Der XP Modus steht dem Windows 7 Starter nicht zur verfügung. (Lizenz)
in meinen Augen die einfachste variante ist es das XP Virtuell auf dem Rechner laufen zu lassen. Es gibt verschiedene Produkte die kostenlos von Ihren Herstellern zur verfügung stehen. VMWarePlayer oder Microsoft Virtual PC 2007. Eine andere wäre das UMIS auf einem anderen 7 Rechner zu "testen"

Ist auf dem Netbook 7 64bit 32bit installiert ?
Bitte warten ..
Mitglied: Truckermane
13.06.2011 um 11:12 Uhr
32 bit, wenn ich richtig gelesen habe, gibt es die Starter nur in 32 bit.
Bitte warten ..
Mitglied: Lochkartenstanzer
13.06.2011 um 11:23 Uhr
Hast Du mal versucht das auf einem echten Win7 laufen zu lassen? Win7-Starter ist ziemlich "verkrüppelt".
Bitte warten ..
Mitglied: Truckermane
13.06.2011 um 11:30 Uhr
Aus Mangel eines Testsystems, Nein.
Bitte warten ..
Mitglied: Nagus
14.06.2011 um 09:02 Uhr
Moin,

1. ich tippe darauf das die Audio Geräte anders angesprochen werden. Win 7 ist hier doch deutlich anders als WinXP - aber das hilft Dir ja nicht wirklich ...
2. Läuft das Programm an JEDEM XP mit Sound? Möglicherweise musst Du dem Programm die Soundkarte mit liefern .... (ini Datei oder so)

Gruß
Nagus
Bitte warten ..
Mitglied: Phalanx82
14.06.2011 um 15:40 Uhr
Hallo,

was ich am ehesten vermute ist, dass das Programm noch einen externen Thread auf macht,
um das Audio File abzuspielen, entweder mit integriertem Player in eigener Instanz oder ggf.
über den Mediaplayer von Windows 7, da kann man auch Files abspielen, ohne dass das Fenster
des Players überhaupt offen ist, den der Player läuft standardmäßig im Hintergrund als Dienst mit.

Gerade bei der Starter Version von Win7 wird das wohl ein Problem geben, denn bei dieser können
immer nur 3 Programme ausgeführt werden. Nr. 1 wäre ggf. dein Programm, Nr. 2 der bestimmt
(vorinstallierte Virenscanner?) und Nr.3 könnte so ziemlich alles sein...

Um heraus zu finden ob es an der Starter Version liegt, müsstest du also eine beliebige andere Win7
Version installieren und testen.


Mfg.
Bitte warten ..
Mitglied: Lochkartenstanzer
14.06.2011 um 16:38 Uhr
Am besten von http://technet.microsoft.com/de-de/evalcenter/cc442495 eine DVD ziehen und damit probieren. Vielleicht liegt es ja wirklich an W7Starter
Bitte warten ..
Mitglied: Truckermane
25.06.2011 um 10:34 Uhr
Das Programm läuft auf Jedem XP mit Sound.
Hatte aber schon mit Vista Probleme. Lief dort schon nicht mit Sound.
Es wäre interessant, wo die Änderung im Betriebssystem liegt, dass der Windowsmediaplayer nicht mehr vom Programm gefunden wird.
Das müsste ja irgendwo in der Registry sein, oder?

Schöne Grüsse aus Altötting, Mane
Bitte warten ..
Mitglied: Truckermane
13.07.2011 um 10:22 Uhr
Habe auf dem Netbook nun XP eingespielt. Unter Win 7 ging es einfach nicht.
Danke für euer Bemühen

Schöne Grüsse aus Altötting, Mane
Bitte warten ..
Ähnliche Inhalte
Microsoft
gelöst Win 10 Edu N - Thumbnail bei MP3 anzeigen (4)

Frage von Richard97 zum Thema Microsoft ...

Windows 7
Dateien umbenennen Unterschiede in Win7 und XP (3)

Frage von mani55 zum Thema Windows 7 ...

Windows 10
Programm Installation bei Win 10 Fehlerhaft (13)

Frage von Keineahnungvonnix zum Thema Windows 10 ...

Windows Mobile
gelöst Klingelton mit einem MP3 einrichten (1)

Frage von michael1306 zum Thema Windows Mobile ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
iOS
IPhone wird ferngesteuert Hacker? (21)

Frage von Akcent zum Thema iOS ...

Vmware
VMware ESX - Start einer VM verhindern (19)

Frage von emeriks zum Thema Vmware ...

Rechtliche Fragen
gelöst Geschäftsführer Email gefaked (18)

Frage von xbast1x zum Thema Rechtliche Fragen ...