Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

LACP: Debian-Linux und Cisco SG500

Frage Netzwerke LAN, WAN, Wireless

Mitglied: BirdyB

BirdyB (Level 2) - Jetzt verbinden

08.03.2014 um 19:41 Uhr, 2084 Aufrufe, 3 Kommentare

Hallo zusammen,

ich habe da mal eine kleine Frage zu LACP: Wir haben hier im Unternehmen 2 Server, die jeweils mit 2 NICs an 2 gestapelte Cisco SG500 angeschlossen sind und eigentlich LACP machen sollten.
Irgendwie kam mir unser Netzwerk allerdings chronisch langsam vor und ich habe mir mal die /proc/net/bonding/bond0 angesehen und dabei folgenden Output bekommen:
01.
Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009) 
02.
 
03.
Bonding Mode: IEEE 802.3ad Dynamic link aggregation 
04.
Transmit Hash Policy: layer2 (0) 
05.
MII Status: up 
06.
MII Polling Interval (ms): 100 
07.
Up Delay (ms): 0 
08.
Down Delay (ms): 0 
09.
 
10.
802.3ad info 
11.
LACP rate: slow 
12.
Aggregator selection policy (ad_select): stable 
13.
Active Aggregator Info: 
14.
	Aggregator ID: 1 
15.
	Number of ports: 1 
16.
	Actor Key: 17 
17.
	Partner Key: 1 
18.
	Partner Mac Address: 00:00:00:00:00:00 
19.
 
20.
Slave Interface: eth0 
21.
MII Status: up 
22.
Speed: 1000 Mbps 
23.
Duplex: full 
24.
Link Failure Count: 0 
25.
Permanent HW addr: 90:b1:1c:5a:0d:31 
26.
Aggregator ID: 1 
27.
Slave queue ID: 0 
28.
 
29.
Slave Interface: eth1 
30.
MII Status: up 
31.
Speed: 1000 Mbps 
32.
Duplex: full 
33.
Link Failure Count: 0 
34.
Permanent HW addr: 90:b1:1c:5a:0d:32 
35.
Aggregator ID: 2 
36.
Slave queue ID: 0
Das interpretiere ich so, als ob der Server nur eine NIC nutzt. Die /etc/network/interfaces sieht so aus:
01.
auto lo 
02.
iface lo inet loopback 
03.
 
04.
iface eth0 inet manual 
05.
iface eth1 inet manual 
06.
 
07.
iface eth2 inet manual 
08.
iface eth3 inet manual 
09.
iface eth4 inet manual 
10.
#iface eth5 inet manual 
11.
 
12.
 
13.
auto bond0 
14.
iface bond0 inet manual 
15.
        slaves eth0 eth1 
16.
        bond_miimon 100 
17.
        bond_mode 4 
18.
	bond_lacp-rate 4
Danach kommen noch die Definitionen für ein paar Bridge-Interfaces, die ich euch jetzt erspare. Sollten diese von Belang sein, liefere ich die gerne nach.

Ich bin allerdings recht ratlos, warum das LACP nicht funktioniert. Bei der Switchkonfiguration bin ich zugegebenermaßen über das Webinterface nicht hinausgekommen, allerdings ist LACP aktiviert.

Hat jemand einen Rat für mich, wo ich hier ansetzen könnte? Vielen Dank!

Gruß

Berthold
Mitglied: Ruffy1984
11.03.2014, aktualisiert um 14:57 Uhr
Hallo Berthold,

du schreibst 2 gestapelte Switche, bedeutet also die sind gestackt und man sieht es als "ein" Switch ? oder hast du die Konfiguration auf beiden Switchen vorgenommen ?

MIt Linux habe ich leider noch kein LACP aufgebaut aber ich gehe davon aus das deine beiden Switche gestackt sind und du jeweils einen NIC an eine SG500 angeschlossen hast.(active-active) Das sollte eigentlich ohne Probleme funktionieren.

Vielleicht hilft dir das weiter:
http://sbkb.cisco.com/CiscoSB/ukp.aspx?vw=1&docid=6876d888fbce42e1a ...
Bitte warten ..
Mitglied: BirdyB
11.03.2014 um 19:20 Uhr
Hallo Ruffy,

leider bekomme ich nur eine Access-Denied-Meldung bei deinem Link...
Die beiden Switche sind gestackt, ich glaube allerdings, dass einfach der Switch nicht konfiguriert ist, da der Kollege, der das eingerichtet hat, sagte, der Switch würde sich dank LACP automatisch konfigurieren. Ich habe jetzt mal für den ersten Server eine LAG angelegt und werde bei nächster Gelegenheit mal probieren, den Server umzustecken...
Bitte warten ..
Mitglied: BirdyB
15.03.2014 um 11:05 Uhr
Also: Ich habe das Problem gelöst... Die Switchports waren einfach nicht richtig konfiguriert, wenngleich mein Kollege mir versicherte, dies erledigt zu haben.

Danke für die Hilfe und beste Grüße.
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs
gelöst Cisco SG500 - Stacking schlägt fehl (6)

Frage von BirdyB zum Thema Switche und Hubs ...

Netzwerkmanagement
gelöst LAG für LWL Strecke über Cisco SG500 notwendig? (26)

Frage von Ex0r2k16 zum Thema Netzwerkmanagement ...

LAN, WAN, Wireless
gelöst CISCO LACP Portchannel - SNMP Trap bei Änderung eines Members (6)

Frage von chfran zum Thema LAN, WAN, Wireless ...

Netzwerkgrundlagen
gelöst Grundlagenfrage zu LACP vs. Spanning Tree (8)

Frage von ukulele-7 zum Thema Netzwerkgrundlagen ...

Neue Wissensbeiträge
Mac OS X

Apple hat macOS High Sierra veröffentlicht

(4)

Information von Frank zum Thema Mac OS X ...

Viren und Trojaner

Ransomware or Wiper? RedBoot Encrypts Files but also Modifies Partition Table

(4)

Information von BassFishFox zum Thema Viren und Trojaner ...

Notebook & Zubehör

WOL bei HP Notebooks

(8)

Erfahrungsbericht von Henere zum Thema Notebook & Zubehör ...

Heiß diskutierte Inhalte
Windows Server
Seit IP Umstellung DC DNS Fehler (29)

Frage von Yaimael zum Thema Windows Server ...

Windows 10
gelöst Netzwerkkarte schaltet sich erst nach dem Logon ein (24)

Frage von DerWoWusste zum Thema Windows 10 ...

Grafik
gelöst CAD Arbeitsplätze (17)

Frage von Diddi93 zum Thema Grafik ...

Weiterbildung
gelöst Fest angestellter Admin oder Systemhaus Admin mit Kundenbetreuung? (16)

Frage von Voiper zum Thema Weiterbildung ...