Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

LAN-Routing mit Windows Server 2012

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Jamaika23

Jamaika23 (Level 1) - Jetzt verbinden

12.10.2014, aktualisiert 14.10.2014, 2558 Aufrufe, 14 Kommentare

Hallo

folgende Ausgangssituation:

Virtuelles Netz Windows Server 2012 R2

c7692d7230f937f4db2112bcb37a2691 - Klicke auf das Bild, um es zu vergrößern

Auf allen Servern und Routern laufen Windows Server 2012 R2.

3 Switches

192.168.1.0 hängt an Privat1
192.168.2.0 hängt an Privat4
10.160.1.0 hängt an Privat3

192.168.1.1 DC01
192.168.1.10 Server01
192.168.1.254 Router01 (10.160.1.10)

192.168.2.1 DC02
192.168.2.10 Server02
192.168.2.254 Router02 (10.160.1.20)

Für Testzwecke hängt im 10.160.1.0 noch ein DC04 mit 10.160.1.1 (für pings)

Die beiden Router sollen nun über das Transfernetz 10.160.1.0 Daten austauschen.

Wenn ich das richtig verstanden habe brauch in dem Fall keine Routen um zb von Server01 Router02 anzupingen. Einzig Routing und RAS muss mit LAN-Routing konfiguriert sein?! Wenn der Router selbst im Netz ist keine Routen, oder? Funktioniert so allerdings nicht.....

Um aber von 192.168.1.0 nach 192.168.2.0 zu pingen muss ich nun auf beiden Routern Routen eintragen:

Router01:
Ziel 192.168.2.0
Sub 255.255.255.0
Gate 192.168.1.254
Schnitt Privat1

Router02:
Ziel 192.168.1.0
Sub 255.255.255.0
Gate 192.168.2.254
Schnitt Privat2

BZW kann ich hier dann nicht mit 0.0.0.0 arbeiten?!

Ich habe zu Testzwecken einen weiteren Switch an Router01 angeschlossen und dort auch einen Server mitreingehangen, mit LAN-Routing ist eine Kommunikation problemlos möglich.

Ich komm aus dem 192.168.1.0 problemlos bis zum Router01 (10.160.1.10) allerdings erreich ich weitere Teilnehmer im 10.160.1.0 Netz nicht und auch in das andere Heimnetz 192.168.2.0 ist nicht erreichbar. Habe bereits alle Einstellunen geprüft und auch Firewalls ausgeschaltet.


Freue mich über Anregungen und eure Hilfe! Wenn ihr Fragen habt nur her damit, ich weiß dass ich manchmal sehr wirr beschreibe

Greetz

Mitglied: Jamaika23
12.10.2014 um 16:38 Uhr
Kann es vielleicht daran liegen dass ich mehrere Netze und nicht nur 2 verbinde?
Bitte warten ..
Mitglied: Pjordorf
12.10.2014 um 17:13 Uhr
Hallo,

Zitat von Jamaika23:
Virtuelles Netz Windows Server 2012 R2
Überall ein Server 2012R2 oder sind auch andere OS beteiligt (eigentlich egal...)

Auf allen Servern und Routern laufen Windows Server 2012 R2.
Deine Server sind also Router?

3 Switches
Die beiden Router
OK. Soweit können wir in deiner Zeichnung sehen das dort 9 Rechtecke und 4 Ovale Objekte sind. Was soll dort was darstellen? Deine Aufzählung passt nicht zu deiner Zeichnung und damit ohne Kopfschmerzen nicht zu überblicken wer was wo....


Wenn ich das richtig verstanden habe brauch in dem Fall keine Routen um zb von Server01 Router02 anzupingen.
Die haben doch unterschiedliche IPs . Wie soll das ohne Routing gehen wenn du dort keine Bridges hast?

Wenn der Router selbst im Netz ist keine Routen, oder?
Ein Router ohne Routen hat welchen sinn?

Um aber von 192.168.1.0 nach 192.168.2.0 zu pingen
Da dies zwei Netze darstellen sollen (192.168.1.0/24 und 192.168.2.0/24) wirst du die IPs mit 0 nicht haben. Daher auch kein ping an eben diese....

BZW kann ich hier dann nicht mit 0.0.0.0 arbeiten?!
Und wo soll 0.0.0.0 hinführen?

Firewalls ausgeschaltet.
Wenn das Routing nicht stimmt kann ja nur die Firewall dran Schuld sein, also Aus damit.....

Gruß,
Peter
Bitte warten ..
Mitglied: colinardo
12.10.2014, aktualisiert um 18:34 Uhr
Moin,
Router01:
Ziel 192.168.2.0
Sub 255.255.255.0
Gate 192.168.1.254

Router02:
Ziel 192.168.1.0
Sub 255.255.255.0
Gate 192.168.2.254

deine Routen sind falsch !
Setze auf beiden Routern jeweils eine Route, folgendermaßen:

Router01:
Ziel 192.168.2.0
Sub 255.255.255.0
Gate 10.160.1.20

Router02:
Ziel 192.168.1.0
Sub 255.255.255.0
Gate 10.160.1.10

Auf beiden "Windows-Routern" muss dazu das IP-Routing aktiviert sein. Dann läuft das wie gewünscht.

Ein Router kennt per Default erst mal nur seine eigenen Schnittstellen und Subnetze die an ihm
direkt angeschlossen sind, andere Subnetze muss man Ihm erst durch eine statische Route mit dem richtigen Gateway beibringen.
Das sind Routing-Grundlagen - die du bei der Menge an Servern eigentlich beherrschen müsstest

Grüße Uwe
Bitte warten ..
Mitglied: Jamaika23
12.10.2014 um 18:33 Uhr
Es sind alles Server2012 R2 Mschinen.
Mit Hyper-V auf Win8.

Die "Router" Router1 und Router2 sind Server2012 R2 mit Remotezugriff -> Routing und Ras.
Dc1 und Dc2 usw sind Server2012R2 mit Active Directory.
Server1,2,3 sind Server2012R2 ohne jegliche Rollen oder Features dazu installiert.
Die Firewalls sind überall ausgeschalten.

Die runden Kreise stellen die Switches dar, die großen Vierecke sind die beiden Router (2012R2), der Rest die Dcs und Server.

Wenn ich dem Router01 drei Schnittstellen für die 3 Switches geb, Privat1,2,3, hat er in jedem Netz "einen Fuss drin" und brauch doch dann keine Routen bzw regelt dass alleine. Die Route brauch ich wenn wie im Bild ein zweiter Router im Spiel ist und man das Netz dahinter erreichen will?!

Ich kann gerne versuchen das Bild nochmal zu machen, der Teil rechts oben Privat2 mit Dc02 und Server02 ist für mein Problem unerheblich da hier alles funktioniert.
Ich möchte die beiden getrennten internen Netzwerke 192.168.1.0 und 192.168.2.0 miteinander verbinden, das Internet stell ich symbolisch mit dem Netz 10.160.1.0 dar. Mit der .0 mein ich immer das ganze Netz, die Pings hab ich auf .1 .10 .254 versucht.

Aber schonmal Danke für die Hilfe
Bitte warten ..
Mitglied: Jamaika23
12.10.2014, aktualisiert um 18:46 Uhr
Ich befinde mich noch ins Ausbildung und die Maschinen laufen alle nur zu Testzwecken zu Hause
Ich dachte au dass ich dass verstanden habe, aber ich kann in meinem Bild zb aus dem Netz von Privat1 nach Privat2 pingen aber nicht in das Netz von Privat3 obwohl Router1 an allen angeschlossen ist. Ich versuchs mal mit den neuen Routen, aber das Problem mit dem gleichen Subnetz löst es nicht.

Edit: Also mit den neuen Routen klappt es nun. Allerdings ist damit das Subnetz Problem nicht gelöst. Router01 hängt an 3 Switches, Privat1-3, von 1 zu 2 klappt Ping, von 1 zu 3 nicht und von 2 zu 3 auch nicht.
Ich kann die 10.160.1.10 den Router01 pingen, aber nicht den Router02 und Dc04 die beide an Privat3 mit 10.160.1.1 und 10.160.1.20 hängen.
Bitte warten ..
Mitglied: colinardo
12.10.2014, aktualisiert um 18:57 Uhr
Zitat von Jamaika23:
. Allerdings ist damit das Subnetz Problem nicht gelöst. Router01 hängt an
3 Switches, Privat1-3, von 1 zu 2 klappt Ping, von 1 zu 3 nicht und von 2 zu 3 auch nicht.
Ich kann die 10.160.1.10 den Router01 pingen, aber nicht den Router02 und Dc04 die beide an Privat3 mit 10.160.1.1 und 10.160.1.20
hängen.
Ich sag nur die Firewalls an den Clients checken nicht an den Routern. Defaultmäßig lässt Windows ICMP Traffic nur aus dem selben Subnetz zu. Das haben wir hier jede Woche bestimmt 3-4 mal - das wird gerne vergessen.
http://www.administrator.de/forum/routing-zwischen-2-subnetzen-übe ...
Bitte warten ..
Mitglied: Jamaika23
12.10.2014 um 18:57 Uhr
Firewall sind alle aus...also an jeder Maschine ob Router Server oder Dc
Bitte warten ..
Mitglied: colinardo
12.10.2014 um 19:02 Uhr
dann aktualisiere deine Grafik mal mit deinen nachgetragenen Infos, damit man genau weis wie du was eingerichtet hast.
Mit tracert kannst du feststellen an welcher Stelle der Traffic nicht durchkommt, ebenso ist mit Wireshark der Verursacher schnell ausfindig zu machen.
Bitte warten ..
Mitglied: chiefteddy
12.10.2014 um 19:54 Uhr
Hallo,

natürlich kannst Du die Router (Routing-Tabellen) von Hand konfigurieren. Aber für diesen Zweck hat man die Routing-Protokolle (RIP, OSPF) "erfunden". Bevor Du also von Hand Routing-Tabellen erstellst, laß das ganze doch den Router alleine machen. Schau dann anschließend das Ergebnis (Routing-Tabellen) an und versuche es zu verstehen. Wenn Du dann alles verstanden hast, kannst Du ja versuchen, die Routing-Protokolle wieder zu deaktivieren und Deine Experimente zu machen.

Für den Einstieg ist RIP leichter zu verstehen und zu implementieren.

http://de.wikipedia.org/wiki/Routing_Information_Protocol

Für größere Netzwerke (LAN) ist OSPF effizienter, aber auch komplexer und aufwendiger zu implementieren.

http://de.wikipedia.org/wiki/Open_Shortest_Path_First

Für ein so kleines Netz, wie Deines ist der etwas höhere Datenverkehr bei RIP abeer unerheblich.



Wenn es um Sicherheit im Netzwerk geht, ist dafür eine Firewall mit ihrem Regelwerk zuständig. Nicht der Roter mit seiner Routing-Tabelle.

Jürgen
Bitte warten ..
Mitglied: Jamaika23
14.10.2014 um 20:29 Uhr
c7692d7230f937f4db2112bcb37a2691 - Klicke auf das Bild, um es zu vergrößern

So mein neuer Netzplan. Server3 sind alles DCs, Server1 alles leere Windows Server 2012 R2. Router sind auch Windows Server 2012 R2 mit Routing und RAS.

Aktuell sieht es so aus dass ich mit den neuen Routen 192.168.1.0 und 192.168.2.0 verbunden habe und auch die Pings funktionieren.
Allerdings ist vom 192.168.1.0 Netz ein Ping nur ins 172.16.1.0 Netz und eben 192.168.2.0 möglich.
Im 10.160.1.0 Netz erreich ich von Server1 nur den Router mit der 10.160.1.10, den Server der mit der 10.160.1.1 angeschlossen ist sowie der andere Router mit der 10.160.1.20 lassen sich nicht anpingen.

Hab das Ganze auch nochmal anders nachgestellt, weil es ja wie es scheint um ein LAN-routing Problem geht. Dazu hab ich einen neuen Router mit 3 neuen switches verbunden und an alle Switches noch ne Server2012 Maschine drangehängt. Nach der Installation von Routing und Ras und der Einstellung LAN-Routing konnte ich aus allen 3 Subnetzen die jweils anderen erreichen, so weit so gut. Allerdings, und hier ist wieder der Vermerk zur eigentlichen Frage, funktioniert dass nur solang ich keinen weiteren Router an einen Switch häng, also dass was oben im Netzplan auch dargestellt ist. Sobald der 2te Router mit drinhängt komm ich von 192.168.1.0 nur noch ins 172.16.1.0 Netz, nicht aber ins 10.160.1.0 bzw den Router schon weitere Maschinen nicht.

Und nochmal: Alle Firewalls sind aus
Bitte warten ..
Mitglied: Jamaika23
14.10.2014 um 20:31 Uhr
3 Subnetze über einen Router -> kein Problem
3 Subnetze über einen Router und ein weiteres Subnetz an einem zweiten Router -> siehe oben
Bitte warten ..
Mitglied: colinardo
14.10.2014, aktualisiert 15.10.2014
natürlich musst du auch dem zweiten Router(Blau unten) das 172.16.1.x Netz via Route kenntlich machen, damit dieser Antworten kann. Das der Server 3 im 10.160.1.x Netz nicht antwortet kommt dann auch sehr wahrscheinlich daher das du auf Ihm den zweiten Router(Blau unten) als Gateway konfiguriert hast. Dann laufen die Pakete natürlich in leere, weil dieser Router das Netz seinerseits nicht kennt.
Also:
Alle Netze die jeweils hinter den Routern vorkommen muss dem jeweils anderen Router durch eine Route kenntlich gemacht werden, wenn man nicht die DefaultRoute auf den jeweils anderen Router setzt.

Du musst dir bildlich den Verlauf des Paketes vorstellen:
Beispiel:
ICMP Paket von 172.16.1.1 nach 10.160.1.20 bedeutet im Moment folgendes bei dir:

1. Paket von 172.16.1.1 an Router01 = OK
2. Paket geht weiter von Router01(10.160.1.10) an Router02(10.160.1.20) = Paket kommt an Router02 an weil Router01 ja selber am 10.160.1.x Netz hängt, jedoch kann Router02 keine Antwort schicken, da er nicht weiß wohin er Pakete mit dem Netz 172.16.1.x schicken soll weil diese ja als Absenderadresse(Source Address) im IP-Header steht. Deswegen muss o.g. zus. Route auf Router02 eingetragen werden oder dort das DefaultGW auf die 10.160.1.10 gesetzt werden.

Dann läuft dat min jung
Bitte warten ..
Mitglied: Jamaika23
13.11.2014 um 20:50 Uhr
Mein Problem waren die Gateways. Hatte in meinem 10.160.1.0 Schwierigkeiten das Gateway zu definieren.

Nun läuft alles, mit den richtigen Routen und Gateways.

Danke für die Hilfe!
Bitte warten ..
Mitglied: colinardo
13.11.2014 um 21:03 Uhr
Alles klar den Beitrag dann bitte noch als gelöst markieren. Merci.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
gelöst Routing und Ras bei Windows Server 2012 R2 (12)

Frage von BlacksGood zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012 mit Fritzbox per VPN verbinden (13)

Frage von StefanT81 zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012 Standard Upgrade auf R2 (8)

Frage von Hendrik2586 zum Thema Windows Server ...

Backup
Backup QNAP auf Windows Server 2012 (10)

Frage von H41mSh1C0R zum Thema Backup ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...