Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

LAN-Verbindung über Commandline deaktivieren und wieder aktivieren

Frage Entwicklung Batch & Shell

Mitglied: robcomboy

robcomboy (Level 1) - Jetzt verbinden

15.05.2011 um 08:52 Uhr, 6318 Aufrufe, 6 Kommentare

für Gebrauch in einem Hintergrunddienst

Hallo zusammen,

Ihr alle kennt das ja,
wenn man die "Lan-Verbindung" in XP unter Netzwerkverbindungen deaktiviert, weil man Sie gerade nicht braucht.
Ich habe zu diesem Thema schon ne ganze Menge im Netz gewühlt, und auch das eine oder andere gefunden,
aber keine Lösung war wirklich überzeugend.

Devcon von Microsoft ist mir bekannt,
hierbei habe ich allerdings das Problem dass es mir wichtige Systemkomponenten deaktiviert, wenn ich die Onboard-Lan-Verbindung deaktivieren will.
http://support.microsoft.com/?kbid=311272


netsh funktioniert meines Wissens nur unter Vista,


Wenn also jemand eine Idee hat, wie man das Ganze hier angehen kann, dann immer her damit.

Vielen Dank.

Grüße, Robcomboy
Mitglied: Skyemugen
15.05.2011 um 09:41 Uhr
Zitat von robcomboy:
netsh funktioniert meines Wissens nur unter Vista,

Aloha,

na dein Wissen möchte ich haben ...
Dennoch ließe sich das Ganze auch per netsh nicht lösen


P.S.: Du bist im www nicht der erste, der danach sucht ...
Bitte warten ..
Mitglied: MiniStrator
15.05.2011 um 11:48 Uhr
Moin,
Devcon von Microsoft ist mir bekannt, hierbei habe ich allerdings das Problem dass es mir wichtige Systemkomponenten deaktiviert, wenn ich die Onboard-Lan-Verbindung deaktivieren will.
Kann ich nicht nachvollziehen. Was machst du denn mit devcon, bzw. wie sieht dein Befehl aus?

Gruß
MiniStrator
Bitte warten ..
Mitglied: bastla
15.05.2011 um 12:12 Uhr
Hallo robcomboy!

Im "TechNet Script Center-Repository ": Enable Disable Network Adapter

Grüße
bastla
Bitte warten ..
Mitglied: robcomboy
15.05.2011 um 12:24 Uhr
Hi Ministrator

Ich habe den Fehler gemacht nur die Anfangs-ID zu benutzen,

01.
"PCI\VEN_13F0"
Damit funktioniert es wunderbar,

http://www.mcseboard.de/windows-forum-scripting-71/per-batch-vbs-script ...

01.
devcon disable =net "@pci\VEN_11AB&DEV_4363&SUBSYS_139A10CF&REV_12\4&192AC53F&0&00E0"
Vielen Dank.

Grüße,
Robcomboy
Bitte warten ..
Mitglied: robcomboy
15.05.2011 um 12:26 Uhr
Hi bastla,

Danke für deinen Ansatz,
vielleicht brauche ich diese Version in der Zukunft mal.

Grüße,
Robcomboy
Bitte warten ..
Mitglied: MiniStrator
15.05.2011 um 12:28 Uhr
Hi Robcomboy,

hatte ich vermutet

Markiere den Fred doch noch als gelöst War zu schnell...

Gruß
MiniStrator
Bitte warten ..
Ähnliche Inhalte
Windows 10
gelöst Sicherheitscenter aktivieren, aber Verwaltungsinstrumentation deaktivieren (1)

Frage von AnfaengerCH zum Thema Windows 10 ...

Netzwerkmanagement
TeamViewer Eingehende LAN-Verbindung (3)

Frage von biwboy zum Thema Netzwerkmanagement ...

LAN, WAN, Wireless
W-LAN-Verbindung bricht ab, LAN bleibt stabil (8)

Frage von max.webbing zum Thema LAN, WAN, Wireless ...

Neue Wissensbeiträge
Viren und Trojaner

Link: Neues Botnetz über IoT-Geräte

Information von certifiedit.net zum Thema Viren und Trojaner ...

Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows 10
Seekrank bei Windows 10 (18)

Frage von zauberer123 zum Thema Windows 10 ...

Switche und Hubs
gelöst VLAN für Gäste WLAN einrichten über FritzBox und Switch (10)

Frage von Elo-14 zum Thema Switche und Hubs ...

Windows Server
Frage zu Server Rack (10)

Frage von rainergugus zum Thema Windows Server ...