Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Langsames Verhalten Exchange 2013

Frage Microsoft Exchange Server

Mitglied: jadefalke

jadefalke (Level 1) - Jetzt verbinden

10.09.2014, aktualisiert 16:30 Uhr, 8859 Aufrufe, 4 Kommentare

Hallo,
ich bin auf der Suche nach Anregungen um mein Exchange 2013 Problem in den Griff zu bekommen.
Der Zugriff auf mein Exchange 2013 Server ist sehr langsam. Sowohl der Aufruf der ECP auch der OWA Seite braucht ca. 40-90 Sekunden.
Es spielt keine Rolle woher ich die Seiten aufrufe (vom Exchange Server direkt oder von einem anderen Server im Netz)
Auch innerhalb der ECP beim Menüwechsel ist es gefühlt langsam.
Im Outlook 2010 und Outlook 2013 arbeiten wir mit aktiviertem Cache, wenn an aus dem Benutzerpostfach in die öffentlichen Ordner wechselt,kann man anfangen zu zählen, 1,2-10, dann sind die ÖO da.

Microsoft empfiehlt auf dem Exchange Server IP V6 auf der Netzwerkkarte zu deaktivieren. Na das mach ich nun mal nicht. Das hat bei Exchange 2010 nur Probleme verursacht, da wirds wohl bei Exchange 2013 nicht anders sein.

Meine Umgebung sieht wie folgt aus.
ein ESXi 5.5 Host ( 2 GB RAM )
- ein Server 2012 DC (DNS, AD, DHCP) lauft mit 4 GB RAM
- ein Server 2012 mit Exchange 2013 Server (kein DC , DNS) läuft mit 14 GB RAM (ca 10 Postfächer)
- weitere Server mit 4 GB RAM

Best Practice Analyser gibt mir eine Warnung aus die ich versucht habe zu rechechieren, aber nicht verstanden habe worum es geht, bzw welche Auswirkung das auf mein System hat.
Für Anwendungspools sollte festgelegt werden, dass sie als Anwendungspoolidentitäten ausgeführt werden.

Die Auslastung des Systems ist recht hoch. Vorallem die CPU fällt nie unter 50% und dafür sind ca 3-4 IIS Worker Processe zuständig
Wenn diese die CPU nicht beanspruchen dann ist es ein "Host Process for WINRM plug-ins" Process der meist mit mindestens 30% CPU Last arbeitet.

Ich kann mir da kein Reim draus machen.
Einfach Killen möchte ich die Processe nicht, voallem da IIS sicherlich diese wieder startet.
WinRM plugIns hab ich nie installiert bzw konfiguriert.
Wo kann ich hier ansetzen?

Für ein paar Ideen wäre ich dankbar.


PS: Ich habe eine Warnung Event ID: 5011 MS-WAS
Schwerwiegender Kommunikationsfehler im Windows-Prozessaktivierungsdienst bei einem Prozess für den Anwendungspool "MSExchangePowerShellAppPool". Die Prozess-ID ist "9664". Das Datenfeld enthält die Fehlernummer.

Was bedeutet das ?
Mitglied: jadefalke
10.09.2014 um 16:37 Uhr
Ich habe weiter getestet und bin mittlerweile der Meinung dass es am IIS liegt.

Die MS-WAS Meldung erhalte ich nachts zwischen 1 und 2 Uhr. In dieser Zeit läuft mein Backup. Das könnte die Meldung erklären. Vorallem weil diese nur 1-2x Auftritt.

Weiterhin habe ich folgendes beobachten können.
Wenn ich die ECP von einem Client aufrufe, dann starten auf dem Exchange Server die IIS Worker Prozesse und treiben die CPU last auf nahezu 100%

Dazwischen mischt auch ein Prozess namens Noderunner.exe der lauft Google ein neues Feature von Exchange 2013 ist und für das Fast Search zuständig ist.
Naja mein Exchange ist alles andere als FAST

jemand eine Idee ?
Bitte warten ..
Mitglied: Komabaer
11.09.2014, aktualisiert um 12:12 Uhr
Hast du Smartphones über Active-Sync laufen?

Das Problem hatten wir in meiner ehemaligen Firma das die Smartphones den IIS Prozess w3wp.exe star beansprucht haben.

Bei uns half damals nur die CAS/HUB Rolle auf einen seperaten Server zu legen und den Prozess zu begrenzen.

BTW: ESXi Server mit nur 2GB??? Verschrieben?
Bitte warten ..
Mitglied: jadefalke
12.09.2014 um 10:52 Uhr
Hallo,

danke für den Hinweis, daran hab ich gar nicht gedacht.
Ja wir haben alle unsere eMail Konten mit Active Sync verbunden. Ist mir aber nie im Traum eingefallen dass die so viel Last verursachen.
Welchen Prozess sollte ich da begrenzen ? den w3wp?
Ich weis wie man die Store.exe begrenzt damit die Speicherauslastung nicht explodiert, aber mir ist nicht bekannt wie ich einem Prozess sagen soll dass er nicht mehr als sagen wir mal 30% CPU fressen soll.
Und auch das wäre mir nicht geholfen denn der IIS Worker Process ist ca 5-6 mal gestartet, und oftmals stehten 3-4 IIS Worker Prozesse untereinander an erster stelle in der CPU Auslastung.

ESXi: ich meinte der Host hat lediglich 2 GB RAM. Der restliche RAM steht für die VMs bereit.Der Exch hat 14 GB.
Bitte warten ..
Mitglied: Komabaer
15.09.2014 um 18:25 Uhr
Welchen Prozess sollte ich da begrenzen ? den w3wp?
Ich weis wie man die Store.exe begrenzt damit die Speicherauslastung nicht explodiert, aber mir ist nicht bekannt wie ich einem
Prozess sagen soll dass er nicht mehr als sagen wir mal 30% CPU fressen soll.
Und auch das wäre mir nicht geholfen denn der IIS Worker Process ist ca 5-6 mal gestartet, und oftmals stehten 3-4 IIS Worker
Prozesse untereinander an erster stelle in der CPU Auslastung.

Du kannst so einiges limitieren, das geht dann über den IIS Manager.
Z.b. bei ActiveSync gehst du im IIS Manager auf "Application Pools" -> Rechtsklick auf MSExchangeSyncPool und dann auf Advanced Settings (Ist bei mir English). Dort findest du unter CPU einige Einstellungen die du tätigen kannst. Wir hatten es damals auf 40% eingestellt. Du musst nur darauf achten den richtigen Wert einzugeben 1/1000.


ESXi: ich meinte der Host hat lediglich 2 GB RAM. Der restliche RAM steht für die VMs bereit.Der Exch hat 14 GB.

Na dann ist ja gut :o)
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Update
gelöst MS: Update-Server-Adressen OHNE Wildcards (17)

Frage von mrserious73 zum Thema Windows Update ...

Viren und Trojaner
Ransomware .nm4 (14)

Frage von Zyklo92 zum Thema Viren und Trojaner ...

Microsoft Office
+1.000 Ordner in Outlook: Wie besser? (11)

Frage von Matsushita zum Thema Microsoft Office ...