Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Layer 3 Switch, DHCP Server und Router vernetzen

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Peacer

Peacer (Level 1) - Jetzt verbinden

29.05.2011, aktualisiert 18.10.2012, 4606 Aufrufe, 3 Kommentare

Hallo Zusammen,

ich habe folgende Konfiguration


zentraler Layer 3 Cisco Switch mit folgenden VLANs

VLAN10 für Clients/Workstations (Subnet: 10.82.10.0/24)
VLAN12 für Printer (Subnet: 10.82.12.0/24)
VLAN35 für WLAN Clients (Subnet: 10.82.35.0/24)
VLAN41 für Server (Subnet: 10.82.41.0/24)

ip helperaddress ist bei ALLEN VLANs: 10.82.41.211/255.255.255.0

DHCP & DNS Server (win 2k8): 10.82.41.211/255.255.255.0
Linksys Router RV042: 10.82.41.210/255.255.255.0

DHCP Server und Router sind natürlich im selben VLAN.


IP-Adressvergabe funktioniert super, nur habe ich jetzt ein kleines Problem die Clients ins Internet zu bringen.
Im Gegensatz zu allen anderen Servern im VLAN41, kann die 10.82.41.210 auch nur aus dem VLAN41 pingen, aus allen anderen gar nicht.


Jemand eine Idee?

danke im Voraus
Peacer
Mitglied: aqui
29.05.2011 um 13:11 Uhr
Das ist doch sonnenklar woran das liegt !!
Pingst du z.B. aus dem VLAN 10.82.12.0, dann merkt der Linksys das der Absender nicht in seinem eigenen VLAN .41.0 /24 liegt.
Folglich sieht er in seine lokale Routing Tabelle ob er dort eine Route in dieses VLAN Netz hat.
Vermutlich hast du wie leider immer hier alle statischen Routen in die VLAN Netze vergessen im Linksys Router unter statische Routen einzutragen.
Ist das der Fall nimmt der Linksys immer seine Default Route und schickt das Ping Antwortpaket ins 10.82.12.0er Netz zum Internet Provider wo es dann im Nirwana verschwindet mit dem Ergebnis was du dann siehst. (10er Netz ist ein im Internet nicht geroutetes RFC 1918 IP Netz !)
Fazit:
Trage alle VLAN Netze (außer das lokale) im Linksys als statische Route ein ala:
Zielnetz: 10.82.10.0, Maske: 255.255.255.0, Gateway: <vlan_ip_abdresse Cisco SwitchVLAN10>
Zielnetz: 10.82.12.0, Maske: 255.255.255.0, Gateway: <vlan_ip_abdresse Cisco SwitchVLAN12>
Zielnetz: 10.82.35.0, Maske: 255.255.255.0, Gateway: <vlan_ip_abdresse Cisco SwitchVLAN35>
Statische Route Cisco Switch: ip route 0.0.0.0 0.0.0.0 10.82.41.210

Fertig ist der Lack !

Noch ein sinnvoller Tip: Den Internet Router solltest du niemals in das gleiche Segment setzen wo der Server untergebracht ist um niemals internen Server Produktivtraffic mit Internettraffic zu mischen und den Server ggf. zu kompromittieren.
Erstelle ein eigenes Segment z.B. VLAN 99 fürs Internet und setze dort den Router rein mit z.B. dem IP Netz 10.82.99.0 /24 und pass die default Route auf dem Switch entsprechend an sowie die statischen Routen auf dem Linksys.
So hast du alles sauber und sicher getrennt und kannst auch viel besser z.B. mit IP Accesslisten auf dem Switch am interface vlan 99 den Internet Traffic ins Produktivnetz steuern wenn du willst... z.B. File Sharing ala Kazaa, eDonkey und Co. und andere nicht gewollte Dinge für die User blocken.
Bitte warten ..
Mitglied: Peacer
30.05.2011 um 07:43 Uhr
Ok habe den Router in ein eigenes VLAN gesetzt.

Jetzt sieht die Konfig folgendermaßen aus:

Router Private IP: 10.82.99.210/255.255.255.0

Routen:

10.82.10.0/255.255.255.0 Gateway: 10.82.10.1
10.82.35.0/255.255.255.0 Gateway: 10.82.35.1
10.82.41.0/255.255.255.0 Gateway: 10.82.41.1

Switch standart route:

0.0.0.0 0.0.0.0 10.82.99.210

pingen konnte ich nun, jedoch kam ich immernoch nicht ins netz.
ein tracert zeigte das ich am router hängen blieb.

Als ich dann die Subnet mask der Private IP des Routers in: 255.0.0.0 abänderte kam ich sofort ins netz.

Ist das korrekt so?

LG Peacer
Bitte warten ..
Mitglied: aqui
30.05.2011, aktualisiert 18.10.2012
Nein, das ist natürlich vollkommen falsch, denn nun hast du einen Adress Masken Mismatch im gesamten System !
Dein Router denkt jetzt er ist im Netzwerk 10.0.0.0 alles was in den letzten 3 Bytes ist ist damit für ihn einen Hostadresse. Das endet so im völligen Adress Chaos !!

Du solltest dir den Thread einmal genau durchlesen bitte !
Deine statischen Routen auf dem Router sind wieder komplett FALSCH !!
Unterschiedliche Gateway hinten anzugeben ist doch totaler Unsinn !! Wie soll denn dein Router bitte sehr IP Adressen wie 10.82.10.1 oder 10.82.35.1 usw. kennen ??
Er kennt ja diese Netze nicht mal, denn genau mit diesen statischen Routen willst du ihm da ja erst bekannt machen. Wie sollte er also diese Gateways bei dir je erreichen können ??? Alles was er kennt ist sein eigenes Netzwerk 10.82.99.0 /24.
Vergiss also diesen Blödsinn mit den falschen Gateways ganz schnell und korriger das !!
Die falsche Subnetzmaske solltest du natürlich auch schleunigst wieder auf 24 Bit setzen !!

Sein Gateway am Switch ist die 10.82.99.1 wenn das die vlan IP Adresse des Switches ist. Dort muss doch logischerweise alles hin. Der Switch kennt dann die Zielnetze, denn sie sind alle an ihn direkt angeschlossen...logisch.
Änder also deine statischen Routen im Internet Router in
10.82.10.0/255.255.255.0 Gateway: 10.82.99.1
10.82.35.0/255.255.255.0 Gateway: 10.82.99.1
10.82.41.0/255.255.255.0 Gateway: 10.82.99.1

Dann funktioniert auch alles und das Drama hier hat ein Ende.
Dann solltest du besser auch noch einmal dringenst:
http://de.wikipedia.org/wiki/Routing
durchlesen damit dir solche banalen Routing Denkfehler in Zukunft nicht mehr passieren ! Dies:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
hilft zusätzlich zum Verständnis wie sich Pakete im OSI Layer 3 fortbewegen...
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
DHCP-Server vor Änderung schützen (1)

Frage von cuilster zum Thema Windows Server ...

Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Netzwerkmanagement
gelöst Ein Gerät, zwei DHCP Server oder mehr (16)

Frage von fuddel18 zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
RODC über VPN - Verbindung weg (10)

Frage von stefan2k1 zum Thema Windows Server ...