Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Layer im IE 7 wird falsch angezeigt

Frage Entwicklung Webentwicklung

Mitglied: EvilMoe

EvilMoe (Level 2) - Jetzt verbinden

14.07.2007 um 22:08 Uhr, 3310 Aufrufe

Hallo,

ich bin gearde auf einem Problem gestoßen ich bin mir sicher ihr kennt eine Antwort drauf. So, ich erzeuge mit JavaScript ein Layer bei bestimmten ereignissen, das ist ja auch kein Problem. Bei der Anzeige unterscheidet sich allerding der IE 7 von allen anderen (Firefox 2 und Opera 9 hab ich probiert).

Der HTML code ausdem JS
01.
	var code =  
02.
	'<div id="layer">' + 
03.
		'<table>'+ 
04.
			'<tr>'+  
05.
				'<td style="background:#333333; height:16px;">'+  
06.
					'<div id="layer_titel">Titel</div>'+ 
07.
					'<div id="layer_close"><img src="images/close.jpg" height="16" align="right" onclick="remove('layer_');"></div>'+ 
08.
				'</td>'+ 
09.
			'</tr>'+ 
10.
			'<tr>'+ 
11.
				'<td>'+ 
12.
					'<div align="left" style="margin-left:7px;">'+ 
13.
						Text+ 
14.
					'</div>'+ 
15.
				'</td>'+ 
16.
			'</tr>'+ 
17.
		'</table>'+ 
18.
	'</div>'; 
19.
 
CSS
01.
/* layer */ 
02.
 
03.
#layer { 
04.
	border:1px solid #000000; 
05.
	position:absolute; 
06.
	width:300px; 
07.
	height:120px; 
08.
	z-index:1; 
09.
	left:47%; 
10.
	top:290px; 
11.
	background:#CCCCCC; 
12.
13.
#layer table{ 
14.
	width:100%; 
15.
	height:100%; 
16.
	border:none; 
17.
	border-collapse: collapse; 
18.
19.
 
20.
#layer img { 
21.
	border:none; 
22.
23.
 
24.
#layer_titel { 
25.
	color: #FFFFFF; 
26.
	font-weight:bold; 
27.
	float:left; 
28.
	height:16px; 
29.
	max-height:16px; 
30.
	 
31.
32.
#layer_close { 
33.
	height:16px; 
34.
35.
 
36.
/* layer */
Jetzt hab ich noch 2 Screenshots gemacht. Das erste ist richtig so sieht im Firefox und Opera aus, der 2. aus dem IE 7.

http://images.evilmoe.com/thumbs/f435b59f7c.png
http://images.evilmoe.com/thumbs/92bc32f04a.png
Neuester Wissensbeitrag
Exchange Server

WSUS bietet CU22 für Exchange 2007 SP3 nicht an. EOL Exchange 2007

Tipp von DerWoWusste zum Thema Exchange Server ...

Ähnliche Inhalte
Windows Server
IP-Einstellungen werden falsch angezeigt (5)

Frage von schlumpf90 zum Thema Windows Server ...

Microsoft
gelöst Lokale Intranet Site im IE wird nicht über GPO hinzugefügt (1)

Frage von Hanuta zum Thema Microsoft ...

Windows 10
Partitonen werden nicht angezeigt (3)

Frage von Alex.Sp zum Thema Windows 10 ...

Windows Server
gelöst GPO wird übernommen aber nicht angezeigt (11)

Frage von stefts zum Thema Windows Server ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst Batch xls nach aktuellem Datum auslesen und email senden (14)

Frage von michi-ffm zum Thema Batch & Shell ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (13)

Frage von Driphex zum Thema Exchange Server ...

Backup
Datensicherung ARCHIV (12)

Frage von fautec56 zum Thema Backup ...