Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Leere Zelle nicht leer?

Frage Microsoft Microsoft Office

Mitglied: dummer-esel

dummer-esel (Level 1) - Jetzt verbinden

08.02.2013 um 12:39 Uhr, 5012 Aufrufe, 3 Kommentare

Hallo,

ich habe ein Makro (VBA, Excel) geschrieben, das bestimmte Zellen von der einen in die andere Excel-Datei einfügt.

Nun wollte ich prüfen, ob die eingefügte Zelle leer ist, um ggf. eine Meldung auszugeben.
Seltsamerweise scheint die Zelle nicht leer zu sein, obwohl sie eindeutig leer ist!

Folgendes habe ich probiert, ist aber alles "False":
01.
Cells(y, x).Select 
02.
 
03.
Selection.PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks:=True, Transpose:=False 
04.
 
05.
If (Cells(y, x) = 0 Or Cells(y, x) = "") ... 
06.
 
07.
If CStr(Cells(y, x).Value) = "" ... 
08.
 
09.
If IsEmpty(Cells(y, x).Value) ...
die Zelle ist eindeutig leer: keine Leerzeichen/Tabs drin, keine Formeln.
Wie kann ich korrekt prüfen, ob ein Wert drinsteht?

Danke schon mal!
Mitglied: Pjordorf
08.02.2013 um 13:18 Uhr
Hallo,

Zitat von dummer-esel:
Seltsamerweise scheint die Zelle nicht leer zu sein, obwohl sie eindeutig leer ist!
Dann wäre doch interesant zu sehen was dort drinnen sein soll, oder? Dir mal isnull oder isblank http://www.techonthenet.com/excel/formulas/isnull.php und http://www.techonthenet.com/excel/formulas/isblank.php angeschaut? Oder hier http://www.mrexcel.com/forum/excel-questions/42495-better-explanation-n ....

Gruß,
Peter
Bitte warten ..
Mitglied: dummer-esel
08.02.2013 um 14:02 Uhr
Hi Peter,

Dann wäre doch interesant zu sehen was dort drinnen sein soll, oder?
gute Idee! Wie mache ich das am besten? Ich habe es mal mit einer MsgBox versucht:
01.
MsgBox("->" & Cells(y, x).Value & "<-", vbOKOnly)
aber das Ergebnis sah dann lediglich so aus: -> <-
(ob da ein Leerzeichen zwischen war kann ich nicht sagen, da ich es nicht markieren konnte)

ebenfalls "false"

wenn ich die Zelle später in der Excel-Tabelle direkt überprüfe (also nach der Ausführung des Makros), ist es alles schön und gut. Sowohl =ISTLEER(A2) als auch =WENN(A2=""; ...; ...) geben TRUE aus.

Bei der Ausführung des Makros scheint aber noch irgend etwas drin zu stehen.

Ich habe noch eine mögliche Fehlerquelle:
- In der Tabelle, woraus kopiert wird, sind mehrere Zellen verbunden.
- In der Einfügen-Tabelle wird das dann in mehrere (nicht verbundene) Zellen eingefügt, wobei nur in der 1. ein Wert steht
- Wenn im Original kein Wert vorhanden ist (trotzdem sind die Zellen verbunden), dann ist auch die erste Zelle leer
-> Kann es also irgendwie damit zusammenhängen, dass beim kopieren mehrere Zellen verbunden waren?

Danke!
Bitte warten ..
Mitglied: dummer-esel
11.02.2013 um 19:55 Uhr
Ich werde noch verrück!

Dies hier
01.
MsgBox(Len(Cells(zeile, 1).Value), vbOKOnly)
liefert mir 0 zurück. (hab auch einen Screenshot gemacht, falls es jemanden interessiert.)

Allerdings wird die Zeile davor
01.
If Len(Cells(zeile, 1).Value) = 0 Then ...
nicht ausgeführt bzw. die Bedingung scheint "false" zu sein.

Woran liegt das?
Hier ist doch irgendwas faul!!

Danke für jegliche Hilfe/Ideen!
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange Postfach leeren - nicht löschen (11)

Frage von AndreasOC zum Thema Exchange Server ...

CPU, RAM, Mainboards
gelöst CMOS Batterie leer (8)

Frage von Markowitsch zum Thema CPU, RAM, Mainboards ...

Microsoft Office
gelöst Pivotchart mit (Leer)-Inhalt ausblenden (2)

Frage von MiSt zum Thema Microsoft Office ...

Windows 10
VPN Netzlaufwerk leer (4)

Frage von Edaseins zum Thema Windows 10 ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 im Unternehmen? (28)

Frage von zorlayan zum Thema Windows 10 ...

LAN, WAN, Wireless
Ping u. DNS geht am Rechner nicht mehr (21)

Frage von Kuemmel zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
CNC Maschinen verlieren Netzwerkverbindung (kurioser Fehler) (17)

Frage von NoHopeNoFear zum Thema LAN, WAN, Wireless ...