Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

LightBox2 gibt fehlerhafte darstellung aus, seit php-code

Frage Entwicklung PHP

Mitglied: Michael1736

Michael1736 (Level 1) - Jetzt verbinden

09.11.2009 um 14:11 Uhr, 2687 Aufrufe, 1 Kommentar

Hallo,
seit dem ich in die Seite eines Kunden ein dynamisches auslesen eines Ordners eingefügt habe, spinnt die Ausgabe von LightBox.
Daher hoffe ich das ich nicht im falschen Forum bin und der Fehler nicht im Javascript liegt (da ich davon keine Ahnung habe und auch nicht im Originalcode rumgeschrieben habe!)

Es geht im die Seite http://www.bildschönes.de .
Dort habe ich zuerst immer den Inhalt manuell hinzugefügt, jedoch wollte ich mir die arbeit erleichtern und das ganze dynamisch mit einem php-script auslesen, welches ich öfter benutze und mir nie Probleme gemacht hat.
Die Problematik die entsteht ist, dass in der Lightbox darstellung, im IE manche der Bilder (scheinbar zufällig, da dies nur manchmal der Fall ist) zwar richtig geladen werden, jedoch die Lightbox eine Größe von vlt. 50px x 50px hat und das Bild so nicht zentriert, sondern von der Mitte aus nach Rechts, über den Seitenrand hinaus dargestellt wird.

Mein Script zum Ordner auslesen ist folgendes:
01.
$verzeichnis = "thumbs_".$url."/"
02.
$ordner = openDir($verzeichnis); 
03.
while ($file = readDir($ordner)) { 
04.
	if($file != "." && $file != ".." && $file != "Thumbs.db") { 
05.
		echo"<a href=\""
06.
		$gross = substr("$verzeichnis$file", 7, 100); 
07.
		echo"$gross"
08.
		echo"\" rel=\"lightbox[".$url."]\" onfocus=\"this.blur()\" title=\"\">"
09.
		echo"<img src=\""
10.
		echo"$verzeichnis$file"
11.
		echo"\" id=\"pic\" /></a>"
12.
		echo"\n"
13.
14.
15.
closeDir($ordner);
Zuerst dachte ich das es vielleicht eine maximale Bildanzahl gibt, und dann Darstellungsfehler entstehen können.
Jedoch passiert dies auch wenn ich weniger Bilder lade.

Ich bin am verzweifeln und hoffe mir kann jemand helfen bzw. eine Alternative Lösung anbieten.

Vielen Dank im Vorraus!

Mit freundlichen Grüßen

Michael
Mitglied: MaxTPayne
20.01.2010 um 20:51 Uhr
Falls jemand noch nach der Lösung des Problems sucht ist diese Recht einfach. Er baut den HTML String falsch zusammen was er aber auf der Webseite schon korrigiert hat.
So müsste der HTML Quelltext aussehen:
<a title="" onfocus="this.blur()" rel="lightbox[img]" href="pfad/zum/bild.jpg"><img id="pic" src="pfad/zum/thumbnail.jpg"></a>

Gruß
MaxTPayne
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...