Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

lighttpd url weiterleitung in bestimmten ordner...

Frage Internet Server

Mitglied: Gungel

Gungel (Level 1) - Jetzt verbinden

03.02.2009, aktualisiert 12:32 Uhr, 5134 Aufrufe

Hallo,
ich hoffe ich bin hier im richtigen unterforum und habe die eventuelle lösung für das problem nicht übersehen.

Folgendes Problem:

ich habe hier zuhause ein NAS von Fujitsu Siemens (SBLAN2 mit NExt extensions) auf diesem NAS läuft als webserver lighttpd desweiteren habe ich zwei domains von zwei unterschiedlichen dyndns anbietern domain1.dyndns.org und domain2.no-ip.org und zwei webseiten auf dem server. eine liegt im web root ordner und die andere in einem unterordner im webroot

die seite die probleme macht habe ich mit bitweaver cms erstellt

jetzt habe ich es schon geschafft mittels der lighttpd.conf meine domain2 in den unterordner zu leiten. die seite wird auch angezeigt aber ohne jegliche css formatierungen.

wie sollte jetzt die umleitung aussehen damit die cssdaten auch alle richtig erfasst werden? oder ist das eher ein problem des CMS

selbst wenn ich versuche das cms in diesem ordner neu zu installieren wird zwar in den install ordner weitergeleitet aber die installation läuft nicht an Fehlermeldung 404 - not found

also vermute ich ersteinmal einen fehler in der weiterleitung

die weiterleitung sieht so aus:

$HTTP["host"] =~ "^(domain2\.no-ip\.org oder de)$" {
url.rewrite-once = ( "^/(.*)$" => "/unterordner/$1" )
}

wie gesagt es wird in den richtigen ordner geleitet aber ebend ohne css und eine neuinstallation ist unter der domain nicht möglich

wenn ich aber domain1.dyndns.org/unterordner in den browser eingebe funktioniert alles.

ich möchte aber nicht das domain1 erkenntlich ist.

Ich hoffe ihr könnt mir helfen

Danke und beste Grüße
der Gung
Neuester Wissensbeitrag
Windows Update

Windows Update-Suche nach Win7 Neuinstallation wieder schneller

(2)

Erfahrungsbericht von the-buccaneer zum Thema Windows Update ...

Heiß diskutierte Inhalte
Exchange Server
Bestehende eMails autoamatisch weiterleiten (21)

Frage von metal-shot zum Thema Exchange Server ...

Hyper-V
gelöst Reiner Hyper- V Server oder lieber Rolle (21)

Frage von Winuser zum Thema Hyper-V ...

SAN, NAS, DAS
gelöst Synology Version 6.1 Probleme (18)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...

Router & Routing
gelöst IP Kamera für drei unabhängige Netzwerke (16)

Frage von ProfessorZ zum Thema Router & Routing ...