Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

LINBO mit Win7

Frage Linux

Mitglied: brainchild

brainchild (Level 1) - Jetzt verbinden

20.09.2011 um 14:42 Uhr, 6026 Aufrufe, 9 Kommentare

Hallo adminstrator.de Community,
seit kurzem hat eine Schule die ich betreue dazu entschieden openML zu nutzen (die Baden-Würtemberger Schullösung).

Nun stehe ich aber vor dem Problem die Win7 Rechner in dieses Netz zu integrieren.
Den diese wollen mit dem PXE-Boot nicht zurecht kommen. (LINBO)

Den wenn ich sie nach der Anleitung konfiguriere, d.h. mit der start.conf Datei Rechner ins Netz aufnehmen usw. bis hin zum Start durch LINBO funktioniert "alles"...
Den wenn ich es nun versuche zu starten bleibt der Rechner hängen mit der Meldung das er versucht die 4 CPUs auf maximale Leistung zu schalten (obwohl er nur 2 hat) und dann kann man nichts mehr in dem LINBO menü machen außer einem reboot mit strg + alt + entf.

Nun ist meine Frage kennt sich jemand mit dem System aus und weiß woran das liegt das es nicht funktioniert?
PS: WinXP Rechner hab ich erfolgreich zum laufen gebracht nur die Win7 Rechner wollen nicht so recht....

Hoffe jemand kann mir weiter Helfen.

Mit freundlichen Grüßen
Mitglied: danielfr
20.09.2011 um 15:02 Uhr
Hi, Du musst den Reboot Workaround benutzen, dazu ist er da. Siehe hier und folgende:
http://lml.support-netz.de/handbuch50/ch07s03s02.html
Ich habe es so konfiguriert, das bei Start v. Festplatte ein grub Menü kommt, das nach 3 sec Windows startet oder man kann auch Linbo wählen. Wenn man unter Linbo auf Start geht, bootet der Rechner neu...
Klingt erstmal komplizierter, funktioniert aber gut.
Gruß Daniel
Bitte warten ..
Mitglied: brainchild
20.09.2011 um 15:13 Uhr
Hey danielfr,

das mit dem Reboot Workaround hab ich bei XP gemacht und da funktioniert es auch einwandfrei.

Bei den Win7 Rechnern ist jedoch das Problem wie gesagt das wenn ich auf Start beim Linbo menü drücke das er alles schön macht mit dem Syncen usw. doch dann wenn er die Partition booten soll kommt die Meldung mit dem ganzen Parametern und dann von wegen
Setzte CPU1# auf maximale Leistung.
Setzte CPU2#....
...
Setzte CPU4# "

und dann bleibt er hängen.

Kannst du mir vielleicht genau schildern wie du deine Win7 Rechner zum laufen gebracht hast?
Bitte warten ..
Mitglied: danielfr
20.09.2011 um 17:35 Uhr
Das Problem hatte ich bisher nur mit Windows XP Rechnern, der einzige (Test-) Win7 ging ohne Reboot. Zeig mal Deine Konfigurationsdatei, vielleicht kann ich da was entdecken. Eigentlich ist Linbo nicht davon abhängig, ob Win 7, XP oder Ubuntu läuft. Das Problem kann auch eine anderes sein...
Bitte warten ..
Mitglied: brainchild
21.09.2011 um 11:11 Uhr
http://pastebin.com/0jh7qFkd = start.conf.dell2011
http://pastebin.com/t8WFaraF = pxelinux.cfg/datei

Ich weiß jetzt nicht was ich dir sonst noch schicken könnte was relevant wäre. denke das sind die wichtigsten.

Linbo müsste doch im allgemeinen schaffen die Partition zu starten auch wenn da nix drauf ist oder?
Bei mir hängt er sich da auch schon auf mit der oben genannten Meldungen.... sind ja nicht wirklich Fehlermeldungen.

Wie gesagt könnte ja daran liegen das er 4 CPUs erkennt anstatt den wirklich nur 2 vorhandenen? Obwohl er bei mir auch bei den WinXP Rechnern 2 CPUs erkennt obwohl die nur einen Pentium drin haben.
Bitte warten ..
Mitglied: danielfr
21.09.2011 um 13:03 Uhr
Hi,
am besten wäre es, wenn die beiden Dateien hier eingefügt werden. Falls jemand mal das gleiche Problem hat, kann er es besser nachvollziehen. Dafür gibts die code Tags...
OK. Das sind schonmal die richtigen. In der start.conf.win7 muss es
KERNEL = reboot
heissen. Sonst wird ja gleich grub geladen und das kracht...
(Handbuch S. 85).
Gruß Daniel
Bitte warten ..
Mitglied: brainchild
21.09.2011 um 13:34 Uhr
Ja aber du gehst jetzt davon aus das die Win7 Rechner mit dem reboot-workaround angeschlossen sind?

Dies sind die Conf files ohne dem Rebootworkaround da wird doch Standardmäßig die grub.exe verwendet oder irre ich mich da?

Wie sieht den deine start.conf für Win7 aus? Diese haben doch sogar ohne dem workaround funktioniert oder?
Bitte warten ..
Mitglied: danielfr
21.09.2011 um 15:12 Uhr
Ja aber du gehst jetzt davon aus das die Win7 Rechner mit dem reboot-workaround angeschlossen sind?
Natürlich, denn genau davon war die ganze Zeit die Rede, oder war das unklar?

Dies sind die Conf files ohne dem Rebootworkaround da wird doch Standardmäßig die grub.exe verwendet oder irre ich mich
da?
Das stimmt. Aber Deine pxelinux.cfg ist ja auch f. Reboot konfiguriert!

Wie sieht den deine start.conf für Win7 aus? Diese haben doch sogar ohne dem workaround funktioniert oder?
Das hat wie gesagt gar nichts mit Win7 XP oder was auch immer zu tun. Wenn es mit Linbo Probleme gibt sollte man den Reboot Workaround benutzen. Das habe ich jetzt ein paar mal geschrieben und sogar die Seite im Handbuch rausgesucht.
Ich hatte NOCH NIE ein Problem, wenn ich mich daran gehalten habe, sei es XP oder Linux (Win7 test lief auf der HW ohne Workaround, aber auch WinXP und Linux, Konfig habe ich plattgemacht).
Das Problem ist IMMER die Hardwareerkennung unter Linbo! Und nochmal, dazu gibt es dann den Reboot Workaround.
Lies Dir am besten nochmals das entsprechende Kapitel im Handbuch komplett durch, da wird alles genau erklärt.
Bitte warten ..
Mitglied: brainchild
23.09.2011 um 08:20 Uhr
Also wie gesagt hat das mit dem rebootworkaround nicht funktioniert weil die Rechner tortzallem dann hängen geblieben sind.

Abhilfe hat allerdings der zusätzliche Bootparameter "nosmp" gebracht, dieser sagt LINBO nämlich das er für sich nur 1 Kern verwenden soll und nicht die Multicoreprozessoren.

Jetzt booten die Rechner einwandfrei aus LINBO raus.
Bitte warten ..
Mitglied: danielfr
23.09.2011 um 10:05 Uhr
Zitat von brainchild:
Also wie gesagt hat das mit dem rebootworkaround nicht funktioniert weil die Rechner tortzallem dann hängen geblieben sind.
Sorry, das war mir nicht ganz klar.

Abhilfe hat allerdings der zusätzliche Bootparameter "nosmp" gebracht, dieser sagt LINBO nämlich das er
für sich nur 1 Kern verwenden soll und nicht die Multicoreprozessoren.

Jetzt booten die Rechner einwandfrei aus LINBO raus.
demnach ohne reboot? ist doch super.
wenns jetzt geht, dann setz den Beitrag doch auf erledigt, damit andere das auch gleich sehen...
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...