Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linker Problem in Visual Studio

Frage Entwicklung Visual Studio

Mitglied: Joesch

Joesch (Level 1) - Jetzt verbinden

25.05.2008 um 17:26 Uhr, 3713 Aufrufe

Hallo zusammen,

ich habe in ein C++ Visual Studio Projekt eine .lib Datei mit zugehörigen header dateien eingebunden. Die .lib Datei der Bibliothek habe ich nach Anleitung selbst für Visual Studio gebaut (C Quellcode). Problem ist nur, dass ich Linker Probleme habe und zwar in folgender Form:
"linalg.obj : error LNK2019: unresolved external symbol __imp__gan_mat_free referenced in function _wmain"
Die Funktion "gan_mat_free" ist auf jeden Fall im ursprünglichen C-Code enthalten. Irgendwie scheint was mit der .lib Datei nicht zu stimmen oder das Prefix "__imp__" wird falsch interpretiert.
Kennt jemand das Problem oder hat evtl. jemand eine Ahnung wie man das Problem beheben kann?
Der Pfad zur .lib-Datei ist auf jeden Fall in "Additional Library Directories" und die .lib selbst in "Additional Dependencies" eingetragen. Über "Additional Include Files" sind die header files referenziert. Sollte also alles passen.
Vielen Dank schonmal!

Gruß
Ähnliche Inhalte
Visual Studio
Visual Studio 2017 - Offline-Installationsdateien updaten (1)

Frage von Highend01 zum Thema Visual Studio ...

IDE & Editoren
gelöst Visual Studio 2017RC - Intellisense autocomplete? (2)

Frage von Highend01 zum Thema IDE & Editoren ...

Neue Wissensbeiträge
Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
VPN Tunnel aufbauen (15)

Frage von Hajo2006 zum Thema LAN, WAN, Wireless ...

Microsoft Office
Saubere HTML aus Word-Dokument (13)

Frage von peterpa zum Thema Microsoft Office ...

E-Mail
gelöst Probleme beim E-Mail Empfang (12)

Frage von TommyB83 zum Thema E-Mail ...

Microsoft
gelöst Subnetting: In welchem Subnetz befindet sich die IP? (12)

Frage von winler zum Thema Microsoft ...