Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux Laufwerkszuordnung FC - SCSI Devices, Internes Device, Mappingproblem

Frage Hardware SAN, NAS, DAS

Mitglied: uLtrA-sl

uLtrA-sl (Level 1) - Jetzt verbinden

05.10.2007, aktualisiert 17.12.2008, 5285 Aufrufe, 2 Kommentare

Hallo admins,


Evtl. kann mir jemand weiterhelfen und zwar habe ich folgendes Problem:

Server: Debian 4.0 Etch 2.6er
/sda Device 74,3GB SCSI
/dev/sda1 /


Nun habe ich eine Emulex LP8000 HBA-Karte an der ein Volume hängt, der sich kennzeichnet als /dev/sdb beim anschließen im Betrieb!
So sollte es natürlich sein.

Jetzt passiert allerdings folgendes beim Booten:
Beim booten markiert sich das externe SCSI Device vom SAN immer als sda und erst später wird meine interne Festplatte als sdb quasi erkannt.
Das Problem er bootet nicht, da er natürlich kein /dev/sda1 finden kann weil das ja auf meiner internen SCSI (74GB) Platte sein müsste.


Ich möchte das nicht so, bzw es funktioniert kein booten mit angeschlossenem SAN, da dieses SAN Volume immer als sda erkannt wird.
Ich bin mittlerweile verzweifelt, woanders beschrieb jemand man kann in der etc/fstab auch die mounts mithilfe der UUID's beschreiben. Aber ohne Erfolg.

Jemand empfohl mir
alias scsi_hostadapter1 lpfcdd
im modprobe zu adden, allerdings gibts bei mir kein lpfcdd sondern nur lpfc was aber auch nicht als "bindinghilfe" funktioniert.
Kenne mich mit diesen Dingen leider nicht gut aus.


Wie kann ich erzwingen das meine schöne interne Festplatte auch sda bleibt?

Warum ist das so schwierig, kämpfe schon länger mit diesem Problem, allerdings muss ich das diesmal zwingend lösen.


Schonmal jemand dieses Problem gehabt?


Danke & gruß
Jens
Mitglied: alexbela
17.12.2008 um 15:23 Uhr
Hallo Jens!
Habe genau das gleiche Problem... Linux (SLES10) mit SAN-Anschluss (lpfc)... Installation klappte soweit ganz gut, nur nach einem Reboot sind die Device-Namen durcheinandergeschmissen -> also das System nimmer startbar...

Hast du dazu schon eine Lösung gefunden?

mfg Alex
Bitte warten ..
Mitglied: uLtrA-sl
17.12.2008 um 18:44 Uhr
Hi Alex,

leider nein. Die Lösung habe ich nicht gefunden. Das ständige "wechseln" zwischen sda/sdb ist immer noch. Mein Workarround bei diesem System ist immer noch ein mehrfacher Reboot, wenn dieser die Platten falsch einließt. (Das ist wie Lotto, manchmal nimmt er die richtigen Laufwerksbezeichnungen, manchmal nicht)

Vielleicht hast du mehr Glück mit SLES und dem Support

Gruß Jens
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Linux
Rdesktop Linux Benutzername leer lassen (3)

Frage von opc123 zum Thema Linux ...

Batch & Shell
gelöst Linux Shell Mailanhang umbenennen (2)

Frage von Thekivi zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...