Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Linux (Mint Lisa) - NFS-Mount vom NAS funktioniert nicht

Frage Linux Linux Netzwerk

Mitglied: pi314

pi314 (Level 1) - Jetzt verbinden

07.04.2012, aktualisiert 10:41 Uhr, 11151 Aufrufe, 5 Kommentare, 1 Danke

Hallo miteinander,

wie man aus dem Titel entnehmen kann, habe ich Probleme beim Versuch ein NAS per NFS zu mounten.

mount -t nfs //192.168.1.99:/pi /media/nas/ -o rsize=262144,wsize=262144,timeo=14,intr 
mount.nfs: Failed to resolve server //192.168.1.99: Name or service not known
Das NAS ist erreichbar, die NFS-Konfiguration für den Ordner ist ebenfalls gesetzt.
ping 192.168.1.99 -c 4 
PING 192.168.1.99 (192.168.1.99) 56(84) bytes of data. 
64 bytes from 192.168.1.99: icmp_req=1 ttl=64 time=0.877 ms 
64 bytes from 192.168.1.99: icmp_req=2 ttl=64 time=0.776 ms 
64 bytes from 192.168.1.99: icmp_req=3 ttl=64 time=0.749 ms 
64 bytes from 192.168.1.99: icmp_req=4 ttl=64 time=0.760 ms 
 
--- 192.168.1.99 ping statistics --- 
4 packets transmitted, 4 received, 0% packet loss, time 3000ms 
rtt min/avg/max/mdev = 0.749/0.790/0.877/0.058 ms
Ein Mount per cifs funktioniert tadellos:
mount -t cifs //192.168.1.99/pi /media/nas/ -o user="",password="",file_mode=0700,dir_mode=0700,rw
Jemand eine Idee?

so long,
pi314
Mitglied: mak-xxl
07.04.2012 um 11:14 Uhr
Moin pi314,

wie sieht die /etc/hosts der NAS aus? Server, Box eingetragen?

Ein frohes Osterfest und freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: 64748
07.04.2012 um 11:19 Uhr
Hallo,

mir kommt dieser Pfad komisch vor:
//192.168.1.99:/pi /media/nas/ -o ....
kann es sein, dass der Doppelpunkt dort nicht hingehört? ---
es sollte wohl
192.168.1.99:/pi /media/nas ...... 
heißen

Markus

<Edit>ich muss mich korrigieren, der Doppelpunkt ist korrekt, aber die beiden // sind falsch</Edit>
Bitte warten ..
Mitglied: pi314
07.04.2012 um 13:09 Uhr
Hallo,

wie sieht die /etc/hosts der NAS aus? Server, Box eingetragen?
Ja, der Server ist hier eingetragen. Ein Ping auf den Hostnamen ist erfolgreich. Sollte aber keine Auswirkungen in diesem Fall haben, da ich ja extra direkt mit der IP-Adresse verbinden will, um ein Problem bei der Namensauflösung zu umgehen . Aber sie funktioniert.

es sollte wohl 192.168.1.99:/pi.. heißen
Ja, es wird..
mount -t nfs 192.168.1.99:/pi /media/nas/ -o rsize=262144,wsize=262144,timeo=14,intr 
mount.nfs: access denied by server while mounting 192.168.1.99:/pi
Er will mich also noch nicht drauflassen.
Hm, der Share-Ordner ist öffentlich, Username/Passwort wird also nicht benötigt.

Ein Mount-Versuch mit User/Pwd bringt auch erwartungsgemäß:
mount -t nfs 192.168.1.99:/pi /media/nas/ -o rsize=262144,wsize=262144,timeo=14,intr,user="",password="" 
mount.nfs: an incorrect mount option was specified
Das NAS ist hier aber richtig konfiguriert:
Hostname: * 
Berechtigung: beschreibbar 
OS Support: Unix / Linux 
ID Mapping: Stammkonto des Gastsystems hat vollen Zugriff auf diese Freigabe (root:root)
Was noch tun?

Dank und Gruß,
pi314
Bitte warten ..
Mitglied: aqui
07.04.2012 um 13:21 Uhr
In der /etc/hosts muss zwingend sowas wie :
192.168.1.99 nas.soho.intern nas nfs
stehen !
Ist das der Fall ?
Was steht denn in der /var/log/messages bzw. im Syslog des NAS ??
Diese Fehlermeldungen dort sollten doch schnell weiterhelfen ?!
Bitte warten ..
Mitglied: pi314
07.04.2012 um 14:26 Uhr
Thanks!

Hab' das Problem gefunden. Es lag zwar nicht an der etc/hosts, wie du gemeint hast, aber deine Anmerkung /var/log/messages hat mich dann auf die richtige Fährte gebracht. Nach erneutem Googeln fand ich dann den Befehl:
showmount -e 192.168.1.99 
Export list for 192.168.1.99: 
/raid0/data/pi     *
Wenn man nun den richtigen Pfad mounten will, klappt's auch
mount -t nfs 192.168.1.99:/raid0/data/pi /media/nas/ -o ...
Danke!
so long,
pi314
Bitte warten ..
Ähnliche Inhalte
Linux Desktop
Ubuntu NFS mount Problem mit Synology NAS
Frage von adminstLinux Desktop3 Kommentare

Hallo zusammen Ich möchte einen NFS Share auf einem Ubuntu Desktop von einem Synology NAS mounten. Gemountet wird der ...

Suse
Mounten eines NFS gemounteten Ordners
Frage von ClusterworkSuse5 Kommentare

Hallo, ich möchte mein Netzwerk von 2 Ebenen (Knoten + Master) auf 3 Ebenen umarrangieren, konkret möchte ich über ...

Suse
NFS Mount einer schon per NFS gemounteten Freigabe
Frage von OlibSylSuse1 Kommentar

Hallo, ich stehe hier vor einem kleinen Problem. Scenario ist folgendes: Ich habe einen Server (SLES 11) auf diesem ...

Linux
Linux Mint 17
gelöst Frage von bebo57Linux3 Kommentare

Habe probehalber Linux Mint installiert . Laptop ThinkPad T400 Auf der Tastatur sind die Tasten z und y vertauscht ...

Neue Wissensbeiträge
Mac OS X

MacOS wo ist die Tilde ?

Tipp von Alchimedes vor 10 StundenMac OS X1 Kommentar

Hallo, ich hab eine MacOS qwertz Keyboard auf US Layout umgestellt da die Sonderzeichen besser erreichbar sind. Leider fehlt ...

Datenschutz

Weitere Informationen zum Sicherheitsproblem BeA

Information von Penny.Cilin vor 17 StundenDatenschutz

Im folgenden ein weiterer Bericht über die Sicherheitsprobleme von Bea. Fataler Konstruktionsfehler im besonderen elektronischen Anwaltspostfach Gruss Penny

Windows 10

Systemdienste behalten nach Win10 inplace-Upgrade nicht die ggf. modifizierte Startart bei

Tipp von DerWoWusste vor 18 StundenWindows 103 Kommentare

Stellt Euch vor, Ihr habt ein Win10 System und modifiziert dort die Startart von Systemdiensten. Zum Beispiel wollt Ihr ...

Microsoft Office

Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei

Anleitung von SarekHL vor 22 StundenMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von fyrb38Windows 1018 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Microsoft Office
Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei
Anleitung von SarekHLMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...