Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Mit Linux-Router zwei Netzwerke verbinden - WIE?! Bitte Hilfe!

Frage Netzwerke Router & Routing

Mitglied: Wolff

Wolff (Level 1) - Jetzt verbinden

01.11.2004, aktualisiert 06.10.2005, 15053 Aufrufe, 19 Kommentare

Ich habe vor mit einem Linux-Router zwei Netzwerke zu verbinden, bekomme aber Probleme.

Aufbau:

Der Router besitzt zwei Netzwerkkarten
eth0: 172.20.0.16 netmask 255.255.255.0
eth1: 192.168.90.16 netmask 255.255.255.0

Nun sollen alle PCs im Netzwerk 172.20.0.* auf einen Exchange-Mailserver im Netzwerk 192.168.90.* zugreifen können.

Ich habe bereits folgende Routen auf dem Linux-Router angelegt:
Dest ### Gateway ### Interface
192.168.90.0 ### 0.0.0.0 ### eth1
172.20.0.0 ### 0.0.0.0 ### eth0

Vom Linux-Server kann ich PCs in beiden Netzwerken anpingen, bekomme aber nur einmal eine Antwort!

Wenn ich unter Windows 172.20.0.16 als Gateway einrichte kann ich das andere Netz nicht erreichen.

Kann mir jemand weiterhelfen?!
Mitglied: BartSimpson
01.11.2004 um 12:24 Uhr
es muss heisten:
Ziel GW IF
192.168.90.0 ### 192.168.90.16## eth1
172.20.0.0 ### 172.20.0.16 ##eth0
Bitte warten ..
Mitglied: linuxadmin
01.11.2004 um 13:37 Uhr
192.168.90.0 ### 192.168.90.16## eth1
172.20.0.0 ### 172.20.0.16 ##eth0

lokale Interfaces brauchen sich selbst nicht als GW.

versuch mal:

echo "1" > /proc/sys/net/ipv4/ip_forward
Bitte warten ..
Mitglied: Wolff
01.11.2004 um 13:52 Uhr
@ BartSimpson
Vielen Dank für die Antwort...hat mir aber leider nicht geholfen...

@linuxadmin
/proc/sys/net/ipv4/ip_forward enthält bereits "1"


mittlerweile kann ich auch den Ping ohne Probleme durchführen...habe den Linux-Server jetzt unter Windows als Gateway eingetragen und versuche dann mit "tracert" einen PC im zweiten Netz zu erreichen...leider komme ich nur bis zum Linux-Server...danach "Zeitüberschreitung"...auf dem Linux-Server finde ich in /var/log/messages folgende Einträge:

Nov 1 13:15:12 mail2 kernel: Packet log: input ACCEPT eth0 PROTO=1 172.20.6.19:8 192.168.90.3:0 L=92 S=0x00 I=46012 F=0x0000 T=2 (#9)
Nov 1 13:15:12 mail2 kernel: Packet log: forward DENY eth1 PROTO=1 172.20.6.19:8 192.168.90.3:0 L=92 S=0x00 I=46012 F=0x0000 T=1 (#4)
Nov 1 13:15:13 mail2 kernel: Packet log: input ACCEPT eth0 PROTO=6 172.20.6.19:1530 172.20.0.16:23 L=40 S=0x00 I=46013 F=0x4000 T=128 (#9)
Bitte warten ..
Mitglied: BartSimpson
01.11.2004 um 13:54 Uhr
simmt da hatte mich jezt nur die schreibweise gewundert.
Haste du iptables regeln definiert. Das würde mir jetzt noch einfallen.
Bitte warten ..
Mitglied: BartSimpson
01.11.2004 um 13:58 Uhr
Das deutet eindeutig auf iptables regeln hin.
Bitte warten ..
Mitglied: Wolff
01.11.2004 um 14:18 Uhr
iptables ist nicht installiert...
Bitte warten ..
Mitglied: BartSimpson
01.11.2004 um 14:33 Uhr
Dann must du aber eine andte firewall auf der kiste haben. Denn meldunf deutet eindeutig drauf hin , das packete gefiltert werden.
Bitte warten ..
Mitglied: Wolff
01.11.2004 um 14:58 Uhr
ich habe gerade nochmal geguckt...es ist ipchains installiert und dort ist auch ein Eintrag...nur wie bekomme ich den Eintrag gelöscht? Habe gerade mal unseren Support angerufen...die konnten mir nur sagen, unser Linux SuSE sei zu alt und ich könne keinen Support für ipchains erhalten...
Bitte warten ..
Mitglied: BartSimpson
01.11.2004 um 15:02 Uhr
Das stimmt ipchains wurde schon lange durch iptables ersetzt.
unter http://people.netfilter.org/~rusty/ipchains/
findes man noch die alte doku
Bitte warten ..
Mitglied: Wolff
02.11.2004 um 07:42 Uhr
Vielen Dank für die Anleitung...
ich habe jetzt ipchains mit folgenden Befehlen "deaktiviert":

ipchains -F
ipchains -X
ipchains -P input ACCEPT
ipchains -P output ACCEPT
ipchains -P forward ACCEPT

die SuSE-Firewall habe ich auch deaktiviert. Trotzdem habe ich immer noch den o.g. Fehler.
Bitte warten ..
Mitglied: BartSimpson
02.11.2004 um 08:44 Uhr
Und was sagt ipchains -L?
Bitte warten ..
Mitglied: Wolff
02.11.2004 um 09:21 Uhr
ipchains -L

steht alles auf ACCEPT
Bitte warten ..
Mitglied: BartSimpson
02.11.2004 um 09:33 Uhr
Und stehen jetzt keine Anderen reglen mehr drinn? Was steht jetzt in deiner logdtei?
Bitte warten ..
Mitglied: Wolff
02.11.2004 um 10:33 Uhr
die log-datei ist jetzt leer...gibt keine neuen Einträge...

habe den Linux-Server jetzt unter Windows als Gateway eingetragen und versuche dann mit "tracert" einen PC im zweiten Netz zu erreichen...leider komme ich nur bis zum Linux-Server...danach "Zeitüberschreitung"
Bitte warten ..
Mitglied: BartSimpson
02.11.2004 um 11:46 Uhr
Hast du bei dem anderen netz das entspechen gateway eingertagen? Denn sonnst kommen die pakcet nur i eine richtung.
Bitte warten ..
Mitglied: Wolff
02.11.2004 um 13:25 Uhr
Danke für den Tipp jetzt funktioniert es ohne Firewall.
Sobald ich aber die SuSE-Firewall wieder einschalte, geht es nicht mehr...

Welche Ports muss ich freischalten?

Sieht bei mir jetzt so aus:

FW_SERVICES_EXTERNAL_TCP="smtp domain echo http" # Common: smtp domain
FW_SERVICES_EXTERNAL_UDP="domain" # Common: domain
FW_SERVICES_EXTERNAL_IP="" # For VPN/Routing which END at the firewall!!
FW_SERVICES_DMZ_TCP="" # Common: smtp domain
FW_SERVICES_DMZ_UDP="" # Common: domain syslog
FW_SERVICES_DMZ_IP="" # For VPN/Routing which END at the firewall!!
FW_SERVICES_INTERNAL_TCP="139 445 smtp pop3 domain http telnet ftp echo" # Common: ssh smtp domain
FW_SERVICES_INTERNAL_UDP="domain syslog" # Common: domain syslog
FW_SERVICES_INTERNAL_IP="" # For VPN/Routing which END at the firewall!!
Bitte warten ..
Mitglied: BartSimpson
02.11.2004 um 15:02 Uhr
Es kommt dauf an, was der Router weiter leiten soll.
Aber keine Ahung wie man das bei Suse machen muss.,
Ich benutze nur Redhat und Fedora.
Bitte warten ..
Mitglied: Wolff
05.11.2004 um 08:40 Uhr
Mein Netz ist folgendermaßen aufgebaut:

Es gibt ein Netzwerk 172.20.x.x das über den Router ins Netzwerk 192.168.90.x kommt.
Im Netzwerk 192.168.90.x gibt es einen VPN-Server (192.168.90.1) und dahinter gibt es ein Netzwerk 192.168.x.x (vielleicht kann man ja aus der Skizze was erkennen...wenn der Zeilenumbruch funktioniert...ich kann die Skizze dann auch per Mail verschicken)
---------------
172.20.x.x - === ROUTER
- 192.168.90.x-
172.20.0.16 ---------------
192.168.90.16 ||
||
||
---------------- ---------------
-192.168.90.1 -
VPN
- 192.168.x.x -
---------------- ---------------

Mein meiner Konfiguration funktioniert fast alles.
Ich habe eine Route für Anfragen an 192.168.x.x nach 192.168.90.1 auf dem Router eingerichtet. Vom Router kann ich auch ohne Probleme alle PCs über die VPN-Verbindung (also z.b. 192.168.1.5) anpingen. Versuche ich aber ein "tracert" vom Windows-Client, so geht dieser bis 192.168.90.1 und nicht weiter. Ein Ping an 192.168.1.5 geht auch nicht. Ich kann aber über den Windows-PC alle PCs mit der IP 192.168.90.x erreichen.

Kann mir jemand weiterhelfen?
Bitte warten ..
Mitglied: 15187
06.10.2005 um 20:19 Uhr
da kommt nix...
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
LAN, WAN, Wireless
Zwei private Netzwerke (LAN und WLAN) mit SXT Lite5 verbinden (9)

Frage von MWelslau zum Thema LAN, WAN, Wireless ...

Linux Netzwerk
OpenVPN, zwei OpenWRT Router verbinden und VLAN durchs VPN leiten (6)

Frage von sharbich zum Thema Linux Netzwerk ...

Router & Routing
gelöst Zwei Netzwerke in einem Haus verbinden, Hardwarevorschlag (10)

Frage von KotyrbaSe zum Thema Router & Routing ...

LAN, WAN, Wireless
Zwei Netzwerke per Richtfunk verbinden (49)

Frage von jimb0p zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...