Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux - SSL Problem - Port 443 wird nicht geöffnet

Frage Linux Apache Server

Mitglied: tappo1

tappo1 (Level 1) - Jetzt verbinden

09.11.2012, aktualisiert 13:18 Uhr, 2780 Aufrufe, 7 Kommentare

Hallo,

ich habe ein SSL Zertifikat auf meinen Server eingerichtet. Dabei kommt es zu einem sehr merkwürdigen Fehler. Anhand der Logfiles etc. läuft alles korrekt - jedoch bekomme ich ein Verbindungsabbruch wenn ich via https://domain.tld versuche die
Webseite anzusprechen. Folgende Dinge wurden geprüft:

-> Syslog -> keine Meldung
-> Messages -> keine Meldung
-> Apache error.log -> keine Meldung
SSL-Engine Log (debugg Modus) -> Keine Meldung - es wurde mit einer info bestätigt das alles korrekt läuft:
09/Nov/2012 12:13:53 32006] [info] Init: Configuring server domain.tld:443 for SSL protocol
-> Die IP ist auch auf dem Server hinterlegt und die Domain verweist auch auf diese.
-> Ein Fehler in der http conf ist nicht vorhanden, die Ausgabe von "/bin/httpd -S" gibt nämlich alles korrekt wieder und bringt keine Fehlermeldungen:
xxx.xxx.xxx.xxx:443 domain.tld ( ...conf/httpd.conf:433)
-> Über "tcpdump host meineip" erkenne ich, dass eine Verbindung zum Server vorhanden ist auch wenn ein "Fehler: Verbindung fehlgeschlagen" kommt.
-> ssldump bringt keine Ergebnisse
-> netstat -an | grep 443 bringt kein Ergebnis und dort liegt wohl auch der Knackpunkt - denn wenn er nicht auf 443 lauscht kann der Apache es nicht verarbeiten
Aber warum ist das ? Wo kann ich da schauen ? Das Problem scheint ja am Apache zu liegen da er den Port nicht öffnet und dieser somit nicht lauscht.
-> kein xinetd
-> keine firewall (iptables o.Ä)
-> httpd -S gibt alles korrekt an (siehe zeile oben)

Ich habe leider keine Idee mehr Fällt euch etwas ein oder hatte ggfs. jemand schon solche Probleme?
Mitglied: Hitman4021
09.11.2012 um 13:22 Uhr
Hallo,

auf welche Ports ist dein Apache den konfiguriert?
01.
Listen 443
was bringt telnet auf die IP-Adresse des Servers?

Gruß
Bitte warten ..
Mitglied: tappo1
09.11.2012, aktualisiert um 13:43 Uhr
Hallo,

Apache läuft grundsätzlich über den Port 80 - was auch funktioniert. Nun wollte ich ein SSL einspielen und dies läuft standardmäßig über 443 - also wurde es auch so von mir in der Virtualhost verankert. Folgender Zeile kann man auch entnehmen das der Apache dies korrekt verarbeitet:

xxx.xxx.xxx.xxx:443 domain.tld ( ...conf/httpd.conf:433)

Wie meinst Du ein Telnet ? Da über netstat schon zu erkennen ist, dass der Port 443 nicht offen ist wird dies wohl kein Resultat erbringen !

telnet xxx.xxx.xxx.xxx 443
Trying xxx.xxx.xxx.xxx...
telnet: Unable to connect to remote host: Connection refused

telnet xxx.xxx.xxx.xxx 80
Trying xxx.xxx.xxx.xxx...
Connected to xxx.xxx.xxx.xxx

Beste Grüße !
Bitte warten ..
Mitglied: Epixc0re
09.11.2012 um 13:53 Uhr
Hallo,

versuch das mal:
01.
Listen *:443 
02.
<VirtualHost *:443> 
03.
ServerName blabla.com 
04.
</VirtualHost>
Grüße,
Stefan
Bitte warten ..
Mitglied: tappo1
09.11.2012, aktualisiert um 14:22 Uhr
Hallo,

es ist ein laufendes System mit weit über 200 Domains. Da kann ich leider nicht einfach Sachen ausprobieren die ggfs. zu Fehlern oder Ausfällen führen. Des weiteren erkenne ich den Sinn davon nicht ? Es wurde doch schon ein Virtuel-Host von mir erstellt der korrekt vom Apache interpretiert wurde, ein zweiter mit ner Wildcard bringt mir ? Wenn Du mir kurz näher bringen könntest was die Absicht dahinter ist.

Ein Fehler in der http conf ist nicht vorhanden, die Ausgabe von "/bin/httpd -S" gibt nämlich alles korrekt wieder und bringt keine Fehlermeldungen:
xxx.xxx.xxx.xxx:443 domain.tld ( ...conf/httpd.conf:433)

Dennoch Danke,
Beste Grüße
Bitte warten ..
Mitglied: Hitman4021
09.11.2012 um 15:15 Uhr
Mit der von mir genannten Listen option sagst du apache das er auch auf diesen Port hören soll. Du kannst in deinem vhost jeden Port angeben den du willst und er wird den in das Log schreiben.

Schreib einfach die von mir genannte option mal in deine httpd.conf

Gruß
Bitte warten ..
Mitglied: tappo1
09.11.2012 um 15:31 Uhr
Hallo Hitman,

bitte schreibe mir doch deine RL Daten via PM - ich würde Dich gerne heiraten ;)
Nu läuft alles, dass es so ein dämlicher Fehler war..... unglaublich.....

Danke !
Bitte warten ..
Mitglied: Epixc0re
12.11.2012 um 23:21 Uhr
Wenns das war, dann bitte http://www.administrator.de/faq/32
nicht vergessen.
Bitte warten ..
Ähnliche Inhalte
Verschlüsselung & Zertifikate
Linux - SSL Private Key absichern (5)

Frage von atomique zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst SSL für WSUS läuft unter Server 2016 nicht (7)

Frage von Raynor zum Thema Windows Server ...

Ubuntu
SSL Zertifikat für Webmin (2)

Frage von ClepToManix zum Thema Ubuntu ...

Windows Server
gelöst Neue Windows Domain im gleichen Netzwerk und Exchange SSL Port ändern Thema Smartphone (12)

Frage von zeroblue2005 zum Thema Windows Server ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Server
Bilder aus dem Web mit CSV runterladen (30)

Frage von Yannosch zum Thema Server ...

Server-Hardware
Bestehendes Raid erweitern um 4 gleiche Platten! (Verständnis Fragen) (12)

Frage von Hendrik2586 zum Thema Server-Hardware ...

Windows Update
WSUS 4 (Server 2012 R2) - Windows 10 Updates nicht möglich (12)

Frage von c0d3.r3d zum Thema Windows Update ...