Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux keine Verbindung zwischen TAP und TUN Devices

Frage Linux Linux Netzwerk

Mitglied: urpils666

urpils666 (Level 1) - Jetzt verbinden

17.07.2013 um 13:23 Uhr, 2008 Aufrufe, 5 Kommentare, 1 Danke

Hallo,
ich bin zwar kein Linux-Anfänger mehr, aber ich kriege auf meinem vServer keine Verbindung zwischen TAP und TUN Devices hin.

Meine Situation:
Ich habe einen vServer gemietet. Dieser baut mittels Shrew VPN Verbindungen zu 4 Fritzboxen auf und erstellt für jede Verbindung ein TAP-Device. Zusätzlich stellt er mittels OpenVPN die Verbindung zu Clients zur Verfügung. Dafür nutze ich ein TUN-Device. Die Verbindungen vom Server zu den einzelnen Gegenstellen funktionieren tadellos. Ich habe auch schon IP Forwarding aktiviert. Von der Einrichtung einer Netzwerkbrücke habe ich bis jetzt Abstand genommen, da hierfür das phys. Interface benutzt werden muß. Da es das einzige Beinchen ist und ich nicht den Ast absägen will, auf dem ich sitze.

Ziel ist es, von einem OpenVPN Client Zugriff über den vServer auf die hinter den Fritzboxen liegenden Netzen zu bekommen.

Woran kann es liegen? Habt ihr Ideen?

P.S. Ich weiß, was TAP- und TUN-Devices sind.
Mitglied: aqui
17.07.2013, aktualisiert um 13:53 Uhr
  • Open VPN funktioniert soweit problemlos ? (Grundlagen erklärt dieses Tutorial )
  • Können OVPN Client den Server pingen ?
  • Benutzt du iptables ? Wenn ja hast du das Forwarding angepasst ?
  • Wie sieht deine Routing Tabelle aus bei aktiven TUN und TAP Interfaces also aktiven Tunnels ?
  • Was sagt ein traceroute vom Client ?
Bitte warten ..
Mitglied: urpils666
17.07.2013 um 14:14 Uhr
Ja, OpenVPN funktioniert. Über den Tunnel sind sowohl Server als auch Client erreichbar.
Iptables sind im Einsatz und Forwarding wurde aktiviert.

Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
0.0.0.0 xxxxxxxxxxxxxx 0.0.0.0 UG 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
172.27.1.0 172.27.1.2 255.255.255.0 UG 0 0 0 tun0
172.27.1.2 0.0.0.0 255.255.255.255 UH 0 0 0 tun0
192.168.3.0 192.168.3.200 255.255.255.0 UG 0 0 0 tap1
192.168.3.0 0.0.0.0 255.255.255.0 U 0 0 0 tap1
192.168.11.0 192.168.11.200 255.255.255.0 UG 0 0 0 tap2
192.168.11.0 0.0.0.0 255.255.255.0 U 0 0 0 tap2
192.168.14.0 192.168.14.200 255.255.255.0 UG 0 0 0 tap0
192.168.14.0 0.0.0.0 255.255.255.0 U 0 0 0 tap0
192.168.21.0 192.168.21.200 255.255.255.0 UG 0 0 0 tap3
192.168.21.0 0.0.0.0 255.255.255.0 U 0 0 0 tap3

C:\>tracert 192.168.3.250

Routenverfolgung zu 192.168.3.250 über maximal 30 Abschnitte

1 45 ms 78 ms 65 ms 172.27.1.1
2 172.27.1.1 meldet: Zielhost nicht erreichbar.

Ablaufverfolgung beendet.
Bitte warten ..
Mitglied: aqui
17.07.2013, aktualisiert um 16:18 Uhr
Mit Forwarding meinst du da das IP Forwarding im System (Server) ??
Also sudo nano /etc/sysctl.conf und dort die Variable net.ipv4.ip_forward=1 entkommentieren.
Oft ist auch noch ein sudo echo 1 > /proc/sys/net/ipv4/ip_forward vonnöten (Beispiel Debian/Ubuntu)
Der Netzwerk Stack muss dann reloaded werden !
Vermutlich ist das aber schon geschehen ?! Das ist essentiell sonst routet der Server nicht !
Wenn du per SSH am Server angemeldet bist oder als OVPN Client kannst du ALLE IP Interfaces des Servers anpingen ?
Ansonsten sieht die Routing Tabelle OK aus. Das 172.27.1er Netz ist das interne OVPN Netz, richtig ? die .1 dann die interne Server IP.
Kannst du diese OVPN Server IP aus einem der IPsec Netze anpingen ?

Was die OVPN Clients anbetrifft hast du alle IPsec Netze 192.168.3, .11, .14 und .21 mit dem "push route..." Kommando in der OVPN Server Konfig an die Clients distribuiert ?
Hier wäre mal ein "route print" Output sinnvoll sofern es Winblows Clients sind.
Irgendwie fehlen dem OVPN Server die Routen in die IPsec VPNs, sei es das die iptables da zuschlagen oder er die Routen nicht erkennt...
Bitte warten ..
Mitglied: kn0rki
20.07.2013 um 17:19 Uhr
Denk daran die Routen für den Rückweg eines Paketes hinzuzufügen. Sprich auf alle deiner 4 Fritzboxen muss ein Routing für das Open VPN Netz eingetragen werden.
Bitte warten ..
Mitglied: aqui
20.07.2013 um 20:11 Uhr
@kn0rki
Jein....! Die internen IPsec Netze terminieren ja direkt an der Fritzbox. Die FB "kennt" somit alle IPsec Netze die direkt an ihr angeschlossen sind.
Das einzige Netz was sie NICHT kennt ist logischerweise das OVPN Netz und da hast du Recht, das muss zwingend statisch als Route via VPN Tunnel der FB in den remoten Fritzboxen nachgetragen werden !
Die AVM Seite sagt wie:
http://www.avm.de/de/Service/Service-Portale/Service-Portal/VPN_Praxis_ ...
bzw. unter "Praxis & Tips".

Zusätzlich muss der OVPN Server natürlich alle diese lokalen LAN Netze an den FritzBoxen mit dem push Kommando in der Server Konfig an die Clients senden. Auch da hast du Recht.
Das der Server im Kernel IPv4 Forwarding aktiviert haben muss und der Netzwerk Stack neu gestartet werden muss ist selbstverständlich und hat der TO (hoffentlich) ja auch gemacht ?

Ob er auch die fehlenden Routen entsprechend eingetragen hat er hier noch nicht gepostet ?!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
gelöst VPN-Verbindung zwischen zwei Fritzboxen bricht sehr häufig ab (14)

Frage von mabue88 zum Thema Router & Routing ...

SAN, NAS, DAS
gelöst Verbindung zwischen Windows2012 R2 und Fujitus Storage DX 60 via FC (3)

Frage von goaknecht zum Thema SAN, NAS, DAS ...

Router & Routing
gelöst Bekomme keine Verbindung zwischen zwei Bintec Routern hin (7)

Frage von DJBreezer zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...