Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linuxrechner als router

Frage Linux Linux Netzwerk

Mitglied: NoRm

NoRm (Level 1) - Jetzt verbinden

05.10.2005, aktualisiert 07.10.2005, 5926 Aufrufe, 16 Kommentare

Guten Tag,

ich habe folgendes Problem:
Ich habe drei Rechner zu Verfügung, 2 Windowsrechner und ein Linuxrechner, in diesem fall soll der Linuxrechner als Router fungieren.Im Linuxrechner sind zwei Netzwerkkarten vorhanden, die ich wie folgt Konfiguriert habe.

eth0
192.168.0.1
255.255.255.0

eth1
192.178.0.1
255.255.255.0

Client I(windowsrechner1) --> eth0
192.168.0.2
255.255.255
192.168.0.1 -> Gateway
192.168.0.1 -> DNS

Client II(Windowsrechner 2) --> eth1
192.178.0.3
255.255.255.0
192.178.0.1 -->Gateway
192.178.0.1 --> DNS

also den Linuxrechner kann ich von beiden Rechner anpingen und halt vom Linuxrechner zu den beiden Clients!!!Nur zwischen den Clients kann ich nicht Pingen, da sagt er mir andauernd Zeitüberschreitung!!!Verwende Linux SuSe 9.3 und auf den Clients jeweils WIndows XP!!!
Ich bitte um Hilfe.
Mitglied: madcookie99
05.10.2005 um 14:40 Uhr
hi
routing tables geschrieben?

sonst weis die eine seite nix von der anderen


http://www.ora.de/german/freebooks/linux_netz/

gruß
Bitte warten ..
Mitglied: Welnex
05.10.2005 um 14:53 Uhr
Hi,

hast Du eine Bridge konfiguriert, dass die beiden Netzwerkkarten in der Linuxkiste überhaupt eine Verbindung haben?

Gruß
Steffen
Bitte warten ..
Mitglied: NoRm
05.10.2005 um 15:03 Uhr
Bridge??? Beschäftige mich noch nicht all zu lang mit Linux?!kannst du das näher erläutern?
Bitte warten ..
Mitglied: NoRm
05.10.2005 um 15:08 Uhr
Routing tables??? Habe ich nicht,wofür sind du zuständig bzw was für eine bewandnis haben diese??
Bitte warten ..
Mitglied: Welnex
05.10.2005 um 15:09 Uhr
Also, meines Wissens nach muss eine Verbindung zwischen den beiden Netzwerkkarten geschafffen werden, damit sie kommunizieren können. Diese Verbindung nennt man Bridge.

Da ich nicht weiss, ob Du über Konsole oder GUI arbeitest und erst recht nicht weiss welches Derivat kann ich Dir im Moment nicht weiterhelfen. Aber google ist wie fast immer Dein Freund.

Viel Erfolg
Bitte warten ..
Mitglied: madcookie99
05.10.2005 um 15:26 Uhr
also, in den routing tabels kommen die netzwerke rein.

wenn eine anfrage an eine ip kommt die für ein anderes netzwerk ist schickt der router sie in das andere netz.

mit cat /proc/net/route kann man sie sich anzeigen lassen


od. nur route eingeben dann kommen die netze. jedenfalls sollten sie da stehen


http://www.administrator.de/routing_%FCber_mehrere_netze.html
Bitte warten ..
Mitglied: NoRm
05.10.2005 um 16:03 Uhr
hm..gut aber danke..i werd mal schauen.....
Bitte warten ..
Mitglied: NoRm
05.10.2005 um 16:14 Uhr
ziel router Genmask USe Iface
192.178.0.0 * 255.255.255.0 0 eht0
192.168.0. 0 * 255.255.255.0 0 eht1
link local * 255.255.0.0 0 eth0
loopback * 255.0.0.0 0 lo
Bitte warten ..
Mitglied: Guenni
05.10.2005 um 20:24 Uhr
@NoRm

Hi,

Mit folg. Befehl an der Konsole des Linux aktiviert man Routing:

echo 1 > /proc/sys/net/ipv4/ip_forward

Etwas zu deiner IP-Adressenwahl: Normalerweise benutzt man im privaten Bereich
Adressen im Bereich von 192.168.0.0 bis 192.168.255.255.

Siehe dazu z.B. --> http://www.lrz-muenchen.de/fragen/faq/netz35/

Ist jetzt zwar in deinem Fall im Moment kein Problem(Fehler), da die Verbindung
zwischen Server und Clients ja zu funkt. scheint, wollte ich nur mal erwähnt haben.

Gruß
Günni
Bitte warten ..
Mitglied: NoRm
06.10.2005 um 07:54 Uhr
Danke für die schnelle hilfe aber diesen BEfehl habe ich schon eingegeben inner Konsole. Macht er aber trotzdem noch nicht. Bitte um weitere Hilfe.
Bitte warten ..
Mitglied: NoRm
06.10.2005 um 08:33 Uhr
ja na kannst mir mal bitte den befehl für die console geben.....habe schonunterschiedliche Befehle gefunden wie zum Beispiel brctl aber den findet er nciht und ich bin auch als root angemeldet..::!!!
Bitte warten ..
Mitglied: NoRm
06.10.2005 um 10:28 Uhr
Gut danke leute....hab es nun geschafft die clients gegenseitig anzupingen!!!Sprich der linux rechner routet jetzt...aber danke für eure hilfe
Bitte warten ..
Mitglied: 15187
06.10.2005 um 11:55 Uhr
Hab fast das gleiche Problem wie Du.
Kannst Du mir mal schreiben, wie Du das hinbekommen hast?

Ich habe Suse 9.3 drauf und Internet-Access per Funk-LAN mit fester IP und 255.255.255.128er Subnet.
Hab der Karte die Adresse zugeteilt und sämtliche Einstellungen wie DNS-Server, Gateway vorgenommen (in meinem Fall muss ich als GW 192.168.1.1 eintragen).

Das seltsame bei mir: ich kann von meinem linux-router aus die 192.168.1.1 anpingen, musste aber neben meiner festen IP auch noch eine IP 192.168.1.2 mit subnetz 255.255.255.0 eintragen, damit er überhaupt in dieses Netz kommt, sprich: er die 192.168.1.1 anpingen kann.

So, nun bin ich also mit dem pingen schon bei meinem provider. Das wars dann aber auch schon. Surfen ist nicht möglich.

Woran liegts? Firewall? Ist nach bestem Wissen eingestellt, d.h. die externe NIC hat als FW-Einstellung "externe Zone" mit geöffnetem Port 80 (wieso muss das eingetragen werden?? externe Zone macht ALLE Ports dicht, was soll der Unsinn? Dann kann ich auch die Karte ausbauen oder das Kabel abschneiden!).
Ich habs auch schon ohne FW versucht, also die FW komplett heruntergefahren. Pingen geht, nach wie vor, Surfen aber nicht (wohlgemerkt: direkt vom Router aus, welcher ja pingen kann!!)

Wer hat Ideen, ich bin mit meinen Linux-Grundkenntnissen jetzt am Ende. Ich hab sämtliche Foren zu Routing und FW und Suse 9.3 und Mac-adresse durch (letztere ist wichtig für den Zugang beim Provider, damit nicht jeder andere Kunde mit meiner IP und somit auf meine Kosten surfen kann).

gruß
turbocyclone
Bitte warten ..
Mitglied: NoRm
06.10.2005 um 13:18 Uhr
hm...so recht kann ich dir auch net weiter helfen aber hier hab ich nen nützlichen link...ich denke mal der könnte dir weiter helfen

http://www.linux-club.de/viewtopic.php?t=13317
Bitte warten ..
Mitglied: 15187
06.10.2005 um 19:00 Uhr
@NoRm: danke, hab ich schon gelesen, es gibt (glaub ich fast) keine deutschsprachige anleitung mehr über dieses "einfache routing", die ich noch nicht gelesen habe. dennoch klappt es damit nicht.

es geht bei mir nur mit manuell erstellter routing-tabelle, welche soeben ihren dienst angetreten hat.

jetzt komm ich schon mit meinem router ins internet, welch wunder der natur

was mir jetzt noch fehlt, ist der korrekte eintrag, damit auch das 192er netzwerk geroutet wird.

wieso ich zum surfen eine komplette routing-tabelle aufstellen muss, weiß ich echt nicht... was ich aber weiß, ist, dass die routing-tabelle, die man mit yast2 aufstellt, nicht wirkt.

ich hab sie also mit "route" erstellt

mein problem sieht demnach so aus:
http://privat.newcon.de/erik/netzwerk/netzwerkproblem.png

und meine routingtabelle sieht bis jetzt so aus:
http://privat.newcon.de/erik/netzwerk/routing.txt

eigentlich würde ich nach meinem verständnis die route so eintragen:

route add -net 192.168.0.0 gw JAKEINEAHNUNG-192.168.0.1 oder 0.0.0.0?? dev eth1

die ergebnisse beim versuch JAKEINEAHNUNG funktionieren aber beide nicht
kann mir jemand einen tipp geben? ich glaub, ich hab alles probiert, was mir logisch erschien...

gruß,
turbocyclone

ps: wenn das läuft, geht's weiter mit vpn-zugang von außen wer hat die ersten tipps?
wenn möglich, ohne zertifikate, also kein L2TP, sondern nur PPTP
Bitte warten ..
Mitglied: NoRm
07.10.2005 um 07:59 Uhr
hm.....das inner console add ip ist eine Möglichkeit. Aber wenn du unter yast2 netzwerkgeräte/Netzwerkarte/ gehst und dann auf das Routing das gibs eine Experteneinstellung und da fügst du als ZielIP den Client dazu sowie sein Gateway und Netzmask......also bei mir ging es denn dadurch....zur not deaktivierst du solange die Firewall.
Und probierst das denn. Bei mir hat Linux auch ne kleine macke gehabt. Bei mir war die Firewall deaktiviert und ich konnt von den Clients den Router nicht anpingen so hab ich die Firewall ein mal aktiviert und danach gleich deaktiviert und siehe da das Problem war gelöst warum auch immer.......
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...