Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Lm-sensors-Werte nicht korrekt?

Frage Linux

Mitglied: Pixel-IT

Pixel-IT (Level 1) - Jetzt verbinden

17.05.2010 um 21:59 Uhr, 5040 Aufrufe, 2 Kommentare

Hallo,

ich habe einen Miniserver gebaut. Diese besteht aus einem passiv gekühlten VIA Epia M10000G unter SuSe 11.2 mit Apache und Samba.

Ich will auf einer Seite Werte zum aktuellen Status des Servers anzeigen. Hierzu will ich lm_sensors verwenden. Doch die Ausgabe ist sehr "erschreckend":

Beteigeuze:/ # sensors
vt1211-isa-6000
Adapter: ISA adapter
in0: +1.95 V (min = +0.00 V, max = +2.63 V)
in1: +1.98 V (min = +0.00 V, max = +2.63 V)
in2: +1.39 V (min = +0.00 V, max = +2.63 V)
in3: +1.98 V (min = +0.00 V, max = +2.63 V)
in4: +2.16 V (min = +0.00 V, max = +2.63 V)
+3.3V: +3.33 V (min = +0.00 V, max = +4.18 V)
fan1: 0 RPM (min = 0 RPM, div = 2)
fan2: 0 RPM (min = 0 RPM, div = 2)
temp1: +117.0°C (high = +255.0°C, hyst = +0.0°C)
SIO Temp: +53.0°C (high = +204.0°C, hyst = +0.0°C)
cpu0_vid: +1.750 V

Soll ich die 112 rufen? Oder so kann ich den Fehler finden? Ich tippe auf eine falsche Konfig, aber ich weiß nicht, wo ich da schrauben muss um den Sensor korrekt abzufragen. 117°C find ich persönlich dann doch sehr höllisch... ;)

Danke und viele Grüße,

Peter
Mitglied: SamvanRatt
18.05.2010 um 10:40 Uhr
Hi
da liest lm die Daten halt roh aus, sprich keine Hysterese und keinen Teilfaktor. Das ist jedem BIOS Hersteller selbst überlassen. Am einfachsten ist das mit realen Werten zu ermitteln (Kältespray, bzw Umgebungstemperatur) um zu sehen ob du eine Hysterese drinnen hast, bzw ob du nicht einen Teilfaktor (du nimmst zwei Temp Punkte und kannst dann ähnlich Kelvin die Absolutpunkte ermitteln), bzw einen Startwert abziehen mußt. Die meisten haben typ einen Wert von 0° (=keine Hysterese) und einen Teilwert von zwei um von 0-127,5°C darstellen zu können. Bei meinem EPIA PX ist das zumindest so und 90° im Betrieb ist bei den Via's nichts ungewöhnliches, insbesondere wenn sie nur passiv betrieben werden (die CPU ist ja nicht der Hauptverbraucher).
Gruß
Sam
Bitte warten ..
Mitglied: Pixel-IT
18.05.2010 um 14:22 Uhr
Habe das jetzt gemacht. Bin mit Hilfe von VIA auf folgende Zeile gekommen:

compute temp1 (@*@*0.0046) - (@*0.088) - 0.748, (@*0.9686) + 65

jetzt sehen meine Ergebnisse so aus:

Beteigeuze:/ # sensors | sed 's/Â/ /g'
vt1211-isa-6000
Adapter: ISA adapter
in0: +1.95 V (min = +0.00 V, max = +2.63 V)
in1: +1.98 V (min = +0.00 V, max = +2.63 V)
in2: +1.39 V (min = +0.00 V, max = +2.63 V)
in3: +1.98 V (min = +0.00 V, max = +2.63 V)
in4: +2.16 V (min = +0.00 V, max = +2.63 V)
+3.3V: +3.33 V (min = +0.00 V, max = +4.18 V)
fan1: 0 RPM (min = 0 RPM, div = 2)
fan2: 0 RPM (min = 0 RPM, div = 2)
CPU Temp: +51.9 °C (high = +68.9 °C, hyst = -0.7 °C)
SIO Temp: +53.0 °C (high = +75.0 °C, hyst = +0.0 °C)
cpu0_vid: +1.750 V

Besser ist das...
Bitte warten ..
Ähnliche Inhalte
Datenbanken
gelöst MYSQL Abfrage Werte summieren (3)

Frage von Ghost108 zum Thema Datenbanken ...

Microsoft Office
Excel Zählewenn aus Formel Wert (2)

Frage von cberndt zum Thema Microsoft Office ...

Windows Server
gelöst SCCM2012 Abfrage eines Registry Wertes (5)

Frage von busteron zum Thema Windows Server ...

Batch & Shell
XML nach Liste mit Werten durchsuchen (12)

Frage von bocker zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
CNC Maschinen verlieren Netzwerkverbindung (kurioser Fehler) (22)

Frage von NoHopeNoFear zum Thema LAN, WAN, Wireless ...

Webentwicklung
Aktuellen Mitarbeiter auf Homepage anzeigen (13)

Frage von alemanne21 zum Thema Webentwicklung ...

Festplatten, SSD, Raid
Raid-Controller (Areca) Datenverlust trotz R5 (11)

Frage von sebastian2608 zum Thema Festplatten, SSD, Raid ...

Windows Server
gelöst Parameter Übergabe Terminal Server (9)

Frage von ThomasKern zum Thema Windows Server ...